Post by alaskaberries » Sat Nov 23, 2013 1:38 am

Something strange occurred that I need some help figuring out. We have used Opencart as our online store for the past 1.5 years with no issues whatsoever. Since we are a seasonal business, I placed our store in maintenance mode in early November of this year. Prior to that, sometime in August 2013, I had disabled all remaining inventory so no one could place any orders at all.
Last week I performed an upgrade from 1.5.4.1 to 1.5.6. I also upgraded vqmod. No problems or issues with upgrades.
As I started to work on entering new products for the next season, I saw a transaction on my dashboard that was dated Nov 6th 2013. It gave it a new Order ID and Invoice number. It stated the order was complete and the transaction payment was thru paypal. I had not received the standard notification email.
When I researched the transaction thru paypal by the date of transaction, no record of it existed. When I researched it by the last name of the customer, it showed the statement was from June 2013 and completed successfully.
Now I was baffled so I called the customer to see if anything had changed on their end. They confirmed that the transaction had occurred back in June and all was well. They were not having any paypal or other issues.

So my dilemma is this. I have upgraded and am right at the point of reopening my store for the holiday season and do not want to until I can find out why this old transaction was reposted to my admin dashboard as a new transaction. Does anyone have any ideas on what may have occurrred? What must I do now?
Like I stated earlier, I have had zero issues with OC until now so am baffled. Any help would be greatly appreciated.

User avatar
New member

Posts

Joined
Sun Nov 27, 2011 12:31 am

Post by butte » Sat Nov 23, 2013 12:57 pm

Upgrading an ongoing shop to any .0 version (such as 1.5.6.0) before the first .1 bug-fix is released (just as 1.5.6.1 is not yet out) is hazardous. The install script of 1.5.6.0 has known workarounds or fixes to the script itself. If you still have your original 1.5.4.1, and can just start all over, again, then you can consider two other solutions.

See 1.5.4.1 CE RC1 and 1.5.5.1 CE RC1 at
http://forum.opencart.com/viewtopic.php ... 82#p444959
and practicalities at
http://forum.opencart.com/viewtopic.php ... 20#p445975
http://forum.opencart.com/viewtopic.php ... 40#p450692

And as for ghost posts there is nothing to worry about; if the Brits are right; about ghosts; whenever ghosts please.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by alaskaberries » Sun Nov 24, 2013 1:57 am

Thanks butte. I did a complete backup prior to installing the upgrade so will just revert back for now.

User avatar
New member

Posts

Joined
Sun Nov 27, 2011 12:31 am
Who is online

Users browsing this forum: No registered users and 11 guests