Post by strobes » Fri Nov 02, 2012 9:08 pm

Hi All

My site has been running fun up until a coupl of days ago when users would get the occassional database error message when trying to click onto a new page... today every page threw up several errors saying there were too many database connections and then a list of connection errors below

I called my hosting site to see if there was a problem with the database and they have told me that the database wont allow more than 200 users at a time to connect and therefore i must have had more than 200 connections at the same time.. i checked analytics and i had only had 19 hits in 24 hours.... when i told them that they suggested that there might be a leak in the script which is opening but not closing the database connection

does anyone have any idea what could be causing this? I am sorry for being vague here but i really dont know much else about it..

I would really appreciate some help with this if anyone knows anything

cheers

steve

New member

Posts

Joined
Fri Sep 02, 2011 7:13 pm

Post by strobes » Fri Nov 02, 2012 10:23 pm

Forgot to mention... i am on Version 1.5.2.1

hope someone can help

cheers

steve

New member

Posts

Joined
Fri Sep 02, 2011 7:13 pm

Post by ogun » Fri Nov 02, 2012 11:44 pm

Are you running any modules or customisations that could be hitting the database?

It's hard to say without seeing the site/having more info - you could try disabling the 'category' module (or whatever it is that draws the category menu) and replacing it with some static HTML in your template, that should speed things up dramatically although it may not fix your problem.

Opencart isn't lightning-fast, but it's no slouch either. Maybe spending a little more on better hosting would be worth investigating.

Active Member

Posts

Joined
Tue Aug 14, 2007 6:04 am

Post by strobes » Sat Nov 03, 2012 6:18 am

Hi

Thanks very much for your reply

As far as i am aware i m not running anything that should be doing that but am not 100% I am not really that great at this side of things, although i can run the site from the admin easily enough anything beyond that is, well, beyond me really to an extent

I am looking at changing hosts as the timing between clicking and the page loading is far far slower than it should be sometimes...there again that could be down to the database problem... i just wish i knew/understood more

Thanks again

Steve

New member

Posts

Joined
Fri Sep 02, 2011 7:13 pm
Who is online

Users browsing this forum: No registered users and 33 guests