Post by stf » Tue Aug 07, 2012 10:35 pm

This is kinda of a big problem because when people add a product to cart , they go to http://www.mysite.com/checkout/cart ... they click on Order and they stay on the same page instead of going to httpS://www.mysite.com/checkout/checkout to enter their details ....

I saw other threads about this but I didnt see the solution to it.

Another thing with this issue is that it doesnt always happen .... and I`m losing orders because of it.


Anyone has a solution to this ?

seo urls enabled
SSL enabled
OC version 1.5.2.1

stf
New member

Posts

Joined
Mon Apr 02, 2012 4:10 pm

Post by stf » Wed Aug 08, 2012 1:33 pm

after digging around and speaking to my host about it, they came up with a solution ... or so I thought ...

They told me to remove non secure external image links ... I had one in the footer and removed it ... but it didnt solve the problem

stf
New member

Posts

Joined
Mon Apr 02, 2012 4:10 pm

Post by sona3nyl » Wed Aug 08, 2012 2:23 pm

I'am looking for a solution for that problem , i'll let you know if i find a solution.

New member

Posts

Joined
Thu Jul 26, 2012 2:21 am

Post by stf » Wed Aug 08, 2012 2:32 pm

Sent another message to my host ... they tried to do something but it messed up my homepage and I removed their code

here is what they did :

Code: Select all

I have added the following redirection code in the .htaccess file.
Options +FollowSymlinks
RewriteEngine on
RewriteCond %{SERVER_PORT} !^443$
rewriterule ^(.*)$ https://www.mysite.com/$1 [r=301,nc]

However I could see that the following code in the .htaccess file does not allow the website to redirect:
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

hence I suggest you to contact your application vendor regarding the coding issue. We do not support scripting issues.
Does anyone have any idea on what that was ? Did they try to force the entire site to use https ?

stf
New member

Posts

Joined
Mon Apr 02, 2012 4:10 pm

Post by sona3nyl » Thu Aug 09, 2012 5:34 am

Did you find a solution?

New member

Posts

Joined
Thu Jul 26, 2012 2:21 am

Post by labeshops » Thu Aug 09, 2012 5:38 am

Are you using a custom theme? Try switching the store to the default theme and see if you have the same problem. If not, contact the theme's creator about the error.

Otherwise, a link to your store might help.

Running Opencart v3.0.3.2 with multi-stores from https://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by sona3nyl » Thu Aug 09, 2012 5:55 am

I solved my problem by replacing all the \catalog\view\theme\default\template\checkout\ files. Give it a try.

New member

Posts

Joined
Thu Jul 26, 2012 2:21 am

Post by stf » Fri Aug 10, 2012 2:35 pm

I`m using shoppica theme.

Left a message on their support forum to ask for a solution.

Using Chrome I found 10 errors in the checkout/checkout page source ....

Code: Select all

Unsafe JavaScript attempt to access frame with URL https://www.mysite.com/checkout/checkout from frame with URL https://www.facebook.com/plugins/fan.php?api_key=0c18007de6f00f7ecda8c040fb76cd90&connections=8&css=http%3A%2F%2Fwww.mysite.com%2Fcatalog%2Fview%2Ftheme%2Fshoppica%2Fstylesheet%2Ffacebook.css.php%3F300&height=250&id=292436777488542&locale=en_US&logobar=false&sdk=joey&stream=false&width=300. Domains, protocols and ports must match.

 SbvtqScestJ.js:38
SbvtqScestJ.js:38

g.categories.(anonymous function).(anonymous function) 
(anonymous function)

(repeated 10 times)
Also the host said that I should replace the standard http references so that objects are loaded instead through https ... which I have no idea how to do :)
Indeed there are plenty of http references on the secure checkout/checkout page ... in the menu and so on ...

stf
New member

Posts

Joined
Mon Apr 02, 2012 4:10 pm
Who is online

Users browsing this forum: No registered users and 26 guests