Post by wilmaogando » Sat Sep 19, 2009 1:15 am

Hi!

In my sotre I only have the option of paying when receiving the products, so when a customer place an order, check the option Pay when receiving products and confirm order, the order is placed. But I don't receive an e-mail ntifying me about that new order, so I can broke the agreement of deliver in 24 hours because I don't know when a new order is placed.

Note: I have thisoption: Send a email to the store owner when a new order is created set to YES in:
Admin, Configuration, Settins, Option.

What can I do?? I really need help in this!

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Post by kdmp » Sat Sep 19, 2009 1:27 am

Do you receive any emails from OpenCart?

How are you sending emails from OC? Mail or SMTP?

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by wilmaogando » Sat Sep 19, 2009 1:34 am

Hi

I did a test right now sending an email to customers and it works perfect the email is received inmediatly.

My store is new and I'am testing the orders before tell my clients to placed from there.

If you wan´t to see my store: www.waohzone.com

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Post by kdmp » Sat Sep 19, 2009 3:57 am

I only have it enabled on my WAMP server OpenCart installation. I don't believe I have my WAMP setup to send email.

Has anybody else noticed what wilma has experienced?

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by fluidman » Sat Sep 19, 2009 4:31 am

Did you put the checkmark in the admin section that you want to receive emails when orders come in?

Newbie

Posts

Joined
Wed Sep 16, 2009 9:15 pm

Post by Daniel » Sat Sep 19, 2009 4:34 am

wilmaogando wrote:Hi

I did a test right now sending an email to customers and it works perfect the email is received inmediatly.

My store is new and I'am testing the orders before tell my clients to placed from there.

If you wan´t to see my store: http://www.waohzone.com

speak to your web host. they might have disabled mails to stop people spamming.

opencart uses the default mail function built into php. if its not setup its not opencarts fault.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by kdmp » Sat Sep 19, 2009 6:48 am

Or as Daniel said - it may not be enabled by your host.

You should try to use SMTP for your site emails.

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by wilmaogando » Sun Sep 20, 2009 5:13 am

Hi everyone!

1. YES I put the checkmark in the admin section that I want to receive emails when orders come in.

2. About that my web host might have disabled mails to stop people spamming, if that's the reason the emails I send from (Admin, Customers, Mail) would be delivered correctly?, because I send and received them right.

3. About SMTP and WAMP I really don´t know about. I'm really new in this.

Thanks in advance for your help!

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Post by kdmp » Thu Sep 24, 2009 4:11 am

I have yet to receive an email from a WAMP install.

Do you have a 'live non-WAMP' host that you could test your install on?

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by wilmaogando » Thu Sep 24, 2009 8:06 am

Sorry I don't know what is live or WAMP host.

???

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Post by kdmp » Thu Sep 24, 2009 8:18 am

WAMP is a 'portable' web server you can run from your computer. Whether it be for a personal website that you link back to your personal computer that is running it, or for testing websites and web applications before releasing them to the web.

Live Web Server - would be what this forum is. It is on a web server accessible to the world for all to use.


SMTP - Send Mail Transfer Protocol. How you send your email to your friends (in most cases).

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by wilmaogando » Thu Sep 24, 2009 9:11 am

Thanks very much Kevin Davidson for your patient.

For your explanation I think I have a Live Server provided by Hostagator.

I send emails from my admin to the clients correctly, and I also receive the confirmation mail of a new product review. The problem is receiving the confirmation mail for a new placed order. Do you know why?

Thanks in advance

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Post by kdmp » Thu Sep 24, 2009 10:11 am

Hi Wilma,

No problem.

Have you set up another payment option? Like Check(Cheque)? Does that an email when you do a test order using the check/money order? I am curious to hear if it does.

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by wilmaogando » Thu Sep 24, 2009 10:19 am

No I don't have another option, I just have enable Cash On Delivery.

Do you recommend me to enable another one to try?

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Post by kdmp » Thu Sep 24, 2009 10:56 am

Yes, just to test it. Enable the cheque/money order payment option so you don't have to process an actual payment.

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by wilmaogando » Thu Sep 24, 2009 11:11 am

Ok I test it, and I still receive the mail as a client confirming me that I placed an order, but as administrator I don't receive any advise about the placed order, so i can miss an order if I don't go to admin and chekck everytime. ???

Wilma
(Don't speak english)


New member

Posts

Joined
Fri Jul 24, 2009 12:15 am
Location - Dominican Republic

Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by kdmp » Fri Sep 25, 2009 5:58 am

Hi Wilma,

What version of OC do you have installed. It looks like 1.2.8 or a version under that.

I have changed the order status in the admin panel. (Admin->Configuration->Setting->Option) I changed it from Processing to Pending to see if that will help. As far as I can tell you have everything set up correctly.

I am not sure if the change in the order status will help. If it doesn't, I would recommend upgrading to 1.3.2. You may find it may resolve you issue.

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by fluidman » Fri Sep 25, 2009 2:51 pm

Are you sure you have set the check mark at Admin > Configuration > Setting > Option > Alert Mail to 'Yes'? (Send a email to the store owner when a new order is created.)

Cause when you have set it to no only the customer will get the confirmation mail but not the store owner.

Just double checking :-)

Newbie

Posts

Joined
Wed Sep 16, 2009 9:15 pm

Post by kdmp » Fri Sep 25, 2009 9:33 pm

Hi fluidman,

The check mark is there. I have verified this.

There is not apparent reason for this, unless Wilma's host provider has some strict email spam protection. The version of OC Wilma is using is sending mail through PHP Mail and this can be blocked by a web host.

I suggest upgrading to version 1.3.2 so that email can be passed through SMTP. That should fix the problem.

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada
Who is online

Users browsing this forum: No registered users and 10 guests