Post by thinkingforward » Wed Dec 30, 2009 11:08 pm

Hi all,

Every time I click on another window or tab and then return to the opencart admin, I have to re-login.

Anyone else having this problem?

Thanks

Active Member

Posts

Joined
Wed Nov 25, 2009 2:55 am


Post by i2Paq » Wed Dec 30, 2009 11:51 pm

I've seen a topic about this not so long ago.
Just use the search, I hope you find it.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by BarneyDay » Thu Dec 31, 2009 2:25 am

Hi, I recently had this problem.

I got round it by copying the php.ini file from the root folder into the admin folder and uploading it.

Rightly or wrongly, it did the trick for me!!

Newbie

Posts

Joined
Mon Dec 21, 2009 11:17 pm

Post by readytechusa » Sat Oct 08, 2011 1:50 pm

i2Paq wrote:I've seen a topic about this not so long ago.
Just use the search, I hope you find it.
Not helpful. I've been searching, and since there are quite a few threads with this issue and apparently(so far) no fix in any of them, I'm just going around in circles.

If you have a solution, please let us know where we can find it. Or simply sticky a thread with possible solutions for this issue. Thanks -John

opencart version: 1.5.1.3


Newbie

Posts

Joined
Thu Oct 06, 2011 1:38 pm
Location - California

Post by i2Paq » Sat Oct 08, 2011 7:09 pm

What have you tried?

It has to do with the session timeout your hoster has set.

Sometimes you can overrule this and there is a topic about this, just use the search.
If this fix found in that topic does not work you have to contact your hoster on this.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by readytechusa » Thu Oct 13, 2011 1:42 am

i2Paq wrote:What have you tried?

It has to do with the session timeout your hoster has set.

Sometimes you can overrule this and there is a topic about this, just use the search.
If this fix found in that topic does not work you have to contact your hoster on this.
Thank you for your response.
I contacted my host iPage, they said their session timeout was set to 24minutes. Which didn't make sense because I'd get thrown out in less than 4 minutes in some instances. They weren't any help with this issue, so I kept searching the forum here. I was able to find the fix, as you said, I did find a way to overrule it and I'll paste my earlier post on it. Thanks again. -John
readytechusa wrote:The recommended fix: session.gc.maxlifetime = 12000000 did not work for me. (1.5.1.3)

I found this advice from a different thread and it worked, so just passing it on, hope it helps for anyone else that happens to be searching for this topic.
readytechusa.com

:::I used this with success:::

Code: Select all

<script type="text/javascript">
function pingServer() {
$.ajax({ url: location.href });
}
$(document).ready(function() {
setInterval('pingServer()', 20000);
});
</script>
:::Put it in admin/view/template/common/header.tpl, right :::before the closing head tag:

Code: Select all

</head>

opencart version: 1.5.1.3


Newbie

Posts

Joined
Thu Oct 06, 2011 1:38 pm
Location - California

Post by lochoe » Thu Feb 16, 2012 12:06 pm

Hye there, is there any other option, after i put that code, i still logout from admin page

when i login to admin, n click any menu/link, i'll be logout and need to login again, so i cant edit any setting, since be logout from the admin page...please help

Newbie

Posts

Joined
Fri Nov 18, 2011 2:52 pm

Post by lochoe » Thu Feb 16, 2012 12:17 pm

i just turn off SEO and change .htacesss to htaccess.txt, dont know is it ok, but the web running fine..better have no seo than website not running...

Newbie

Posts

Joined
Fri Nov 18, 2011 2:52 pm

Post by srcleveland » Wed Apr 11, 2012 6:22 am

has this ever been addressed??????

the logout is annoying!!!!

If it si in the hosting site, where is it so we can tell them how to fix it. if it is in the code FIX IT!!!!

Newbie

Posts

Joined
Wed Apr 11, 2012 5:40 am

Post by srcleveland » Wed Apr 11, 2012 7:03 am

I think i found the answer :)
I added the above entry to the php.ini file within the admin folder and it started working "session.gc.maxlifetime = 12000000"

please note that what is in the php.ini from the install is "session.gc_maxlifetime = 12000000"

Newbie

Posts

Joined
Wed Apr 11, 2012 5:40 am

Post by fili » Thu Apr 12, 2012 12:41 am

at yesterday i have same problem, and already solve it

it's about server issue, maybe you can contact your hosting provider to turn off
cache (facility) from your server / cpanel,

it's work.. just contact your hosting provider. to turnoff cache setting special on your hosting / cpanel

User avatar
New member

Posts

Joined
Tue May 04, 2010 10:35 pm

Post by justinv » Tue Aug 14, 2012 6:47 am

I have just released a free vqmod that fixes this issue: http://www.opencart.com/index.php?route ... on_id=7741

Documentation: OpenCart User Guide
Mods: Total Import PRO | CSV Import PRO | Ecom Tracking | Any Feed | Autosuggest | OpenCart CDN
Image


Active Member

Posts

Joined
Tue Oct 12, 2010 1:24 pm

Post by edze » Wed Aug 14, 2013 6:40 am

Hi guys,

I have three opencart webshops, all v 1.5.5.1, on the same server of the same webhoster. When working in Admin, I get thrown out of Admin exactly every hour. For example, when I log in at 09:55 I get logged out at 10:00 , and when I login at 11:05 I get logged out at 12:00. So I get logged out not exactly after one hour, but exactly on the hour.

Is there a solution, please?

Kind regards,
Edze

Newbie

Posts

Joined
Thu May 09, 2013 6:36 pm

Post by webkix » Thu Oct 09, 2014 1:53 pm

Navigate to /httpdocs/admin and edit the php.ini file.
Change the session.gc_maxlifetime value, for ex:

Code: Select all

session.gc_maxlifetime = 12000000;

You can find more useful info in my opencart blog at :WebKix


Newbie

Posts

Joined
Mon Sep 15, 2014 12:17 pm

Post by mkp007 » Tue Feb 09, 2016 5:33 am


Vorticy, Inc.
Opencart 1.5.6.4, MySQL 5.1.73-5, PHP 5.3.3-46, Plesk v12.0.18, OS CentOS 6


New member

Posts

Joined
Fri May 10, 2013 12:56 am
Who is online

Users browsing this forum: Bing [Bot] and 64 guests