Post by dharshan » Sat Jul 25, 2009 12:09 am

hai, i have hosted open cart in host gator and in the following root directory.
www.pestpro.co.in/products but when i am checking yes for seo urls at sever setting in admin the products are pointing to home directory and i wont be able to view it., i have discussed this problem with the hostgator support but the asked to consult the you guys. kindly help me.


i am qouteing the conversation with hostgator support
Hello.


Something about OpenCart's use of SEO-friendly web links is misconfigured. When we set "Use SEO URL's" to "No" in the Server section of the Settings page, the links begin working correctly again.

One issue is that, as explained on that Settings page, "htaccess.txt" must be renamed to ".htaccess" for SEO URL's to work. However, something else is also misconfigured, because the SEO-friendly links are trying to redirect back to your main page, instead of to your "products" directory. We recommend reviewing OpenCart's installation instructions and configuration, making sure all settings are correct, particularly those that state where your OpenCart installation is located.

If you still see issues even after reviewing the configuration and renaming the htaccess.txt file, let us know and we will hel investigate.

Thank you!


Kris Kelley
Level I Linux Administrator
HostGator.com

...
kindly help me out
thank you

Newbie

Posts

Joined
Fri Jul 24, 2009 11:52 pm

Post by readyman » Sat Jul 25, 2009 4:13 am

Which version have you got there?
You'll need to add the "products" folder to your htaccess file...
If everything is redirecting to the home page rather than the products directory, then you have nothing to worry about... just add the 'products' bit.

http://www.alreadymade.com
Follow me on twitter.com/alreadymade


User avatar
Global Moderator

Posts

Joined
Wed May 20, 2009 5:16 am
Location - Sydney

Post by zeevy » Sat Jul 25, 2009 1:24 pm

dharshan wrote:hai, i have hosted open cart in host gator and in the following root directory.
http://www.pestpro.co.in/products but when i am checking yes for seo urls at sever setting in admin the products are pointing to home directory and i wont be able to view it., i have discussed this problem with the hostgator support but the asked to consult the you guys. kindly help me.


i am qouteing the conversation with hostgator support
Hello.


Something about OpenCart's use of SEO-friendly web links is misconfigured. When we set "Use SEO URL's" to "No" in the Server section of the Settings page, the links begin working correctly again.

One issue is that, as explained on that Settings page, "htaccess.txt" must be renamed to ".htaccess" for SEO URL's to work. However, something else is also misconfigured, because the SEO-friendly links are trying to redirect back to your main page, instead of to your "products" directory. We recommend reviewing OpenCart's installation instructions and configuration, making sure all settings are correct, particularly those that state where your OpenCart installation is located.

If you still see issues even after reviewing the configuration and renaming the htaccess.txt file, let us know and we will hel investigate.

Thank you!


Kris Kelley
Level I Linux Administrator
HostGator.com

...
kindly help me out
thank you

may be problem with rewrite base

try changing it to

rewritebase /products
or
rewritebase /products/

in .htaccess file

New member

Posts

Joined
Tue Jul 21, 2009 8:08 pm
Who is online

Users browsing this forum: No registered users and 19 guests