Post by wings » Thu Dec 16, 2010 5:56 pm

Beste Opencart gebruikers,

Ik werk met Opencart 1.4.9 en heb daarop een template van Santosh Setty.
Ook heb ik iDeal van Mollie erop draaien.
Als ik nu met iDeal kies voor direct afrekenen, vinden er in de template twee rare veranderingen plaats.
Mijn logo linksbovenin wordt ineens nog maar met het bovenste randje getoond, en onderaan op het scherm staat de button van "ik heb de voorwaarden gelezen" helemaal rechts buiten de template.
Omdat mijn engels niet al te best is krijg ik aan de Indiase maker van de template niet goed uitgelegt wat de problemen zijn.
Heeft iemand van jullie misschien enig idee wat ik kan aanpassen, en vooral waar ik wat kan aanpassen om dit te verhelpen ?
Alvast heel hartelijk bedankt voor de moeite !

René Meijwaard.
HTTP://www.wingsdump.nl/store

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by i2Paq » Fri Dec 17, 2010 2:17 am

En wat zegt de maker/verkoper hiervan?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by wings » Fri Dec 17, 2010 2:44 am

De maker/verkoper krijg ik het in het Engels niet goed uitgelegt, dus deze snapt niet wat ik bedoel.
Ik dacht, misschien is er hier iemand die me op weg kan helpen....

Met vriendelijke groet,
René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by i2Paq » Fri Dec 17, 2010 4:11 am

Heb je een test account welk ik kan gebruiken?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by wings » Fri Dec 17, 2010 5:05 am

Probeer het maar gewoon in de shop.
Ik zal iDeal op "test" zetten, en ik wis de bestellingen.
Alvast bedankt voor de moeite !

Mvrgr. René

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by i2Paq » Fri Dec 17, 2010 2:16 pm

Ja dat is lekker zeg, dan kan ik elke keer of gegevens invoeren of een account aanmaken.
Als ik dat voor elke shop doe heb ik een dagtaak.

Jij wil dat er iets getest wordt, zorg dan ook voor de mogelijkheid.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by wings » Fri Dec 17, 2010 3:59 pm

Sorry, begreep niet echt wat je bedoelde.( weet ook niet echt hoe ik een test account moet opzetten)
De vraag is ook eigenlijk meer : waar kan ik deze layout problemen aanpassen.
Maar ik wil je natuurlijk niet met al dat tikwerk opzadelen.
Hartelijk bedankt voor alle moeite tot zover !
René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by i2Paq » Sat Dec 18, 2010 4:19 am

Maak gewoon een "klant" aan die je als testaccount kunt gebruiken, heb ik in mijn eigen shop ook.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by wings » Sat Dec 18, 2010 4:55 am

Ik heb nu inderdaad een testklant aangemaakt.
het rare is nu dat als ik als "klant" inlog en dan kies voor met iDeal betalen, de layout wel keurig netjes in orde is.
Als ik dan na het weer uitloggen kies voor de optie "direct afrekenen", valt na het invullen van de pagina met naw gegevens het logo bovenaan voor de helft weg en staat onderaan de button helemaal rechts buiten de opmaak van de site.
Ik neem aan dat bij deze actie een andere file wordt aangeroepen, maar ik weet niet welke dit is, en welke ik dus zou moeten aanpassen.
Met vriendelijke groet,
René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by wings » Sat Dec 18, 2010 5:07 am

screenshot-half-logo.jpg

screenshot-half-logo.jpg (54.11 KiB) Viewed 3348 times

Hierboven zie je wat ik bedoel met het halve logo.

Hieronder zie je dat de button "ik heb de voorwaarden gelezen" helemaal naar rechts staat
screenshot-button-helemaal-rechts.jpg

screenshot-button-helemaal-rechts.jpg (45.16 KiB) Viewed 3348 times

Hoop dat mijn vraag zo wat duidelijker is.

Met vriendelijke groet,
René Meijwaard

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by Gerrit » Mon Dec 20, 2010 5:00 pm

Zit in je stylesheet, kijk of je toevallig de default template of een andere ook geinstalleerd hebt staan.
Waarschijnlijk maakt de Ideaal module hier gebruik van.

Je kan ook kijken of de mollie module toevallig in de default is geplaatst ipv jouw eigen template dir.
Dit verkeerd plaatsen komt vaker voor als je denkt.

G.

For modelcars cars see my OC 3.0.2.0 shop: http://www.gbcars.nl/
For Wooden Toys see my 2.3.0.2 shop: https://www.dehoutentreinenwinkel.nl/


User avatar
Active Member

Posts

Joined
Fri Nov 27, 2009 9:06 pm

Post by wings » Mon Dec 20, 2010 7:45 pm

Beste Gerrit,

Hartelijk dank voor de info, ga kijken of ik het op deze manier kan vinden.
Ik laat het hier nog wel even weten.
Groetjes, René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by burrito » Mon Dec 20, 2010 8:28 pm

geeft ie niet bovenaan een error als je direct afrekenen kiest? een sql of php error die in zwart wordt laten zien (daarom kan je hem niet zien nu op die achtergrond) en omdat je header een vast hoogte heeft wordt de rest afgesneden.

Dat zou mijn gok zijn, even een blok maken van de ruimte bovenin je header.

Verder klopt er niets van alle boxen op die pagina, ik denkt dat er ergens een div verkeerd wordt afgesloten op die pagina.

Image
Opencart specialist | Our website | Our modules


User avatar
Active Member

Posts

Joined
Tue Dec 15, 2009 6:10 pm
Location - Amsterdam, The Netherlands

Post by wings » Mon Dec 20, 2010 9:03 pm

Beste Burrito,

Je hebt helemaal gelijk.
Inderdaad zit er ook de volgende foutmelding onder :

Notice: Undefined index: shipping_method in /home/wingsdump/domains/wingsdump.nl/public_html/store/catalog/model/payment/pay_in_store.php on line 21

Maar ik snap niet goed wat je bedoelt met : even een blok maken van de ruimte bovenin je header
Zou je dit misschien ook voor een beginneling uit kunnen leggen ?
Alvast hartelijk dank voor de moeite !
Groetjes, René

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by wings » Tue Dec 21, 2010 3:48 am

Zit inmiddels al een flink tijdje te staren naar de guest_step_2.tpl en de payment_tpl om te kijken waarom er nou bij de guest checkout wel van alles mis gaat, en bij de geregistreerde klant niet, maar ik weet eigenlijk niet waar ik op moet letten.
Heeft misschien iemand enig idee ?
Alvast bedankt !
Groetjes, René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by Gerrit » Wed Dec 22, 2010 5:57 pm

ik kwam dit tegen bij de 1.4.9.3 topic.

???
NOTES:
Most 1.4.9.x themes should work fine. There were only tiny changes to the tpl files and only the header.tpl is likely to be something you'd have different in a custom theme. Be sure your custom themes never have their own "payment" folder as that folder should always be left out so that the default is used so that any updates to payment modules are applied to your store

For modelcars cars see my OC 3.0.2.0 shop: http://www.gbcars.nl/
For Wooden Toys see my 2.3.0.2 shop: https://www.dehoutentreinenwinkel.nl/


User avatar
Active Member

Posts

Joined
Fri Nov 27, 2009 9:06 pm

Post by burrito » Wed Dec 22, 2010 7:10 pm

er is een combinatie van 2 problemen met je website,

mijn opmerking van het blok kan je negeren, dat was alleen om de melding zichtbaar te maken en die heb je al

probleem 1:
Notice: Undefined index: shipping_method in /home/wingsdump/domains/wingsdump.nl/public_html/store/catalog/model/payment/pay_in_store.php on line 21

die moet relatief simpel te achterhalen zijn, kijk eens in pay_in_store.php op regel 21 en zoek shipping_method op, daar gaat iets mis.

probleem 2:
template problemen, die zitten in een verandering in de header.tpl in de nieuwe versie van opencart, er zal in je tpl file een </div> staan die er niet in moet, of juist wel... het makkelijkst is om de tpl te vergelijken met een tpl van een pagina die wel goed werkt (dus niet de header, maar de pagina zelf vergelijken) in het begin van de pagina zal je verschillen zien die er niet horen.

Meer kan ik zo niet echt uitleggen, ik wil er wel even naar kijken voor je maar dan moet je me even een pm sturen met wat meer info... (zoals contact gegevens)

Image
Opencart specialist | Our website | Our modules


User avatar
Active Member

Posts

Joined
Tue Dec 15, 2009 6:10 pm
Location - Amsterdam, The Netherlands

Post by wings » Thu Dec 23, 2010 5:30 am

Beste Gerrit en Burrito,

Allereerst bedankt dat jullie de moeite willen nemen om een Oc nieuweling wat bij te brengen.
De mollie module etc. zitten volgens mij op de goede plek.

Wat betreft de foutmelding op line 21
Daar staat de volgende regel :
if ($this->session->data['shipping_method']['id'] != 'pickup.pickup') {

Maar ben niet goed op de hoogte van Php, dus snap hier eigenlijk niet veel van.
Heb hier voor de rest ook van het begin af aan niets aan gewijzigd.

Dus Burrito, ik stuur je graag een pm met mijn contactgegevens...

Groetjes,
René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by wings » Fri Dec 24, 2010 4:52 am

Met dank aan Burrito is de foutmelding opgelost en zijn ook de rare fouten uit mijn betaalpagina !
Het bleek toch door de pay_in_store.php te komen.
Nu heb ik deze dus verwijderd en een andere betaal- en verzendmethode gebruikt/aangepast voor "afhalen in winkel" en "betalen in winkel".
Enige nadeel is nu wel dat de klant in het betaalscherm kan kiezen voor "verzenden" in combinatie met "betalen in winkel" maar ik hoop hier met de tijd ook nog een oplossing voor te vinden.
Hoop dat andere Opencart gebruikers met deze info ook nog wat kunnen...
Met vriendelijke groet,
René Meijwaard.

New member

Posts

Joined
Wed Oct 20, 2010 7:21 pm


Post by i2Paq » Fri Dec 24, 2010 6:18 am

wings wrote:Enige nadeel is nu wel dat de klant in het betaalscherm kan kiezen voor "verzenden" in combinatie met "betalen in winkel" maar ik hoop hier met de tijd ook nog een oplossing voor te vinden.
Ship 2 Pay.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands
Who is online

Users browsing this forum: No registered users and 8 guests