Post by quintal » Sun Feb 17, 2019 10:06 pm

Ik heb al volop naar antwoorden gezocht maar kan geen enkele vinden ...
Na veel verschillende manieren van proberen heb ik eindelijk succesvol mijn winkel van 1.5.6.4 naar 2.1.0.2 kunnen upgraden. Het lijkt erop dat alles zonder fouten werkt, maar er wordt geen enkele afbeelding weergegeven.
Ik heb mijn foto's (data map) geüpload naar de nieuwe locatie image/catalogus en als ik de image manager open, zijn de verschillende mappen zichtbaar, dus de locatie is correct, maar er zijn geen afbeeldingen zichtbaar. Als ik een upload maak via Image Manager, wordt de afbeelding geüpload en wordt zelfs een bericht 'geslaagd' weergegeven, maar de afbeelding is nergens zichtbaar...
Beide config.php zijn dus correct (heb ook getest met de data map in enkel image/, maar dan is er niets (dus ook geen mappen) zichtbaar in image manager).
Iemand?

Newbie

Posts

Joined
Sat Dec 01, 2012 4:15 am

Post by victorj » Mon Feb 18, 2019 3:50 am

Als eerste controleer de rechten van de mappen, meestal hebben deze 755 daarna de bestanden in de mappen meestal 644.
Zit je op hosting met direct admin ga daar dan naar toe en open filemanager.
ga naar een image map en controleer daar de eigenaar van de bestanden, dat moet apache zijn, zo nee, selecteer dan al die bestanden en reset de eigenaar.

zorg ervoor dat de namen geen rare tekens bevatten, alleen a-z A-Z en 0-9 dus geen /@% enz
controleer ook de php.ini.
verhoog zo nodig de memory_limit. staat deze op 16 of 32M dan kunnen er geen thumbnails aangemaakt worden, zeker als je behoorlijk grote plaatjes gebruikt.
verhoog zo nodig tot 512M

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Eigen productie en snelle levering.
https://123-deurrubbers.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by k2tec » Mon Feb 18, 2019 6:40 pm

Als je de database gegevens van de oude shop gebruikt dan staan de gegevens nog op data en niet op catalog.

Code: Select all

UPDATE oc_category_description
SET description=REPLACE(description,'image/data','image/catalog')

Code: Select all

UPDATE oc_product_image
SET image =REPLACE(image,'data/', 'catalog/')

User avatar
Active Member

Posts

Joined
Mon Apr 12, 2010 8:06 pm

Post by quintal » Mon Feb 18, 2019 11:39 pm

Bedankt K2tec, dat zou het wel eens kunnen zijn. Zou je me ook kunnen vertellen wáár ik dat moet veranderen?

En Victorj, bedankt voor je suggesties, maar die had ik allemaal al uitgevoerd, dus dat is het niet..

Newbie

Posts

Joined
Sat Dec 01, 2012 4:15 am

Post by k2tec » Tue Feb 19, 2019 4:04 pm

In je database

User avatar
Active Member

Posts

Joined
Mon Apr 12, 2010 8:06 pm

Post by quintal » Tue Feb 19, 2019 10:50 pm

nee, is het ook niet...
Wat ik vandaag gedaan heb, is even een volledige nieuwe installatie van opencart 2.1.0.2 gedaan, onder een andere url, met een volledig lege, nieuwe database en verder geen veranderingen, alsof ik vandaag van start zou gaan met een webwinkel..., en hier heb ik hetzelfde probleem. Wél zijn hier in de admin en op de live-site alle afbeeldingen te zien, maar zodra ik image-manager gebruik, staan er alleen lege mappen en geen afbeeldingen.
Ik heb geloof ik alle posts over dit onderwerp zo'n beetje gelezen en vaak ook alle suggesties geprobeerd, maar aangezien het nu dus ook gebeurd bij een geheel nieuwe 'schone' installatie, vind ik het wel vreemd (ligt ook niet aan m'n browser, verschillende geprobeerd).

Newbie

Posts

Joined
Sat Dec 01, 2012 4:15 am
Who is online

Users browsing this forum: No registered users and 13 guests