Post by cofran » Tue Dec 08, 2009 6:33 am

Bueno esta es una contribución que se reclamaba por los usuarios de opencart, sobre todo por los de España. Espero que les sirva, Saludos!

Contribución: Medio de pago Servired

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by Gooler » Wed Dec 09, 2009 7:17 pm

Gracias por la aportación.

Newbie

Posts

Joined
Wed Dec 09, 2009 7:13 pm

Post by cofran » Thu Dec 10, 2009 11:01 am

Por favor! de nada Gooler. Por cierto he subido una revisión de la pasarela que puedes pasar a buscar para actualizar la anterior. Saludos!

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by hande » Sat Dec 12, 2009 5:51 am

A ver si éste fin de semana puedo testearlo.
Gracias por el aporte.

@ Shop | Work | Blog | Photos | Wallpapers | Twitter


User avatar
New member

Posts

Joined
Tue Nov 17, 2009 5:57 am
Location - Barcelona / Spain

Post by cofran » Wed Dec 16, 2009 10:04 pm

che, sería bueno que los que esten utilizando la pasarela comenten su experiencia asi como tambien aquellos que hayan pasado a producción tambien comentar, para todos aquellos usuarios que quisieran implementarla. Como así también si han tenido algun inconveniente, si lo han resuelto y como lo hicieron.

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by hande » Sat Jan 09, 2010 12:48 am

Supongo que será una pregunta tonta, pero qué pasos hay que seguir para que funcione correctamente?

Lo he instalado y activado sin problemas (he añadido un par de carpetas para los idiomas que tengo en mi sitio de pruebas)

Me aparece el mensaje;
Importe 0,00
Código Comercio xxxxxxxx
Terminal 0
Número pedido
Error en datos enviados. Contacte con su comercio.
El código de comercio me aparece el correcto, pero no marca el importe ni número de pedido.

Tengo que pedir alguna clave o algo a servired o mi entidad bancaria? O bien basta con el código de comercio?
PD: lo he intentado con la versión 1.2 y la 1.3.

@ Shop | Work | Blog | Photos | Wallpapers | Twitter


User avatar
New member

Posts

Joined
Tue Nov 17, 2009 5:57 am
Location - Barcelona / Spain

Post by cofran » Sat Jan 09, 2010 3:54 am

Hola, la terminal debe ser 1 o 2 pero no 0 como aparece allí, y tenes que tener la clave de pruebas que te dan desde el banco que creo que es qwerty123456789 y tambien poner el modulo como prueba o test (todo desde la configuracion del modulo).

Lo otro que podes hacer es intentar comprar algo, hacer todo el proceso de compra hasta el "ir a pagar" (coneccion con servired) alli hace click derecho en alguna parte del sitio y pone "ver codigo fuente" y busca el formulario y fijate que datos estan pasando y si son correctos.

Saludos!

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by leomazz » Sat Jan 09, 2010 12:07 pm

No te olvides de los que usamos Mercadopago....
Gracias!

Mamma mia! Donde me meti...?


New member

Posts

Joined
Mon Jan 04, 2010 10:45 am
Location - Banfield - Buenos Aires

Post by hande » Sun Jan 10, 2010 7:18 pm

leomazz wrote:No te olvides de los que usamos Mercadopago....
Gracias!
Cada cosa en su sitio;
[Medio de Pago] Mercadopago --> http://forum.opencart.com/viewtopic.php?f=98&t=9310
Mercadopago? --> http://forum.opencart.com/viewtopic.php?f=98&t=9236

Dejemos cada mensaje con el tema que toca. Aquí hablamos de servired y el módulo creado;
http://www.opencart.com/index.php?route ... ion_id=305

@ Shop | Work | Blog | Photos | Wallpapers | Twitter


User avatar
New member

Posts

Joined
Tue Nov 17, 2009 5:57 am
Location - Barcelona / Spain

Post by kapitol » Thu Feb 11, 2010 7:24 pm

muchas gracias por compartir tu trabajo cofran !! ;D

tengo un problema...he subido los archivos e instalado en el panel de modulos del admin este módulo de servired, pero cuando quiero editar para introducir las variables de mi negocio sale la página en blanco, supongo que por algún tipo de error en el php de algunos de los archivos (no lo se)

desconozco cual es mi versión exacta de opencart pero diría que es la 1.3.4...¿alguna idea de que puede estar ocurriendo? muchas gracias nuevamente por tu aportación =)

Newbie

Posts

Joined
Thu Feb 11, 2010 7:17 pm

Post by cofran » Thu Feb 11, 2010 11:52 pm

mmm tendrías que fijarte en el LOG de errores a ver que tipo de error tiene, tambien comprobar realmente la versión que estas usando de OC porque solamente lo he testeado y programado para la versión 1.3.4 y desconozco si funciona en versiones anteriores a esta.

Por último recomendarte que descarges la última verión publicada ya que el orden de versiones en el apartado de contribuciones/extensiones es de forma descendente, entonces la primera que aparece allí es la más antigua y la última es la más reciente... podes guiarte por la fecha de publicación de cada versión del modulo servired para estar más seguro de descargar al última versión publicada.

Saludos!

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by kapitol » Wed Feb 17, 2010 2:25 am

Hola de nuevo...por aquí sigo con mi lucha !

Me doy cuenta de un aspecto, y es que en principio los errores provienen de la parte de la administración del módulo, por lo que mi pregunta es:

¿realmente podría prescindir de esta funcionalidad y colocar todos mis datos necesarios en el código no?
lo único que se pierede es el componente visual de la UI, pero en teoria se debe poder hacer

otra cosa ya es que me encuentre otro error derivado de que tengo la 1.3.2 más adelante, a la hora de pagar...voy a probarlo esto y os comento

saludos ! ^-^

Newbie

Posts

Joined
Thu Feb 11, 2010 7:17 pm

Post by cofran » Wed Feb 17, 2010 2:53 am

che pero te mande un PM con el link para que descargues las modificaciones que le hice al modulo para tu versión de OC y no respondiste nada.

Descargalo desde este link: Modulo de Pago SERVIRED para OpenCart 1.3.2

Quien tenga esta versión de OpenCart e instale el modulo por favor comenten los pro y contras que han tenido, yo lo he testeado y los datos pasan a la pasarela sin ningún problema como así también la administración anda a la perfección.


Saludos!

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by kapitol » Wed Mar 03, 2010 6:43 pm

cofran wrote:che pero te mande un PM con el link para que descargues las modificaciones que le hice al modulo para tu versión de OC y no respondiste nada.

Descargalo desde este link: Modulo de Pago SERVIRED para OpenCart 1.3.2

Quien tenga esta versión de OpenCart e instale el modulo por favor comenten los pro y contras que han tenido, yo lo he testeado y los datos pasan a la pasarela sin ningún problema como así también la administración anda a la perfección.
Saludos!
Muchas muchas muchas gracias cofran por tu generosidad...esta nueva revisión de tu módulo parece estar bien acoplado a la 1.3.2...todo va perfecto de momento ;D

un pequeño error, que en realidad no se si es por mi customización, pero en la parte de administrador, el archivo admin/view/servired.tpl no encontraba las variables $header y $footer...realmente no son necesarias y pueden ser comentadas y obviadas, sin que nada se descuadre

seguiré posteando mis impresiones, gracias de nuevo, muchas

pd:
no recibi MP alguno, es extraño pero bueno...lo siento cofran !!

Newbie

Posts

Joined
Thu Feb 11, 2010 7:17 pm

Post by cofran » Fri Mar 05, 2010 12:39 am

bien, dale danos tu impresión y comenta como funciona, así lo subo a las contribuciones con las indicaciones de errores corregidas que me marcas.

Saludos!

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by felixsg » Wed Mar 24, 2010 4:04 am

alguien tiene planeado actualizarlo para que funciones en 1.4.4
encontre como activar una funcion que habian quitado. pero
cuando intento comprar falla en la geolocalización

gracias

Newbie

Posts

Joined
Wed Mar 24, 2010 3:43 am

Post by cofran » Wed Mar 24, 2010 6:04 am

Ya esta subido para poder usar en la versión 1.4.x por ahora vamos a ver hasta donde se extiende la "x" en fin, no lo pude testear porque no tengo más los datos del banco para poder hacerlo así que depende de ustedes y sus comentarios lo que puede pasar una ves que salen del sitio (opencart) ya que yo, poco y nada puedo ver :P

te dejo el link: http://www.opencart.com/index.php?route ... ion_id=496

Saludos!

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by felixsg » Wed Mar 24, 2010 6:37 pm

gracias
solo me da este error cuando quiero activarlo y no funciona
404 Not Found
The requested URL /store/admin/payment/servired does not exist.
nota: he creado la carpeta
y no encuentra el archivo
donde puedo cambier ese enlace y poner la orden php que necesita la parte admin?

Newbie

Posts

Joined
Wed Mar 24, 2010 3:43 am

Post by cofran » Thu Mar 25, 2010 12:16 am

ya esta solucionado che, disculpa, fijate que es el archivo titulado "ServiRed para OC 1.4.4 (v2)"

Y bueno, comenta si anda o no...

User avatar
Active Member

Posts

Joined
Thu Oct 01, 2009 7:37 am
Location - Córdoba, Argentina

Post by felixsg » Thu Mar 25, 2010 3:56 am

de momento va bien
en cuanto lo pruebe con el banco
te dire más

gracias

Newbie

Posts

Joined
Wed Mar 24, 2010 3:43 am
Who is online

Users browsing this forum: No registered users and 3 guests