Post by celestial » Sat Jan 14, 2012 7:16 am

faru wrote:Celestial, tengo la versión 1.5.1.3 y acabo de reemplazar el archivo order.php en la carpeta \catalog\model\checkout
Hice una compra pero solo llego el e-mail al cliente, pero no al administrador de la tienda.
Volví a dejar el archivo order.php antiguo y realice una compra y me llego los 2 correos (al administrador y al cliente).
En que estaré fallando?
El ultimo order.php es el que tenes que tomar puse dos toma el segundo del foro

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by faru » Sat Jan 14, 2012 7:29 am

Genial funciona perfecto muchas gracias !!!! :yahoo:

New member

Posts

Joined
Wed Oct 26, 2011 3:05 am

Post by reginamor » Fri Jan 20, 2012 9:02 pm

celestial wrote:
faru wrote:Celestial, tengo la versión 1.5.1.3 y acabo de reemplazar el archivo order.php en la carpeta \catalog\model\checkout
Hice una compra pero solo llego el e-mail al cliente, pero no al administrador de la tienda.
Volví a dejar el archivo order.php antiguo y realice una compra y me llego los 2 correos (al administrador y al cliente).
En que estaré fallando?
El ultimo order.php es el que tenes que tomar puse dos toma el segundo del foro

yo solo veo uno ???

User avatar
Active Member

Posts

Joined
Wed Sep 21, 2011 4:44 am

Post by celestial » Fri Jan 20, 2012 10:21 pm

reginamor wrote:
celestial wrote:
faru wrote:Celestial, tengo la versión 1.5.1.3 y acabo de reemplazar el archivo order.php en la carpeta \catalog\model\checkout
Hice una compra pero solo llego el e-mail al cliente, pero no al administrador de la tienda.
Volví a dejar el archivo order.php antiguo y realice una compra y me llego los 2 correos (al administrador y al cliente).
En que estaré fallando?
El ultimo order.php es el que tenes que tomar puse dos toma el segundo del foro

yo solo veo uno ???
Y mirastes el mensaje que dice ESTE ES EL ARCHIVO A COLOCAR he eliminado el archivo errado y solo quedo el bueno

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by reginamor » Fri Jan 20, 2012 11:00 pm

vale, si yo veia solo ese, no sabia que habias modificado.
Muchas gracias ;)

User avatar
Active Member

Posts

Joined
Wed Sep 21, 2011 4:44 am

Post by jorobado32 » Sat Mar 10, 2012 1:42 am

De lujo, yo tenia el mismo problema y solucionado 100%, ahora quiero quitar un enlace que tengo puesto en esa plantilla de mi webmaster, cual es la plantilla a editar, Mil gracias por todo

Active Member

Posts

Joined
Sat Mar 10, 2012 12:24 am
Location - Spain

Post by arielito23 » Tue May 15, 2012 4:09 pm

yo tengo el mismo problema reemplace el order.php y tengo errores no se puede confirmar el pedido y envia este error

Code: Select all

Fatal error: Call to undefined method ModelCheckoutOrder::addOrder() in /home/xxx/public_html/xxx/catalog/controller/checkout/confirm.php on line 325
uso la version 1.5.2.1

New member

Posts

Joined
Sun May 06, 2012 2:01 pm

Post by celestial » Tue May 15, 2012 10:05 pm

arielito23 wrote:yo tengo el mismo problema reemplace el order.php y tengo errores no se puede confirmar el pedido y envia este error

Code: Select all

Fatal error: Call to undefined method ModelCheckoutOrder::addOrder() in /home/xxx/public_html/xxx/catalog/controller/checkout/confirm.php on line 325
uso la version 1.5.2.1
Revisa bien el foro el dia de ayer se soluciono esto, fijate que el archivo comprimido lleva un archivo errado pero mas abajo en el post esta solucionado el error, con esto no volveras a tener este problema, abajo esta el enlace.

http://forum.opencart.com/viewtopic.php?f=98&t=62722

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by arielito23 » Wed May 16, 2012 8:16 pm

geniooo!!!! gracias celestial , y pido perdon por no leerme bien el post :P

New member

Posts

Joined
Sun May 06, 2012 2:01 pm

Post by edusierram » Thu May 17, 2012 9:40 pm

Buenas tardes.

Yo tenia el mismo problema y logre solucionarlo gracias a vosotros. Lo único que no consigo eliminar el "ARRAY" que sale en el asunto del mail junto al numero de pedido. Si alguien sabe como hacerlo agradecería enormemente su ayuda. Mi versión es la 1.5.1.3.

Un saludo y muchas gracias por vuestra ayuda.

Newbie

Posts

Joined
Fri Nov 04, 2011 8:44 pm

Post by celestial » Thu May 17, 2012 9:56 pm

edusierram wrote:Buenas tardes.

Yo tenia el mismo problema y logre solucionarlo gracias a vosotros. Lo único que no consigo eliminar el "ARRAY" que sale en el asunto del mail junto al numero de pedido. Si alguien sabe como hacerlo agradecería enormemente su ayuda. Mi versión es la 1.5.1.3.

Un saludo y muchas gracias por vuestra ayuda.

Prueba cambiando esta linea:

$subject = sprintf($language->get('text_new_subject'), html_entity_decode($this->config->get('config_name'), ENT_QUOTES, 'UTF-8'), $order_id . ' (' . $order_total . ')');

Por esta

$subject = sprintf($language->get('text_new_subject'), html_entity_decode($this->config->get('config_name'), ENT_QUOTES, 'UTF-8'), $order_id);

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by edusierram » Fri May 18, 2012 3:19 pm

Perfecto! Muchas gracias. Lo he cambiado y ya no sale el ARRAY.

Newbie

Posts

Joined
Fri Nov 04, 2011 8:44 pm

Post by jorobado32 » Mon May 21, 2012 10:40 am

Hola de nuevo me vuelve a pasar, antes tenia la version 1.5.1.3 y con el archivo de celestial se soluciono, he actualizado a la version 1.5.2 y me vuelve a salir el correo feo y pobre hacia mi, he instalado el archivo de celstial y crea conflicto, da error, supongo que al ser de otra version. Alguna sugerencia o solucion?

Active Member

Posts

Joined
Sat Mar 10, 2012 12:24 am
Location - Spain

Post by celestial » Mon May 21, 2012 9:37 pm

jorobado32 wrote:Hola de nuevo me vuelve a pasar, antes tenia la version 1.5.1.3 y con el archivo de celestial se soluciono, he actualizado a la version 1.5.2 y me vuelve a salir el correo feo y pobre hacia mi, he instalado el archivo de celstial y crea conflicto, da error, supongo que al ser de otra version. Alguna sugerencia o solucion?
Aca esta:

http://forum.opencart.com/viewtopic.php ... 22#p288854

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica

Post by jorobado32 » Mon May 21, 2012 11:17 pm

Gracias Celestial, no lo habia visto, me fui directamente al post donde lo encontre la ultima vez

Active Member

Posts

Joined
Sat Mar 10, 2012 12:24 am
Location - Spain

Post by caag06 » Sun May 27, 2012 1:10 am

Saludos y muchas gracias.

Mi versión es 1.5.3.

He seguido este post y he seguido las instrucciones y usado los archivos aquí colgados pero nada. Aún llega el email del administrador con muy poca información mientras que el del comprador llega completo con logo.

¿Me podrían dar una mano por favor?

gracias por su atención.

Newbie

Posts

Joined
Fri Oct 14, 2011 12:49 am

Post by big2142 » Mon May 28, 2012 4:04 pm

caag06 wrote:Saludos y muchas gracias.

Mi versión es 1.5.3.

He seguido este post y he seguido las instrucciones y usado los archivos aquí colgados pero nada. Aún llega el email del administrador con muy poca información mientras que el del comprador llega completo con logo.

¿Me podrían dar una mano por favor?

gracias por su atención.
habrá que cambiar un poco los nuevos archivos, espera a que Celestial se pronuncie ;)

Newbie

Posts

Joined
Fri May 04, 2012 3:56 pm

Post by roobel » Wed Jul 18, 2012 5:54 pm

Refloto este tema para ver si hay solución en los que tenemos la versión 1.5.3.1
La verdad es que el mail que llega al administrador es de lo más cutre...No sé como no lo han arreglado ya en las nuevas versiones.
Celestial!! ¿Una ayudita de las tuyas?

Muchas Gracias!

New member

Posts

Joined
Tue Jun 05, 2012 10:32 pm

Post by rastafary » Thu Jul 19, 2012 12:31 am

yo tengo el mismo problema y es la version 1.5.2.1, algun buen samaritano que pueda apoyar ?

Newbie

Posts

Joined
Wed May 23, 2012 10:44 pm

Post by celestial » Thu Jul 19, 2012 12:55 am

roobel wrote:Refloto este tema para ver si hay solución en los que tenemos la versión 1.5.3.1
La verdad es que el mail que llega al administrador es de lo más cutre...No sé como no lo han arreglado ya en las nuevas versiones.
Celestial!! ¿Una ayudita de las tuyas?

Muchas Gracias!
PROBADO 2 VECES CON INSTALACION NUEVA DEL OC 1.5.3.1

Lean primero todo el mensaje, todo hasta el final y despues empiezan (lean y despues empiecen por donde dice OJO mas abajito)

Ok pon muchisima atencion a esto, te mando unos archivos en el zip que se llama catalog y necesito que primero respaldes cada uno de los archivos originales de tu tienda, NO VAYAS a copiar todo de un solo porque SOBREESCRIBIRAS archivos, ve uno por uno conforme la lista de archivos que viene en el zip, con paciencia respalda tu original anteponiendole un _ (por ejemplo _order.php). NOTA: si es instalacion nueva entonces no hay problemas en sobreescribir los archivos. SI TIENEN MODIFICACIONES PROPIAS EN ALGUNO DE LOS ARCHIVOS tendran que usar algun programa de comparacion para ver las diferencias.

Que hace esta modificacion, aparte de que te llega como administrador un email como el que le llega al cliente, en la factura van las imagenes de los productos, al igual cuando te vas a tu cuenta de usuarios y revisas el historial de ordenes ahi veras cada orden con sus imagenes.

OJO: Aparte de copiar los archivos del zip tendras que agregar un campo a la tabla oc_order_product (el oc_ es mi prefijo, si tienes otro lo usas o sino solo dejas el nombre de la tabla)

Nombre campo: image
Tipo: varchar
Logitud: 255
Predeterminado: NULL
Cotejamiento: utf8_bin

No respondo por la instalacion de esta modificacion en versiones que no es la que se indica al inicio ni al no seguimiento estricto de las indicaciones

Celestial - Martín Abel Rosales
WhatsApp: 50671482211
Email: martinrosales2012@hotmail.com
Skype: martin.abel.rosales
San José , Costa Rica


User avatar
Expert Member

Posts

Joined
Sat Mar 20, 2010 4:19 am
Location - Costa Rica
Who is online

Users browsing this forum: No registered users and 15 guests