Post by Eff2402 » Tue Jul 23, 2019 8:29 am

Tengo dos problemas con la conversión de la dirección http a https:

1.- Intentando navegar dentro de la web a la home, tengo el error siguiente:

No se puede acceder a este sitio web
No se ha podido encontrar la dirección IP del servidor de
https://bookmotoride.comindex.php (aparece sin la barra de separación entre bookmotoride.com e index.php)

2.- Por otra parte, si intento desde la home (poniendo correctamente la barra entre com e index) navegar a cualquier parte de la web, vuelve a mostrar http:// en vez https://

En Configuración la url de la tienda está como https://bookmotoride.com/
Por si es necesario, detallo el fichero .htaccess instalado

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled.
# 2. In your opencart directory rename htaccess.txt to .htaccess.
# For any support issues please visit: http://www.opencart.com
Options +FollowSymlinks
# Prevent Directoy listing
Options -Indexes
# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA,R=301]

### Additional Settings that may need to be enabled for some servers
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.
# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off
# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off
# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M
# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M
# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200
# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200
# 7. disable open_basedir limitations
# php_admin_value open_basedir none

Gracias, por vuestra ayuda.

Newbie

Posts

Joined
Sat Jul 20, 2019 1:45 am

Post by dharmawebstudio » Tue Jul 23, 2019 11:34 pm

Hola @Eff2402.

Dos cosas:

1. Configura la tienda en https en system > settings > edit store > pestaña servidor.
2. Revisar el fichero config.php y admin/config.php: en cada uno de ellos encontraras unas variables que se llaman HTTPS_SERVER y HTTPS_CATALOG; revisa que contengan https y no http y también revisa que ambas terminen en /


Un saludo.

Dharma Web Studio - Daniel Civit
Web Developer
Website: https://dharmawebstudio.com


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 6:33 am
Location - Madrid - Spain
Who is online

Users browsing this forum: No registered users and 12 guests