Page 1 of 1

Problema con SERVIRED

Posted: Sun May 30, 2010 2:22 am
by blinbdn
Hola a todos,

Tengo un problema, cuando instalo la contribución "Servired 1.0 para OC 1.3.2", que es mi versión de OC me deja configurarlo y eso.

Pero a la hora de realizar el pago, selecciono ese método de pago y me aparece lo siguiente en pantalla:
Error: Unknown column 'o.shipping_country_id' in 'on clause'
Error No: 1054
SELECT *, c1.iso_code_2 AS shipping_iso_code_2, c1.iso_code_3 AS shipping_iso_code_3, c2.iso_code_2 AS payment_iso_code_2, c2.iso_code_3 AS shipping_iso_code_3, z1.code AS shipping_zone_code, z2.code AS payment_zone_code FROM `order` o LEFT JOIN country c1 ON (o.shipping_country_id = c1.country_id) LEFT JOIN country c2 ON (o.payment_country_id = c2.country_id) LEFT JOIN zone z1 ON (o.payment_zone_id = z1.zone_id) LEFT JOIN zone z2 ON (o.payment_zone_id = z2.zone_id) WHERE o.order_id = '112'
Estoy desesperado, teneis idea de donde atacar? Lo necesito realmente esta TPV...

Muchas gracias de antemano!

Re: Problema con SERVIRED

Posted: Sun May 30, 2010 12:49 pm
by cofran
fijate esa columna de la tabla "order" que dice no existe a ver si realmente esta en la bbdd "shipping_country_id" y también corrobora que no lo esta haciendo con otros medios de pago también.

Re: Problema con SERVIRED [solucionado]

Posted: Wed Jul 14, 2010 7:50 pm
by tamystar
Hola, tengo un problema con el modulo de pagos Servired.
Me he instalado para la versión 1.3.2 pero en realidad tengo instalado el Opencart 1.3.4.
Al instalarlo me daba unos logs de error de que no encontraba el header y el footer de uno de los archivos, pero eso ya lo solucioné comentando esas lineas de código.
Aun así al entrar en la parte de administración en Editar, me redirige a una página en blanco.
Y lo mas raro es que no me registra ningún log de error.

¿Alguién me puede ayudar?, no creo que sea problema de versiones, ya que se supone que una versión mas antigua tiene k funcionar en una mas reciente, pero no sé.

NO se si existen mas módulos de servired para otras versiones de Opencart.

Gracias!!!

Re: Problema con SERVIRED

Posted: Wed Jul 14, 2010 10:56 pm
by cofran
proba esta versión de Servired: http://rapidshare.com/files/406930106/Servired_1.3.zip y comenta si te funciona bien con tu versión 1.3.4, antes desinstala la que pusiste y borra todos los archivos para que no haya ningún conflicto. ÇPor otro lado, de la versión 1.3.2 de Opencart a la 1.3.4 cambiaron varias cosas, y una de las tantas es el sistema de template por eso los errores del header y footer que comentas. Siempre utiliza contribuciones que sabes son para tu versión de Opencart y no para una anterior o posterior.

Saludos!

Re: Problema con SERVIRED

Posted: Thu Jul 15, 2010 3:41 pm
by tamystar
Muchas gracias cofran, este me funciona correctamente para mi version 1.3.4.

Gracias!!!