Post by lizardtoes » Wed Aug 14, 2013 9:59 pm

I am very sorry if I'm not presenting my case correctly. I have OC installed and it's working fine except for two things - first, almost all my orders are placed, automatically, into the 'Missing' category for some reason. (I didn't create this cat or even knew it existed until the first couple of orders came in) They're coming through Paypal. Because of this I get NO notification of new orders coming in and this is causing a customer service issue for me. Second, my Canadian customers are unable to order because they get no shipping options whatsoever even though I've enabled that country and filled out the parameters just like I did for the UK, Domestic, etc (which are all working just fine).

I have no idea what version I'm running, I can't seem to find that info. I apologize for being so dumb about this. I am not a developer (obviously) and am somewhat out of my element here. I know enough about cart software to be able to set up the shop and get everything in there, but these last two obstacles have me stumped. Rather than try to learn it in order to fix it myself, it's much easier for me to simply hire someone. So if someone here is an experienced dev and has a good, long board history/references I can check up on, I have real money to pay.

If this post is against board rules I am very sorry. Please point me to the proper area, if you would.

Thanks,
Kellie

Newbie

Posts

Joined
Wed Aug 14, 2013 9:49 pm

Post by butte » Wed Aug 14, 2013 11:53 pm

You can get a grip on your version under your admin log-in, unless the version was removed from the screen.

You can get an initial grip on the problem by searching (top right on page) for "missing orders PayPal" and then refining the onslaught a term or two at a time. There are solutions. You would at least have an idea, that way, of what is involved.

Guru Member

Posts

Joined
Wed Mar 20, 2013 6:58 am

Post by sb65 » Thu Aug 15, 2013 5:38 pm

Taking the Paypal issue first, it could be a number of things. Possibly you don't have the Paypal settings configured correctly on Opencart, so the messaging that's coming from Paypal is not correctly changing the Order Status and generating notification emails - check this under Extensions > Payments > [your Paypal option].

If these are OK, check that Paypal is sending the messages to you - do this from your Paypal account - History > IPN History. You should see a list of IPN messages (Instant Payment Notification) that correspond to successful payments. Check these are going to the right address. If you don't see any messages then check your settings under My Account > Profile > Instant Payment Notification.

If all this looks OK then it's conceivable that you have a problem with your server configuration which is preventing the IPN messages getting through. This is probably something to take up with your hosting company.

Turning to your Canadian orders, that's Opencart not set up properly. Very simply, you need to have a GeoZone set up which includes Canada - System > Localisation > GeoZones. Then you need to assign delivery costs to this zone via Extensions > Shipping > [your shipping option].

Drop me a PM if I can help.

New member

Posts

Joined
Tue Sep 20, 2011 9:18 pm

Post by paulfeakins » Thu Aug 15, 2013 6:50 pm

I'd echo the comments above about PayPal IPN, I wrote a blog post about this here:
http://www.antropy.co.uk/blog/opencart- ... owing-ipn/

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom
Who is online

Users browsing this forum: No registered users and 5 guests