Post by mickey25m » Mon Nov 23, 2020 8:24 pm

Hi everybody,

i have multiple shops in opencart de latest is on 3.0.3.6 with journal theme, vqmod and some extensions.

everything is stable but sometimes i get this error see image.

when i upload the files vqmod.php and patheReplaces.php everything is good.

my memory for php is not the problem now i set it to 512MB so thats a lott.
is there a problem with the latest vqmod 2.6.4? i have i with other versions also. but i dont know now where to search. i already make a fresh copy of everything.

the store works good but one in a couple days +/- 7 days) i get this problem.
---
Paid Theme, obtained outside of OpenCart, topic moved to the commercial Forum ....

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by TrishL » Mon Nov 23, 2020 8:34 pm

Hello,
I can help you.
PM sent, please check.
BR
Trish

Professional Opencart Developer
Email - trish.c@talentsfromindia.com


Newbie

Posts

Joined
Mon Nov 09, 2020 5:39 pm

Post by straightlight » Mon Nov 23, 2020 8:34 pm

Possibly cache errors. Try the VQMod Integrated version here and see if that solves the issue: https://www.opencart.com/index.php?rout ... n_id=19501 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by mickey25m » Mon Nov 23, 2020 9:02 pm

ok install that i hope so.

do i need to delete the vqmod folder ?

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by straightlight » Mon Nov 23, 2020 9:03 pm

mickey25m wrote:
Mon Nov 23, 2020 9:02 pm
ok install that i hope so.

do i need to delete the vqmod folder ?
Yes, uninstall the old version before installing the new one and ensure to keep your XML extension files.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by mickey25m » Mon Nov 23, 2020 9:07 pm

uninstall is like replace the index.php in public and admin for the original right?

then delete the vqmod folder (or rename) and then install the extension again ?

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by straightlight » Mon Nov 23, 2020 9:19 pm

mickey25m wrote:
Mon Nov 23, 2020 9:07 pm
uninstall is like replace the index.php in public and admin for the original right?

then delete the vqmod folder (or rename) and then install the extension again ?
Yes. As long as you first replace the original index.php and admin/index.php of the OC version you're using.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by mickey25m » Mon Nov 23, 2020 9:23 pm

he dont use now the files in the vqmod/xml folder.

i replace index.php and admin/index.php
i install the module make it actief change user rights
refresh modifications

what do i wrong ?

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by mickey25m » Mon Nov 23, 2020 9:25 pm

Fatal error: Uncaught Twig\Error\SyntaxError: Unknown "html_variables" function. in /var/www/vhosts/nl/domains/nl/storage/modification/admin/view/template/common/header.twig:4 Stack trace: #0 /var/www/vhosts/nl/domains/nl/storage/vendor/twig/twig/src/ExpressionParser.php(451): Twig\ExpressionParser->getFunctionNodeClass('html_variables', 4) #1 /var/www/vhosts/nl/domains/nl/storage/vendor/twig/twig/src/ExpressionParser.php(235): Twig\ExpressionParser->getFunctionNode('html_variables', 4) #2 /var/www/vhosts/nl/domains/nl/storage/vendor/twig/twig/src/ExpressionParser.php(175): Twig\ExpressionParser->parsePrimaryExpression() #3 /var/www/vhosts/nl/domains/nl/storage/vendor/twig/twig/src/ExpressionParser.php(70): Twig\ExpressionParser->getPrimary() #4 /var/www/vhosts/nl/domains/nl/storage/vendor/twig/twig/src/Parser.php(142): Twig\ExpressionParser->parseExpressio in /var/www/vhosts/nl/domains/nl/storage/modification/admin/view/template/common/header.twig on line 4

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by straightlight » Mon Nov 23, 2020 10:19 pm

Caused by an older installed extensions you might be using where it may not support the latest version of VQMod. Disable the XML files one-by-one with the exception of vqmod_opencart.xml file and see if that solves the issue.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by mickey25m » Tue Nov 24, 2020 3:43 am

thats the newest extension from mollie i think (payment)

i will check tommorow

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by mickey25m » Tue Nov 24, 2020 4:57 pm

Fatal error: Uncaught Error: Class 'util\Util' not found in /var/www/vhosts/.nl/httpdocs/catalog/model/payment/mollie/base.php:112 Stack trace: #0 /var/www/vhosts/.nl/storage/modification/system/engine/loader.php(256): ModelPaymentMollieBase->getMethod(Array, 99.949993) #1 /var/www/vhosts/.nl/httpdocs/system/engine/proxy.php(47): Loader->{closure}(Array, Array) #2 /var/www/vhosts/.nl/httpdocs/catalog/model/journal3/checkout.php(618): Proxy->__call('getMethod', Array) #3 /var/www/vhosts/.nl/httpdocs/catalog/model/journal3/checkout.php(257): ModelJournal3Checkout->payment_methods(99.949993) #4 /var/www/vhosts/.nl/httpdocs/catalog/model/journal3/checkout.php(81): ModelJournal3Checkout->sync() #5 /var/www/vhosts/.nl/storage/modification/system/engine/loader.php(256): ModelJournal3Checkout->init() #6 /var/www/vhosts/.nl/httpdocs/system/engine/proxy.php(47): Loader->{closure}(Array, Array) #7 /var/www/vhosts/.nl/storage/modificati in /var/www/vhosts/.nl/httpdocs/catalog/model/payment/mollie/base.php on line 112

New member

Posts

Joined
Sat Aug 13, 2011 6:14 pm

Post by straightlight » Thu Nov 26, 2020 9:57 pm

Either contact the extension developer or contact me directly via PM to get this resolved as a custom job.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member
Online

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 12 guests