Post by antstyl » Tue Mar 05, 2013 6:08 pm

Καλημέρα σε όλους,

όταν προσπαθεί κάποιος να επικοινωνήσει με email μέσω της φόρμας επικοινωνίας του eshop βγάζει το εξής σφάλμα.


2013-03-05 12:03:07 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: php_network_getaddresses: getaddrinfo failed: No address associated with hostname in /var/www/vhosts/store/system/library/mail.php on line 153
2013-03-05 12:03:07 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to mail.*.gr:25 (php_network_getaddresses: getaddrinfo failed: No address associated with hostname) in /var/www/vhosts/store/system/library/mail.php on line 153
2013-03-05 12:03:07 - PHP Notice: Error: php_network_getaddresses: getaddrinfo failed: No address associated with hostname (0) in /var/www/vhosts/store/system/library/mail.php on line 156


Γνωρίζει κανείς τι μπορεί να φταίει? Έψαξα αλλά δεν βρήκα τίποτα και είναι σημαντικό πρόβλημα..
Last edited by antstyl on Thu Nov 14, 2013 3:07 pm, edited 1 time in total.

User avatar
Active Member

Posts

Joined
Mon Nov 12, 2012 5:40 pm

Post by Opencart-Hellas » Tue Mar 05, 2013 6:17 pm

Έχει ξανασυμβεί ανάλογο πρόβλημα. Τη προηγούμενη φορά οφειλόταν σε προβληματικά αρχεία μετάφρασης. Δοκίμασε να στείλεις μήνυμα με αγγλική μετάφραση και δες αν σου παρουσιάζει το ίδιο πρόβλημα.

Opencart-Hellas.gr - Η Ελληνική κοινότητα του Opencart
Πλήρης Ελληνική μετάφραση OpenCart


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 5:30 am
Location - Athens, Hellas

Post by antstyl » Tue Mar 05, 2013 6:20 pm

Να αλλάξω την γλώσσα του καταστήματος σε Αγγλική δηλαδή?

User avatar
Active Member

Posts

Joined
Mon Nov 12, 2012 5:40 pm

Post by Opencart-Hellas » Tue Mar 05, 2013 6:24 pm

Αν σου είναι εύκολο και είναι δίγλωσσο ναι, δοκίμασε το, μπορεί να φταίει κάποιο αρχείο ελληνικής μετάφρασης. Βεβαιώσου επίσης ότι δεν έχεις δηλώσει με λάθος τρόπο εναλλακτικά emails.

Opencart-Hellas.gr - Η Ελληνική κοινότητα του Opencart
Πλήρης Ελληνική μετάφραση OpenCart


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 5:30 am
Location - Athens, Hellas

Post by antstyl » Tue Mar 05, 2013 6:29 pm

Τα αρχεία γλώσσας τα έχω μέσα στον server αλλά έχω διαγράψει την αγγλική γλώσσα από το admin για να μην έχει τα πεδία.

Εναλλακτικα emails δεν έχω στο κατάστημα, μόνο προώθησει έχω βάλει στις ρυθμίσεις του email όμως.
Δική σου μετάφραση χρησιμοποιώ, δεν ξέρω όμως αν έχω κάνει κάποια άλλη αλλαγή εγώ και το επηρέασε.
Μπορώ να κάνω κάτι άλλο?

User avatar
Active Member

Posts

Joined
Mon Nov 12, 2012 5:40 pm

Post by Opencart-Hellas » Tue Mar 05, 2013 6:38 pm

Στο tab mail αφαίρεσε δοκιμαστικά οτιδήποτε email προώθησης και άσε μόνο το γενικό email του καταστήματος στο tab Γενικά.

Opencart-Hellas.gr - Η Ελληνική κοινότητα του Opencart
Πλήρης Ελληνική μετάφραση OpenCart


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 5:30 am
Location - Athens, Hellas

Post by antstyl » Tue Mar 05, 2013 7:00 pm

Διευκρίνιση: Στο tab mail δεν έχω βάλει κάποιο email στο Επιπρόσθετα Emails Ειδοποιήσεων:

Να σβήσω τα πάντα από το tab mail ή μόνο το email που έχω?

User avatar
Active Member

Posts

Joined
Mon Nov 12, 2012 5:40 pm

Post by Opencart-Hellas » Tue Mar 05, 2013 7:06 pm

Δηλαδή έχεις στο κατάστημα μόνο ένα email δηλωμένο στο General ?

Opencart-Hellas.gr - Η Ελληνική κοινότητα του Opencart
Πλήρης Ελληνική μετάφραση OpenCart


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 5:30 am
Location - Athens, Hellas

Post by antstyl » Tue Mar 05, 2013 7:14 pm

ναι ένα μόνο, αυτό που έχω και στο tab mail

User avatar
Active Member

Posts

Joined
Mon Nov 12, 2012 5:40 pm

Post by Opencart-Hellas » Tue Mar 05, 2013 7:18 pm

Που ακριβώς στο tab mail έχεις δηλώσει ξανά το email ? και τι μέθοδο email έχεις δηλώσει (mail/smtp).

Opencart-Hellas.gr - Η Ελληνική κοινότητα του Opencart
Πλήρης Ελληνική μετάφραση OpenCart


User avatar
Active Member

Posts

Joined
Fri Jul 27, 2012 5:30 am
Location - Athens, Hellas

Post by antstyl » Wed Mar 06, 2013 3:36 am

Ύστερα από άπειρη υπομονή του Opencart-Hellas (Χίλια ευχαριστώ για άλλη μια φορά) και όσα δοκιμάσαμε,

βρέθηκε λύση και την παραθέτω για όποιον αντιμετωπίσει ίδιο πρόβλημα στο μέλλον (γιατί από ότι είδα είναι συχνό).


Αντικατάσταση στο sytem/library/mail.php στην γραμμή 97,

Code: Select all

$header .= 'Content-Type: multipart/related; boundary="' . $boundary . '"' . $this->newline . $this->newline;
με αυτό

Code: Select all

$header .= 'Content-Type: multipart/related; boundary="' . $boundary . '"' . $this->newline;

User avatar
Active Member

Posts

Joined
Mon Nov 12, 2012 5:40 pm

Post by pedtros » Wed Jun 19, 2013 10:41 pm

Τα ίδια error εχω κι εγώ.
Έκανα τις αλλαγές που υποδεικνύετε, αλλά πάλι έχω πρόβλημα. Δηλαδή πότε δουλεύει και πότε όχι.
Στο error log βλέπω τα εξής:
2013-06-19 13:56:29 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: php_network_getaddresses: getaddrinfo failed: Name or service not known in /home/******/public_html/********/system/library/mail.php on line 153

2013-06-19 13:56:29 - PHP Warning: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to mail.d*****-******.gr :25 (php_network_getaddresses: getaddrinfo failed: Name or service not known) in /home/********/public_html/*********.gr/system/library/mail.php on line 153

2013-06-19 13:56:29 - PHP Notice: Error: php_network_getaddresses: getaddrinfo failed: Name or service not known (0) in /home/*********/public_html/**********.gr/system/library/mail.php on line 156

2013-06-19 14:18:03 - PHP Notice: Error: EHLO not accepted from server! in /home/*********/public_html/**********.gr/system/library/mail.php on line 200

2013-06-19 14:20:59 - PHP Notice: Error: EHLO not accepted from server! in /home/*********/public_html/*********.gr/system/library/mail.php on line 200

2013-06-19 14:21:37 - PHP Notice: Error: EHLO not accepted from server! in /home/**********/public_html/*********.gr/system/library/mail.php on line 200
Το δοκίμασα και με Mail και με SMTP. Πριν δούλευε με SMTP και δούλευε κανονικά. Ξαφνικά μου παρουσίασε το πρόβλημα πριν απο 2-3 μέρες... Μπορεί κάποιος να με βοηθήσει? Το OC μου είναι το 1.5.2.1
Ευχαριστώ.

New member

Posts

Joined
Sat Mar 24, 2012 5:53 am

Post by pedtros » Thu Jun 20, 2013 4:34 pm

Καλημέρα... Ζητώ απεγνωσμένα πια την βοήθειά σας γιατί θα μου στρίψει με την περίπτωση αυτή.
Ενώ όλα δούλευαν κανονικότατα στα mail, ξαφνικά μια μέρα αποφάσισε απο μόνο του το σύστημα να χαλάσει...???
Τώρα, με την ρύθμιση mail αντι για SMTP που είχα πριν, λαμβάνω τα μηνύματα απο την επικοινωνία, αλλά δεν λαμβάνω τις παραγγελίες... Με την SMTP δεν λαμβάνω τίποτα...
Τα νέα error που βρήκα στο log είναι:
2013-06-19 21:04:54 - PHP Warning: unlink(/home/ecotherm/public_html/discount-store.gr/system/cache/cache.product.2.0.8.eb95305719ad8db9c175206ef48b3873.1371675826) [<a href='function.unlink'>function.unlink</a>]: No such file or directory in /home/ecotherm/public_html/discount-store.gr/system/library/cache.php on line 14

2013-06-20 8:06:53 - PHP Notice: Error: RCPT TO not accepted from server! in /home/ecotherm/public_html/discount-store.gr/system/library/mail.php on line 308

2013-06-20 8:11:38 - PHP Notice: Error: HELO not accepted from server! in /home/ecotherm/public_html/discount-store.gr/system/library/mail.php on line 268
Η προηγούμενη λύση που έδωσε ό φίλος antstyl σε μένα δεν δούλεψε :-\
Αν υπάρχει κάποια πρόταση, θα ήμουν υπόχρεος... Μέχρι που σκέφτομαι ν' αλλάξω server. Αλλιώς δεν μπορώ να εξηγήσω την ξαφνική αλλαγή συμπεριφοράς του συστήματος.. Ενώ δηλ. πριν απο 3-4 ημέρες δούλευε κανονικά και σήμερα οχι, σημαίνει ή ότι κάνανε κάποια αναβάθμιση ή κάποια συντήρηση και τους ξέφυγε κάτι... Κάνω λάθος?

New member

Posts

Joined
Sat Mar 24, 2012 5:53 am

Post by alexharalam12270 » Mon Jul 15, 2013 4:17 pm

Παιδιά και εγώ έχω πρόβλημα με το email. Θέλω να το συνδέσω με ένα hotmail και βάζω τα παρακάτω στοιχεία
Image και δεν στέλνει τα email χωρίς όμως να μου βγάζει μήνυμα σφάλματος. Υπάρχει περίπτωση να φταίει επειδή είναι localhost;

My Profile


New member

Posts

Joined
Sun Jul 14, 2013 3:05 pm
Location - Greece

Post by gkasios » Mon Jul 15, 2013 4:33 pm

Όταν θέλουμε να χρησιμοποιήσουμε SMTP πρέπει να το επιλέξουμε και εκεί που λέει Mail Protocol

Our Extensions


User avatar
New member

Posts

Joined
Tue Jan 08, 2013 1:57 am


Post by alexharalam12270 » Mon Jul 15, 2013 4:44 pm

Τώρα μου βγάζει αυτό
Notice: Error: AUTH LOGIN not accepted from server! in C:\xampp\htdocs\(ΔΙΕΓΡΑΨΑ ΑΠΟ ΕΔΩ ΤΟ ΟΝΟΜΑ ΤΟΥ ΦΑΚΕΛΟΥ)\system\library\mail.php on line 217

My Profile


New member

Posts

Joined
Sun Jul 14, 2013 3:05 pm
Location - Greece

Post by gkasios » Mon Jul 15, 2013 7:12 pm

Δοκιμάστε με τα ακόλουθα στοιχεία
SMTP Host: ssl://smtp.live.com
SMTP Port: 587

Our Extensions


User avatar
New member

Posts

Joined
Tue Jan 08, 2013 1:57 am


Post by alexharalam12270 » Fri Aug 09, 2013 4:21 am

Λοιπόν [SOLVED]. Έφταιγε το localhost. Πρέπει να ανεβάσεις το site σε webserver για να λειτουργει κανόνικα το συστημα email

My Profile


New member

Posts

Joined
Sun Jul 14, 2013 3:05 pm
Location - Greece
Who is online

Users browsing this forum: No registered users and 5 guests