Page 1 of 1

Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 4:20 pm
by antonist
Είναι μια εβδομάδα τώρα που παρατηρώ δυσλειτουργία του site μου. Χάνονται καταχωρήσεις, πωλήσεις κλπ. Είμαι στο admin και καταχωρώ ...και βλέπω τις αλλαγές στο site να γίνονται κανονικά, παράλληλα μου έρχονται και πωλήσεις που ευτυχώς επιβεβαιώνονται από το gmail. Όταν βγώ από το site και από το admin και πάω να μπω μετά από λίγη ώρα, έχουν όλα χαθεί. Το περίεργο είναι ότι από το phpMyadmin βλέπω πχ ότι πελάτης που καταχωρήθηκε λίγο πριν... υπάρχει στην βάση αλλά στο admin δεν εμφανίζεται. Μάλιστα εάν προσπαθήσω να τον καταχωρήσω εγώ (με το email του), μου λέει ότι η εγγραφή υπάρχει. Έτσι κατέληξα τις τελευταίες μέρες να καταχωρώ 2-3 φορές τις αλλαγές για να τις δεχτεί.

Είμαι στην έκδοση 1.5.6 και χρησιμοποιώ όλους τους browsers και διαφορετικά PC, ώστε να μην πω ότι υπάρχει κάποιος ιός.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 4:50 pm
by OpDev
Υπάρχει δυνατότητα να κάνεις import τη βάση σε μια νέα εγκατάσταση του opencart;(είτε localhost είτε σε κάποιο subdomain που ίσως έχεις)

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 7:24 pm
by antonist
Λίγο δύσκολο... πιο εύκολο θα ήταν να το κάνω πάνω στο υπάρχον. Αλλά γιατί ; δεν έχω αλλάξει κάτι στο κώδικα εδώ και μήνες. Αυτό όμως που άλλαξε είναι ότι ο server μου, τις τελευταίες μέρες άλλαξε από cpanel.xion.arvixe.com σε aardvark.arvixe.com, (δηλαδή με ενημέρωσαν για αυτό ότι θα γίνει) χωρίς να χρειάζεται να κάνω κάτι εγώ. Αλλά πάλι δεν καταλαβαίνω γιατί πρέπει να κάνω τις καταχωρήσεις 2-3 φορές μέχρι να αποθηκευτούν σίγουρα. Βέβαια παίρνω backup αλλά δεν μπορεί να συνεχίζεται αυτό σε κάθε καταχώρηση...

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 7:36 pm
by Opencart-Hellas
Από το phpmyadmin έλεγξε αν υπάρχουν διπλοκαταχωρήσεις στη βάση με το ίδιο ID (σε παραγγελίες, προϊόντα, κλπ).

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 7:46 pm
by antonist
Και ένα καινούργιο στοιχείο... παρατήρησα κάποιες από τις τελευταίες φορές, ενώ είμαι μέσα στο admin, με πετάει έξω και όταν ξαναμπώ ήδη έχει χάσει ότι καταχωρήσεις είχα κάνει.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 8:14 pm
by OpDev
Μήπως την μία κοιτάς την παλιά βάση και μία την καινούργια;

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 8:26 pm
by antonist
Τσεκάρησα ότι δεν έχω διπλές εγγραφές, ούτε στα προϊόντα ούτε στις παραγγελίες. Μάλιστα είδα ότι στην database υπάρχουν οι τελευταίες εγγραφές που καταχώρησα προϊόντα, αλλά δεν εμφανίζονται ούτε στο admin ούτε στο front. Δηλαδή άν κατάλαβα καλά, εγώ καταχωρώ, οι πωλήσεις γίνονται, η database ενημερώνεται και κάποια στιγμή με πετάει έξω ο server ;;; ξανακάνω login και όταν ξαναμπαίνω δεν βλέπω τις καταχωρήσεις ...αλλά η database τις έχει!

Mια τρέλα δηλαδή και δεν ξέρω που και τι να ψάξω.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 8:30 pm
by OpDev
Κοίταξε το config οτι κοιτάει την ίδια βάση με αυτή που εσύ διαχειρίζεσαι.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 8:40 pm
by antonist
Το config είναι OK, αλλά όπως προανέφερα κάτι για τους servers του παρόχου, μου είπαν ότι μεταφερόμαστε από τον xion.arvixe.com στον aardvark.arvixe.com, αλλά από ότι βλέπω έχω πρόσβαση και στους 2, φαίνεται ότι μάλλον γίνεται mirroring (αν και δεν κατέχω πολλά περί τούτου)

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 8:55 pm
by Opencart-Hellas
Σχετικά με αυτό που ανέφερες ότι έχεις πρόσβαση και στους δύο servers, κάνε ping στο domain του καταστήματος σου από το pc σου και δες τι IP βλέπεις. Μετά κάνε ping στο νέο και στο παλιό server και αν ταυτίζεται η IP του καταστήματος σου με τον νέο server τότε από άποψη DNS βλέπεις τον νέο server και σε αυτό το κατάστημα κάνεις login (δεν παίζει ρόλο αν δεν έχουν κατεβάσει ακόμα τον παλιό server και δηλώνοντας στο url τον παλιό server να μπορείς να μπείς στο cpanel του).
Και ένα καινούργιο στοιχείο... παρατήρησα κάποιες από τις τελευταίες φορές, ενώ είμαι μέσα στο admin, με πετάει έξω και όταν ξαναμπώ ήδη έχει χάσει ότι καταχωρήσεις είχα κάνει.
Ενδέχεται να προέκυψε πρόβλημα αποθήκευσης των sessions μετά το update που σου έκαναν.
Πρώτα έλεγξε ότι υπάρχει το php.ini της εγκατάστασης του Opencart στον φάκελο του καταστήματος.
Έλεγξε επίσης το error log σου αν αν εμφανίζει καταχωρήσεις που σχετίζονται με session. Επίσης έλεγξε αν ο σκληρός σου είναι γεμάτος και δεν έχεις άλλη διαθέσιμη χωρητικότητα. Δοκίμασε και να διαγράψεις τα cache στο system/cache.
Συμβουλέψου τον πάροχο σου να σε βοηθήσει να εντοπίσεις αν το session.save_path είναι σωστά δηλωμένο με τα κατάλληλα permissions και αν καταχωρούνται τα sessions.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 9:22 pm
by antonist
Και οι 2 servers έχουν την ίδια shared IP και κάνοντας ping απο το pc μου στο site βλέπω ότι χρησιμοποιεί αυτήν την IP. Έχω πρόσβαση και στα 2 cpanel και βλέπω τα ίδια ακριβώς (προφανώς αυτην την στιγμή γίνεται mirroring). Το δε error log είναι κενό. Όσο για το php.ini το έχω απενεργοποιήσει εδώ και μήνες όταν προέκυψε κάποιο θέμα πρόσβασης και με προέτρεψαν να το κάνω rename και από τότε δουλεύω έτσι. Το τελευταίο μέρος είναι της συμβουλής σας είναι και το σκληρότερο και πιο χρονοβόρο, οπότε... δεν έχω και κάτι άλλο να κάνω. Ευχαριστώ πολύ πάντως για την συμμετοχή στο πρόβλημα μου.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 9:31 pm
by Opencart-Hellas
Και οι 2 servers έχουν την ίδια shared IP και κάνοντας ping απο το pc μου στο site
Αυτό που αναφέρεις δεν γίνεται. Shared IP μπορούν να έχουν μόνο virtual domains και όχι server hostnames εν λειτουργία (ακόμα και VPS). Μάλλον θα άλλαξαν το hostname του server και η IP παρέμεινε η ίδια και δεν κατάλαβες τι εννοούσαν.
Όπως και νάχει επικοινώνησε με το τμήμα τχνικής υποστήριξης του παρόχου σου και ζήτα τους να σου εξηγήσουν να καταλάβεις τι ακριβώς έκαναν και να εντοπίσουν γιατί από τότε που έγινε η αλλαγή έχεις πρόβλημα με τα sessions.

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 9:45 pm
by antonist
Όσο επικοινωνούσαμε εμείς εδώ το admin με πέταξε έξω 3-4 φορές και κάθε που έκανα login έβλεπα την τελευταία μου πώληση ...την μια στιγμή να την βλέπω, μαζί με κάτι καταχωρήσεις προιόντων και στο επόμενο login να χάνονται (όλα αυτά μέσα σε 5-10'). Παίζουν με τα νεύρα μου ή μου φαίνεται;

Re: Χάνονται οι καταχωρήσεις...

Posted: Fri Jul 11, 2014 10:05 pm
by Opencart-Hellas
Κοίταξα λίγο τα IP's των hostnames, είναι διαφορετικά.
Αν δεν βρεις λύση με την τεχνική υποστήριξη, κατέβασε πλήρες backup του domain σου και της βάσης από το cPanel και εγκατέστησε τα offline σε XAMPP. Εκεί έλεγξε αν όλα λειτουργούν σωστά για να διαπιστώσεις αν υπάρχει πρόβλημα στο server ή στην εφαρμογή και ανάλογα κινήσου με τον hoster.

Re: Χάνονται οι καταχωρήσεις...

Posted: Sat Jul 12, 2014 1:58 am
by antonist
Έχω ξεκινήσει επικοινωνία με τον hoster. Ευχαριστώ πολύ για το support σας.

Re: Χάνονται οι καταχωρήσεις...

Posted: Tue Jul 15, 2014 2:54 pm
by antonist
Επειδή βρήκα τη λύση στο πρόβλημά μου, είπα να το μοιραστώ μαζί σας μήπως και βοηθήσω κάποιον άλλο φορουμίστα με παρόμοιο πρόβλημα. Κάποια στιγμή πριν καιρό, ο hoster μου πρότεινε-προέτρεψε να κάνω χρήση της υπηρεσίας cloudflare όπου με κάποιον wizard που διαθέτουν ολοκλήρωσα την διαδικασία και μπήκα στο free plan. Καθώς λοιπόν ψαχνόμουν στο cpanel θυμήθηκα αυτήν την υπηρεσία και μπαίνοντας στις ρυθμίσεις του, είδα ότι χρησιμοποιούσε σαν IP την παλιά που είχε ο προηγούμενος server. Το άλλαξα και καταχώρησα την καινούργια IP του Server και από τότε σταμάτησε και το πρόβλημα. Λυπάμαι για τον τίτλο που έβαλα "χάνονται οι καταχωρήσεις" γιατί τελικά αυτό που συνέβαινε ήταν πιο περίεργο. Χρησιμοποιώντας το System Information του admin, όταν δούλευε σωστά ...μου έδειχνε ότι εκείνη την στιγμή βρισκόμουν στον καινούργιο server. Όταν με πέταγε έξω και ξαναέκανα login, πήγαινα στο System Information του admin και τότε μου εμφάνιζε ότι βρισκόμουν στον παλιό server (χωρίς φυσικά τις τελευταίες προσθήκες). Αυτά...!

Re: Χάνονται οι καταχωρήσεις...

Posted: Tue Jul 15, 2014 8:55 pm
by Opencart-Hellas
Αν θες ρίξε μια ματιά στα "Page Rules". Από εκεί μπορείς να απενεργοποιήσεις το CDN για κάποιο path όπως πχ η διαχείριση.

Re: Χάνονται οι καταχωρήσεις...

Posted: Tue Jul 15, 2014 9:32 pm
by antonist
Το κοίταξα... αλλά δεν έχω βάλει καθόλου rules.

Re: Χάνονται οι καταχωρήσεις...

Posted: Wed Jul 16, 2014 3:50 am
by Opencart-Hellas
Το έχω καταλάβει. Αν παρουσιαστεί οποιοδήποτε πρόβλημα στο μέλλον, μπορείς να δηλώνεις στα page rules του cloudflare κάποιο path που να εξαιρείται από το caching που κάνει (πχ το path του admin). Έτσι θα μπορείς πιο εύκολα να εντοπίζεις πιθανά προβλήματα.