Moderator: madimar

Post by famarinu » Tue Jan 19, 2016 4:28 pm

Buongiorno,
conoscete un modulo per OC 2.1 free che disabilita il tasto destro del mouse?
su questo sito ne ho trovato solo uno ed utilizzza vqmod e non lo ho installato, se ne conoscete un'altro evito d'installare vqmod.
Grazie!

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by vcabreu.py » Wed Jan 20, 2016 12:25 am

Buongiorno.

Fare uso del JAVASCRIPT con JQUERY para esto.

File ->/catalog/view/javascript/common.js

aggiungere alla fine:

Code: Select all

$(function() {
	$(this).bind("contextmenu", function(e) {
		e.preventDefault();
	});
});
:joker:

User avatar
Newbie

Posts

Joined
Thu Jan 14, 2016 12:30 am
Location - Americana | São Paulo | Brazil


Post by madimar » Fri Jan 22, 2016 2:45 pm

faccio solo un commento su vqmod. E' vero che OC2 ha il suo ocmod ma oggi ci sono ancora tante extension basate su vqmod e, a mio modesto parere, non ha senso farne a meno.
Ciao,
M

Inviato dal mio Find 5 utilizzando Tapatalk

-----------------------------------------------------------------------
My last mods: Partita IVA e CF | Pro EU VAT Number | Sales Agents | Pricelist Pro
-----------------------------------------------------------------------


User avatar
Active Member

Posts

Joined
Thu Sep 24, 2009 6:27 pm


Post by famarinu » Fri Jan 22, 2016 3:26 pm

scusa madimar, mi potresti spiegare che cos'è vqmod? non l'ho mai preso in considerazione perchè pernsavo che facesse parte solo di OC1

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by Burt65 » Mon Jan 25, 2016 7:30 pm

OCMOD e basato su Vqmod e puoi usarli entrambi senza problemi.

Vqmod non ha niente a che vedere con la versione di Opencart che usi, mentre OCMOD e stato integrato nel nuovo Opencart. Ci sono moltissime estensioni che usano solamente Vqmod, quindi non e` che hai una propria scelta. Se vuoi usare quelle estensioni dovrai installare VQmod.

Over 95% of all computer problems can be traced back to the interface between the keyboard and the chair...


User avatar
Active Member

Posts

Joined
Mon Nov 18, 2013 3:23 pm
Location - Oz

Post by madimar » Tue Jan 26, 2016 3:37 pm

famarinu wrote:scusa madimar, mi potresti spiegare che cos'è vqmod? non l'ho mai preso in considerazione perchè pernsavo che facesse parte solo di OC1
Provo a fare ordine. Vqmod é un tool, sviluppato da dei veterani di Opencart e perfezionato negli anni. Esso permette, attraverso script xml, di apportare delle modifiche virtuali al codice di base, senza appunto dover modificare permanentemente i file originali.
Vqmod é stata la chiave degli sviluppo di Opencart e dell'extension store negli ultimi anni, avendo reso più semplice la gestione delle extension di terze parti ed è diventato lo standard de facto negli anni scorsi.
Quando la versione 2 di Opencart é stata pianificata, si é discusso tanto di integrare vqmod nel core di Opencart ma alla fine l'owner di Opencart ha deciso di creare da zero una mezza copia di VQMOD chiamandola Ocmod, suscitando tra l'altro le proteste della maggior parte degli sviluppatori.

Detto questo, ora la situazione é che ci sono due sistemi utilizzabili anche contemporaneamente senza conflitti per gestire le extension, ocmod e vqmod. Nessun problema dunque ad installare anche vqmod ed aprirsi la porta ad un mondo di extension ancora sviluppate e basate su di esso.

Spero di aver chiarito,

M

Inviato dal mio Find 5 utilizzando Tapatalk

-----------------------------------------------------------------------
My last mods: Partita IVA e CF | Pro EU VAT Number | Sales Agents | Pricelist Pro
-----------------------------------------------------------------------


User avatar
Active Member

Posts

Joined
Thu Sep 24, 2009 6:27 pm


Post by famarinu » Tue Jan 26, 2016 5:45 pm

Molto chiara la spiegazione, provo ad installarlo
grazie!

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by famarinu » Mon Feb 15, 2016 9:17 pm

l'ho installato, ma ora vorrei disinstallarlo perchè mi da un errore, come faccio? elimino la cartella da ftp?

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by carlocozzetto » Mon Feb 15, 2016 10:01 pm

Una Domanda, avendo trovato un'estensione che richiedeva vqmod, premettendo che una versione 2, avendo problemi di FTP che non mi fa accedere dall'installatore di estensioni, ho caricato la cartella del vqmod e l'ho installata nella root del sito, seguendo le istruzioni per le versioni 1 di OP, ho fatto giusto o ho sbagliato?
Comunque sia l'estensione non funziona...

User avatar
New member

Posts

Joined
Sat Feb 13, 2016 11:29 pm

Post by raikage » Tue Feb 16, 2016 2:37 am

carlocozzetto wrote:Una Domanda, avendo trovato un'estensione che richiedeva vqmod, premettendo che una versione 2, avendo problemi di FTP che non mi fa accedere dall'installatore di estensioni, ho caricato la cartella del vqmod e l'ho installata nella root del sito, seguendo le istruzioni per le versioni 1 di OP, ho fatto giusto o ho sbagliato?
Comunque sia l'estensione non funziona...
allora i file vqmod nn possono essere caricati dall'installatore di estensioni,da li si caricano solo gli ocmod e basta!!!.

i file vqmod devono essere copiati nella cartella vqmod/xml che sono dei file con estensione .xml
se non vanno e perchè probabilmente bisogna adattare il codice al template che si utilizza.

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by carlocozzetto » Tue Feb 16, 2016 3:37 pm

raikage wrote:
carlocozzetto wrote:Una Domanda, avendo trovato un'estensione che richiedeva vqmod, premettendo che una versione 2, avendo problemi di FTP che non mi fa accedere dall'installatore di estensioni, ho caricato la cartella del vqmod e l'ho installata nella root del sito, seguendo le istruzioni per le versioni 1 di OP, ho fatto giusto o ho sbagliato?
Comunque sia l'estensione non funziona...
allora i file vqmod nn possono essere caricati dall'installatore di estensioni,da li si caricano solo gli ocmod e basta!!!.

i file vqmod devono essere copiati nella cartella vqmod/xml che sono dei file con estensione .xml
se non vanno e perchè probabilmente bisogna adattare il codice al template che si utilizza.
Scusa raikage, ti riporto qui sotto le istruzioni di del modulo Vqmod come da download regolarmente effettuato da OP/Extension:
Easy vqmod package for all opencart versions, enjoy :]
-----------------------------------------------------
~ Install on opencart v2 ~
-----------------------------------------------------
- Go to Extension installer and select the package
- Done
-----------------------------------------------------
~ Install on opencart v1.5 ~
-----------------------------------------------------
- Upload content of "upload" folder to your website
- Enter this url in your browser: http://[yourwebsite.com]/vqmod/install
- Done

Ho tolto qualche riga in bianco di troppo.
Il template è quello standard di OC

User avatar
New member

Posts

Joined
Sat Feb 13, 2016 11:29 pm

Post by raikage » Tue Feb 16, 2016 4:11 pm

avranno sbagliato loro a dare le istruzioni,se si tratta di vqmod lo puoi installare solamente da ftp.

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by carlocozzetto » Tue Feb 16, 2016 7:50 pm

raikage wrote:avranno sbagliato loro a dare le istruzioni,se si tratta di vqmod lo puoi installare solamente da ftp.
Quindi l'ho installato giusto, ma devo mettere mano al XLM...
Grazie per la delucidazione!
;D

User avatar
New member

Posts

Joined
Sat Feb 13, 2016 11:29 pm

Post by raikage » Tue Feb 16, 2016 8:20 pm

se hai il template standard non c'è bisogno,ma non conoscendo l'estensione che hai installato,non saprei dirti xke non ti funziona.
tieni però presente che alcune estensioni vanno installate nel sistema tramite extensioni-->moduli-->nome estensione cliccando sul pulsante verde.

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by carlocozzetto » Tue Feb 16, 2016 10:46 pm

raikage wrote:se hai il template standard non c'è bisogno,ma non conoscendo l'estensione che hai installato,non saprei dirti xke non ti funziona.
tieni però presente che alcune estensioni vanno installate nel sistema tramite extensioni-->moduli-->nome estensione cliccando sul pulsante verde.
Questo mi diventa un problema perché il mio provider vuole ftp esplicito su TLS e mi sa che è questo che inchioda l'installazione delle estensioni, la cosa mi limita molto, perché non saprei proprio dove andare a mettere le mani.
Cosa che tra le altre cose mi fa impazzire perché non funziona neanche con filezilla...
:crazy:

User avatar
New member

Posts

Joined
Sat Feb 13, 2016 11:29 pm

Post by raikage » Tue Feb 16, 2016 10:55 pm

non penso proprio che sia per via del tls che le estensioni non vadano.

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by carlocozzetto » Tue Feb 16, 2016 11:04 pm

ipotizza pure apertamente, ho appena provato con filezilla e non si connette... e mi va di lusso perchè carico le cose da cPanel, da quando hanno messo il TLS non ci si riesce a connettere via ftp.
Provando con le estensioni tronca il carico in quanto disconnette dal server...

e dall'installatore mi da un errore qui:
vqmode/vqcache/vq2-admin_controller_extension_installer.php alla riga 295
Last edited by carlocozzetto on Tue Feb 16, 2016 11:11 pm, edited 1 time in total.

User avatar
New member

Posts

Joined
Sat Feb 13, 2016 11:29 pm

Post by raikage » Tue Feb 16, 2016 11:07 pm

ma se utilizzi filezilla senza tls ti funziona?

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm

Post by carlocozzetto » Tue Feb 16, 2016 11:12 pm

provato per intere notti no... non va proprio.

con l'installatore mi da un errore qui:
vqmode/vqcache/vq2-admin_controller_extension_installer.php alla riga 295

User avatar
New member

Posts

Joined
Sat Feb 13, 2016 11:29 pm

Post by raikage » Tue Feb 16, 2016 11:15 pm

infatti extension_installer è perchè non supporta i file vqmod ma solo ocmod.

https://www.informaticazone.it
Consulenza,Sviluppo Extension per: Opencart,Magento,Prestahop,Wordpress,Ocart,Zencart,Joomla,Multimerch e SEO Specialist Certified

Info e Contatti

Image


User avatar
Active Member

Posts

Joined
Mon Jun 03, 2013 3:04 pm
Who is online

Users browsing this forum: No registered users and 9 guests