Post by Emmanuel » Fri Oct 10, 2008 7:26 am

Hi everyone,
I really need some help here as I'm at my wits end!
I've got this website That I'm designing at the moment: http://highwoodhealth.org/example/a/index.html


And I'm trying to make my new open cart website to integrate.
here is the link to the open cart website: http://www.shop.highwoodhealth.org

Here is my problem:

I want to put the floating menu that is on the left side of the first website, into the open cart website, in the same spot ect....
I'm quite familiar with code but this has got me stumped. I tried for quite a while but could get the menu to float....

Would really appreciate some help

Emmanuel

New member

Posts

Joined
Thu Oct 02, 2008 2:46 pm

Post by david.gilbert » Fri Oct 10, 2008 9:03 am

There are 2 ways you could do this:

1 (and easier): Hard code your floating menu into either /catalog/template//module/information.tpl or /catalog/template//module/category.tpl (not to forget adding your supporting CSS to /catalog/template//css/default.css)

2 ( much better but harder): write your own controller and supporting code for external links. That way you can add/remove/edit them in admin.

-Dave

Professional Website Services - http://www.davidmgilbert.com/


User avatar
Active Member

Posts

Joined
Sun Jan 06, 2008 5:02 pm
Location - Mount Compass, South Australia

Post by Emmanuel » Fri Oct 10, 2008 10:22 am

Already had a little go at hard coding it in to the layout.tpl file.....

will give the other two a go though....

I have no idea how to write a controler!!

I've never worked with php code only html code....

any instructions on how to write a controler?

Thanks for your help so far

New member

Posts

Joined
Thu Oct 02, 2008 2:46 pm

Post by Emmanuel » Fri Oct 10, 2008 12:09 pm

Ok I've coded it into the imformation.tpl file

this is the result:

http://shop.highwoodhealth.org

It will still not float like it does in the other webstie?

Also What is the best way to link it to default.css?
Is it by putting a it in a tag?
and then creating an id in the default.css?
I tried this and it made everything go wacko!

Thanks for help

Emmanuel

New member

Posts

Joined
Thu Oct 02, 2008 2:46 pm
Who is online

Users browsing this forum: No registered users and 2 guests