Post by kendallstump » Tue Mar 11, 2008 11:58 pm

i get the error Error: Shipping method required! upon check out as I am testing my cart. I have gone through the admin panel and have not found anything to correct this. can someone help?
thanks

Newbie

Posts

Joined
Tue Mar 11, 2008 9:15 am

Post by kendallstump » Wed Mar 12, 2008 12:27 am

OK, i think i have this figured out. I had disabled ALL of the shipping types instead of just the ones I did not want to allow.

Newbie

Posts

Joined
Tue Mar 11, 2008 9:15 am

Post by mikeytrw » Tue May 27, 2008 9:30 pm

Hi I am having the same problem with my cart, only I have weight based shipping enabled....


Still get the error regardless of disabling and re-enabling it.

Should there not be a way to select shipping method for each product rather than allowing the user to select?

Thanks

Mike

New member

Posts

Joined
Tue May 27, 2008 9:28 pm

Post by bruce » Tue May 27, 2008 9:49 pm

There is currently no product based shipping module for OpenCart.

As for your problem, it may be that the shipping address does not match any of the geo zone that you have defined as applying to your weight based shipping module.

Active Member

Posts

Joined
Wed Dec 12, 2007 2:26 pm

Post by redboxdesign » Mon Jun 02, 2008 6:58 pm

I had the same problem but resolved it with a different solution. Take for example Singapore. It is listed as a country, but has no zones. I kept getting Error: Shipping method required! I fixed it by adding Singapore as a Zone within Singapore the Country. Somehow this fixed it.

Newbie

Posts

Joined
Fri Apr 11, 2008 1:57 pm

Post by bruce » Mon Jun 02, 2008 8:44 pm

Actually it is the same. With no zones defined, you cannot get a match.  :D

Active Member

Posts

Joined
Wed Dec 12, 2007 2:26 pm
Who is online

Users browsing this forum: No registered users and 5 guests