Post by jyoz » Fri Aug 22, 2008 4:47 am

I'm using V. 0.7.7 of Open cart. I got everything to work.

Now their are two things that are not major issues but are bugging me.

I have a private SSL and am using it on OpenCart everything is great.

The problem is that when you search on the page the cart goes into secure mode. Yet on the search page the search form's post method is to a http:// address not https:// so when a person searches the first time everything is great. When you search again you get a "Though the connection is encrypted, the form is being submitted through an unencrypted location." I really hate this.

The other problem is when you go to a category and have multiple pages, once you use the drop down to switch pages you get the products in an Encrypted page, fine - but when you try to swtich you get the "submitting info through unencrypted location" error again.

I was able to solve the latter problem by increasing my products per page to 99.

But how do i solve the secure / submit through unsecured search problem?

thanks

Newbie

Posts

Joined
Tue Aug 12, 2008 6:55 am

Post by Luvz2drv » Fri Aug 22, 2008 5:39 am

2 ways.... 

1) edit the controllers that are giving you the issue to url->ssl(  instead of url->href

above could prove to be long and tedious

2) change your config file for the none secure connection from http://  to https:// so your store always run in secure mode..

Jonathon

Global Moderator

Posts

Joined
Fri Mar 21, 2008 10:58 am

Post by Qphoria » Fri Aug 22, 2008 6:26 am

id recommend option 1. I don't think shops were meant to run in ssl at all times

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by jyoz » Fri Aug 22, 2008 8:06 am

Thank you to the both of you!

the problem was with the search.php controller... i simply replaced this....
$view->set('action', $url->href('search', 'page'));
with this...
$view->set('action', $url->ssl('search', 'page'));
Thanks again!

Newbie

Posts

Joined
Tue Aug 12, 2008 6:55 am

Post by Qphoria » Fri Aug 22, 2008 8:11 am

I'm not sure that searches should even be ssl based. Perhaps changing the actual search from going into ssl mode would be best. But as long as you got some work around, that's fine for now.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by jyoz » Fri Aug 22, 2008 9:42 am

True. It's just that i'm hoping to go live in a day or two...

I'll still look into it though.

Thanks again!

Newbie

Posts

Joined
Tue Aug 12, 2008 6:55 am

Post by jyoz » Fri Aug 22, 2008 1:51 pm

quick follow up just in case anyone needs it...
To disable the SSL feature all together for the search function
find the search.php file in the controller folder

simply replace this line... (very end of document)
$response->redirect($url->ssl('search'));
with this
$response->redirect($url->href('search'));
this was the line that was telling the controller to go into SSL mode, even though it's useless for the search feature.  ;D

Newbie

Posts

Joined
Tue Aug 12, 2008 6:55 am

Post by bruce » Fri Aug 22, 2008 2:40 pm

Thanks for the follow up post. Most helpful.  8)

Active Member

Posts

Joined
Wed Dec 12, 2007 2:26 pm
Who is online

Users browsing this forum: No registered users and 5 guests