Post by heinzchen » Wed Nov 02, 2011 9:35 pm

Hallo,

hat einer eine Lösung wie ich eine fertige PDF an die Bestätigungsmail anhängen kann?

Code: Select all

$mail->addAttachment(DIR_IMAGE . 'xyz.pdf');
hängt zwar die ensprechende Datei an, aber leider wird diese nicht im Mail-Client angezeigt, sondern nur codiert im Quelltext ausgegeben.

Gruß

OC 1.5.1.3

New member

Posts

Joined
Mon Jul 11, 2011 5:38 pm

Post by OSWorX » Wed Nov 02, 2011 10:49 pm

Scheint ein Fehler von dir zu sein, bei mir funktioniert es einwandfrei.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by heinzchen » Thu Nov 03, 2011 1:14 am

OSWorX wrote:Scheint ein Fehler von dir zu sein, bei mir funktioniert es einwandfrei.
Das sind die original Scripte, bis auf diesen einen Zusatz.
Hast du noch Modifikationen in der system/library/mail.php vorgenommen?

New member

Posts

Joined
Mon Jul 11, 2011 5:38 pm

Post by OSWorX » Thu Nov 03, 2011 1:51 am

heinzchen wrote:
OSWorX wrote:Scheint ein Fehler von dir zu sein, bei mir funktioniert es einwandfrei.
Das sind die original Scripte, bis auf diesen einen Zusatz.
Hast du noch Modifikationen in der system/library/mail.php vorgenommen?
Ja, aber nur was den Betreff betrifft denn der ist (wie einiges an der Mailklasse schon lange) schlichtweg falsch!
Nein, nicht was die Attachements betrifft.

Es funktioniert bei mir aber auch mit einem nicht gefixten, Originalscript.

Custom Development | Individuelle Entwicklung | Support & Bugfixes

Image Image Image


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by heinzchen » Thu Nov 03, 2011 2:19 am

OSWorX wrote:Ja, aber nur was den Betreff betrifft denn der ist (wie einiges an der Mailklasse schon lange) schlichtweg falsch!
Nein, nicht was die Attachements betrifft.

Es funktioniert bei mir aber auch mit einem nicht gefixten, Originalscript.
Komisch!
Bei mir und meinem Kollegen waren die Attachments (2 PDF Dateien) nur codiert im Quelltexte sichbar,
aber nicht als Anhang ersichtlich/anklickbar (u.a. im Thunderbird).
Ich habe jetz in der mail.php einige Kleinigkeiten modifizieren müssen, jetzt gehts auch hier.

New member

Posts

Joined
Mon Jul 11, 2011 5:38 pm

Post by Nasko » Mon Jan 09, 2012 7:13 pm

Wäre nett, wenn du den rest auch mitteilen würdest, was für Modifikationen du noch machen müstest.
Ich habe es noch nicht gestestet aber ich denke einfach auch an den Anderen. :)

OC 1.5.1.3 http://www.coshino.de


New member

Posts

Joined
Mon Jan 09, 2012 5:55 pm

Who is online

Users browsing this forum: No registered users and 4 guests