Post by pee » Sat May 30, 2009 10:42 pm

Klar. Ansonsten kannst du dich einfach melden. Ich konnte glücklicherweise schon einige Erfahrung mit OC sammeln und bin gerne bereit zu helfen.

Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by hitu_125 » Thu Jun 11, 2009 6:05 pm

Hi, pee, I done everything as you mentinod for german language, but not able to convert /switch

Newbie

Posts

Joined
Thu Apr 30, 2009 11:59 am

Post by pee » Thu Jun 11, 2009 6:30 pm

You have to translate alle the product, category, geo-zones, prices, weight- and price-classes in the admin-menu. New delivery-statuses are needed as well, for get the orders in the admin-menu. Look for that. ;)

Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by Trollomann » Fri Jun 12, 2009 4:47 am

Hallo zusammen,

habe gerade OpenCart installiert und frage mich nun ob es denn gerenell Probleme mit der deutschen Sprache gibt, weil sie nicht standardmäßig mitgeliefert wird. Zumindest wird auf der Wikipediaseite erwähnt dass OC mit englicher und deutscher Sprache ausgeliefert wird. Nach dem ich dann Deutsch auch nicht unter den Languages zum Download fand und erst hier im Forum sichtete verdichtete sich natürlich mein Verdacht, dass da was im Busch ist :) Wer klärt mich mal auf?

Weiterhin ist mir aufgefallen dass nach dem ich das Sprachpaket reinkopiert nach der PDF-Anleitung, dass OC sich unter Admin/Konfiguration/Einstellungen/Lokal die Einstellungen die ich vornehmen nicht merkt. Wenn ich mich neu einlogge sind sie wieder auf Standard gestellt. Diese komischen Phänomene die ich hier beobachte treten nicht mehr auf wenn ich das Sprachpaket wieder vom Server lösche also irgendwas stimmt da mit nicht ganz.

Wär für jeden Hinweis dankbar.

Letzte Frage, wie könnte ich Deutsch zur Standard Sprache machen?

Vielen Dank
Sebastian

Newbie

Posts

Joined
Fri Jun 12, 2009 4:38 am

Post by pee » Fri Jun 12, 2009 9:54 am

Hallo Sebastian,

du machst Deutsch zur Standardsprache, indem du alles bisher englische übersetzt (ich habe in vorangegangenen Postings darüber bereits geschrieben). Da das als Standard-Setzen bei dir nicht funktioniert, fehlen vermutlich Übersetzungen die du eben »selber im Adminmenü vornehmen« musst und daher dann auch die Phänomene. Einfach den Thread ganz lesen und bei meinem Schulenglisch ein Auge zu drücken. ;)

Es ist falsch, dass OpenCart mit der deutschen Sprache »ausgeliefert« wird. Die derzeit aktuelle deutsche Übersetzung ist von mir. Deswegen steht da auch immer Netzor.de drin. Wenn du Fragen hast, poste einfach. Ich mag OC.

Viele Grüße aus der Eifel,
pee

Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by pee » Fri Jun 12, 2009 11:32 am

So..

und hier gibt es wiedermal ein Update der Sprachdateien von mir. An den Stellen wo der Shop und der Support genannt wird, steht meine Domain drin. Seht die Nennung als Platzhalter und ändert diese einfach entsprechend ab.

Bei Fragen bin ich natürlich jederzeit gerne für euch da.

Viele Grüße aus der Eifel,
pee

Attachments


Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by 42blue » Thu Jun 18, 2009 3:03 am

@pee

danke für deine mühe .. bin auch freelancer und ein kunde von mir plant nun ebenfalls open cart einzusetzen .. hoffe ich kann hier zukünftig auch was zur verbesserung von open cart beitragen ;)

Newbie

Posts

Joined
Thu Jun 18, 2009 3:00 am

Post by pee » Thu Jun 18, 2009 5:01 am

Ja gerne. Lass uns Freelancer zusammenhalten! ;)

Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by TigerMatze » Thu Jul 09, 2009 4:38 am

Hi,

da bei den Sprachdateien von pee noch einiges fehlte habe ich mir die Mühe gemacht das für OC 1.2.9 zu übersetzen. Also einfach die Dateien in die entsprechenden Ordner kopieren und es kann los gehen.

Ich muss noch dazu sagen, dass dies kein offizieller release ist!

Attachments


User avatar
Newbie

Posts

Joined
Sun Jun 28, 2009 5:37 pm
Location - Flensburg

Post by fossy » Fri Jul 10, 2009 10:15 pm

Ich hab mal die doppelten (Sicherungsdateien) rausgelöscht und die Texte/Dateien nach UTF-8 konvertiert; dann klappts auch bei mir mit den Umlauten.

Attachments

Sprachdateien 1.2.9_utf-8 kein offizieller release!


Dirk
--
...it' never too late!


User avatar
New member

Posts

Joined
Tue Jun 02, 2009 3:19 am

Post by pee » Mon Jul 13, 2009 1:17 pm

Hi,

an dieser Stelle gibt es noch ein weiteres Update von mir. :-)

Viele Grüße,
pee

Attachments


Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by hfmn » Wed Jul 15, 2009 2:28 pm

Vielen Dank!

Newbie

Posts

Joined
Fri Jul 03, 2009 2:54 pm

Post by pee » Wed Jul 15, 2009 3:09 pm

Gerne. :-)

Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by pee » Thu Jul 16, 2009 1:53 pm

Hab hier noch die Installationsanleitung mit rein gepackt.

Attachments


Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by pee » Mon Jul 20, 2009 7:56 am

Hier ist eine neue Version. Viele Grüße. O0

Attachments


Professionelles Onlineshop-Design & -Programmierung: http://netzor.de


User avatar
pee
New member

Posts

Joined
Fri May 08, 2009 4:48 pm
Location - Germany

Post by Xcite » Sat Aug 22, 2009 5:33 am

Hallo,

ich habe mir die deutschen Sprachdateien runtergeladen und in meine OC Installation eingebunden, wie in der Anleitung beschrieben.
Im Front-End funktioniert die Sprachdatei wunderbar, aber im Backend (Adminoberfläche) passiert überhaupt nichts.
Wenn ich unter
Admin -> Configuration -> Setting -> Local
auf German umstelle, dann ist das beim nächsten aufrufen außerdem auch wieder auf English zurückgesetzt.
Wie kann das sein?

Danmke schonmal für die Hilfe.

Newbie

Posts

Joined
Sat Aug 22, 2009 5:22 am

Post by exp » Sat Sep 19, 2009 5:27 pm

Hallo alle zusammen

Ich will mich erstmal vorstellen. Mein Name ist Andy Tagliani und wir hosten und supporten einige Kunden mit ihren Webinstallationen. Unter anderem auch einen Kunden mit OpenCart. Installation und Konfiguration verlief soweit problemlos, ich habe nur festgestellt, als mir der Kunde einige Fehlermeldungen übersandte, dass die deutschen Sprachdateien nicht vollständig sind. Ich leite weiter unten mal einige Fragen des Kunden weiter wenn ihr erlaubt. Da wir beabsichtigen für einen anderen Bereich ebenfalls einen kleinen Shop einzusetzen, würden wir die deutschen Sprachdateien (zumindest für uns und unsere Kunden, wir stellen diese aber gerne hier zur Verfügung, wenn erwünscht) komplettieren. Bitte nicht als Vorwurf verstehen, ich kritisiere diesen Umstand nicht. Ich habe zuvor einige Fragen, vielleicht könntet ihr uns mit ein paar Hinweisen helfen, meine Fragen:

1. utf-8 ohne BOM?
2. Ich habe in den deutschen Sprachdateien einige Dateien, die mit einer Tilde versehen sind, hat dies eine besondere Bewandnis, sind diese Dateien ohne die utf-8 Konvertierung? Können diese gelöscht werden?
3. Ich habe in den deutschen Sprachdateien einige Dateien, die sind in den englischen Sprachdateien nicht vorhanden. Sind diese evtl. nicht komplett oder ist der Grund darin zu sehen, dass die deutschen Sprachdateien für die aktuelle Version (noch) nicht angepasst sind?

Ich persönlich finde es gut, dass wenn eine Sprachdatei nicht vorhanden ist, eine (mehr oder weniger) Fehlerseite erscheint, somit ist man gezwungen diese zu erstellen! Der eine oder andere ist damit evtl. doch ein wenig überfordert, wenn er noch nicht viele Erfahrungen in dieser Beziehung gesammelt hat. Ansonsten, OpenCart hat einen guten Eindruck auf mich gemacht!

Viele Grüße
Andy

exp
Newbie

Posts

Joined
Sat Sep 19, 2009 5:03 pm

Post by mubico » Fri Sep 25, 2009 10:33 pm

Hallo Community,
nun der Shop ist ja nun wirklich super easy zu bearbeiten, dennoch stell ich mir die Frage warum Language Files publiziert werden die nicht ganz korrekt sind und in der Admnistration gar nicht funktionieren.

Ich hab nun EN deaktiviert und DE als Standard gesetzt. Die klinen Fehler hab ich selbst noch ausgebügelt.
Ich denke ich muss mir dass mit der Administration nochmal ansehen, denn auch wenn das Frontend deutsch ist, bleid es hier so wie es war, nämlich english.

Kann aber auch sei dass ich einen an der Murmel habe und ich zu dumm zum kopieren bin.
Mal sehen was der Morgige Tag bringt.

Newbie

Posts

Joined
Fri Sep 25, 2009 10:18 pm

Post by eddispagetti » Thu Oct 29, 2009 9:47 pm

Hallo zusammen,
ich bin froh, dass es ne Menge Leute gibt, die interessiert sind, Open Cart zu übersetzen. Ich habe die letzte Datei von Netzor etwas weiter übersetzt. Nur leider ist mir aufgefallen, dass es echt viele Lücken gibt und teilweise komplette Sachen gelöscht wurden. Warum? Zum Beispiel sind in der Englischen Fassung "Help-Texte" mit dabei, die dem User erklären, was die einzelnen Punkte bedeuten. Ich finds total sinnvoll. Aber warum werden sie nicht mehr angezeigt? Versteh ich nicht?

Also wer Lust und Zeit hat proaktiv daran mitzuarbeiten, möge sich melden.
Wenn jemand weiß, dass in 2-3 Wochen ein deutsches Release geplant ist, der sollte es auch schnell posten, denn dann kann man sich die Arbeit sparen;)

gruß
eddi

Newbie

Posts

Joined
Thu Oct 29, 2009 8:13 pm

Post by larspeyer » Sat Nov 07, 2009 2:33 am

Hallo Zusammen,
Ich gehöre auch zu den Freelancern und habe einen Kunden, welcher gerne einen Shop mit OC aufbauen möchten.
Installation und konfiguration lief soweit ohne Probleme. Ich habe folgender Release von OC installiert: v1.3.3 Released 4th November, 2009

Nun mein Problem: Wenn ich das deutsche Sprachpaket (http://www.opencart.com/index.php?route ... ion_id=270) herunterlade und installiere, habe ich in allen Browsern das Problem mit den Umlauten die nicht richtig angezeigt werden.

In der README-Datei des Sprchpaketes steht, dass dieses Problem durch das Einfügen folgender Zeile in der header.tpl behoben wird: <meta http-equiv=ContentType" content=text/html;charset=UTF-8">

Nun dies stimmt für FireFox und konsorte, aber einmal mehr nicht für unseren Freund, IE8.
Ich wollte fragen ob ihr das Problem kennt und ob schon eine Lösung dazu im Umlauf ist.

Besten Dank!
Lars

Newbie

Posts

Joined
Sat Nov 07, 2009 2:24 am
Who is online

Users browsing this forum: No registered users and 2 guests