Post by csleepg » Wed Feb 18, 2009 2:42 pm

Hi,
  I am getting this error when want to run installation script to install opencart.I have no problem with old version.How to fix this as my php system is a preloaded.I am running it in synology NAS.

Error: magic_quotes_gpc is enabled!

New member

Posts

Joined
Mon Feb 02, 2009 10:13 am

Post by fido-x » Wed Feb 18, 2009 3:34 pm

You could try adding the following line to top of your .htaccess file:--

Code: Select all

php_flag magic_quotes_gpc Off

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by starchy » Wed Feb 18, 2009 5:33 pm

If there are 1and1 users out there, php_flag magic_quotes_gpc Off doesn't work if you drop it in the .htaccess file unless you're on a dedicated server (you'll get a 500 server error).  To disable the magic quotes directive, copy the php.ini file that's included in the installation package and paste it into the /install folder.  As an FYI, it's not recursive for shared hosting packages so you'll have to place php.ini in pretty much every folder and sub-folder where you want magic quotes disabled.

Also, for 1and1 users, all *.php files are parsed with PHP4.  If you want to use PHP5, you will need to add the following lines to your .htaccess file and place the file in the root of your OpenCart installation folder:

AddType x-mapp-php .php4
AddType x-mapp-php5 .php
AddHandler x-mapp-php .php4
AddHandler x-mapp-php5 .php
Last edited by Anonymous on Wed Feb 18, 2009 5:37 pm, edited 1 time in total.

New member

Posts

Joined
Wed Feb 18, 2009 5:02 pm
Who is online

Users browsing this forum: No registered users and 1 guest