Post by markiboy » Sat Dec 29, 2007 1:54 am

Hi

I paid for a web site doing and online shop working lovely

recentley over the last day or 2 there as been a error going through to check out and then when i press checkout this comes up

Notice: Undefined index: product_id in /home/www/megapetc/shop/catalog/module/review.php on line 32

Warning: Cannot modify header information - headers already sent by (output started at /home/www/megapetc/shop/catalog/module/review.php:32) in /home/www/megapetc/shop/catalog/plugin/checkout_shipping.php on line 5


what should i do now ? or what may be doing this

Newbie

Posts

Joined
Mon Dec 24, 2007 2:49 am

Post by WCNZ » Thu Mar 27, 2008 1:27 pm

I am getting the same problem when submitting the cart after checkout_confirm.php. Any solutions known? Thanks!

New member

Posts

Joined
Mon Mar 24, 2008 11:21 am

Post by bruce » Thu Mar 27, 2008 2:57 pm

what version of opencart?

Active Member

Posts

Joined
Wed Dec 12, 2007 2:26 pm

Post by WCNZ » Sun Mar 30, 2008 7:57 am

Hi Bruce, my version is 0.7.3.1, I am running it on a local windows machine with xampp installed, php 5, apache 2, mysql 4 (if that helps any?!)

The error occurs right after I submit the cart in checkout_process:

Code: Select all

Notice: Undefined index: product_id in C:\xampplite\htdocs\EditOpenCart\library\cart\order.php on line 81

Notice: Undefined index: product_id in C:\xampplite\htdocs\EditOpenCart\library\cart\order.php on line 81

Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\xampplite\htdocs\EditOpenCart\library\mail\mail.php on line 142

Warning: Cannot modify header information - headers already sent by (output started at C:\xampplite\htdocs\EditOpenCart\library\cart\order.php:81) in C:\xampplite\htdocs\EditOpenCart\library\environment\response.php on line 22
The other 2 errors are caused (I think) becuase I do not have an smtp server installed.

Thanks for your assistance!

New member

Posts

Joined
Mon Mar 24, 2008 11:21 am

Post by bruce » Sun Mar 30, 2008 2:19 pm

sorry, I don't know anything about the older versions of opencart. I first discovered it at 0.7.7

Active Member

Posts

Joined
Wed Dec 12, 2007 2:26 pm

Post by Luvz2drv » Mon Mar 31, 2008 3:39 pm

why run older verson-- it was update for a reason

try a  0.7.7  see if oyu have the same issue

Global Moderator

Posts

Joined
Fri Mar 21, 2008 10:58 am

Post by WCNZ » Tue Apr 01, 2008 3:43 pm

Thanks Bruce for your reply, it wasn't until you prompted me for my version no. that I realised I was not running the latest. I must have downloaded it a while ago, and not realised. I will upgrade, and see where I get.

Thanks again!

New member

Posts

Joined
Mon Mar 24, 2008 11:21 am
Who is online

Users browsing this forum: No registered users and 5 guests