Post by OKHO » Wed Dec 06, 2006 1:03 am

I found OpenCart is very nice to work with, but this desition I made based on DEMO.  My installation does not work at all!!!!

Here is the First Problem I found.
in install/index.php ther is a line 53

if (!$connection = @mysql_connect($_POST['db_server'], $_POST['$db_username'], $_POST['db_password']))
there is extra $ with  $_POST['$db_username']  it should be fixed to
if (!$connection = @mysql_connect($_POST['db_server'], $_POST['db_username'], $_POST['db_password']))

At least installation works after that.
Second BIG problem is with PHP functions.

See attachment.  Because of this nothing works as supposed to be. 
I am running:
PHP 5.1.6
MySql 5.x
Apache with SAPI PHP module.

Attachments

???
OpenCart.gif

Newbie

Posts

Joined
Wed Dec 06, 2006 12:42 am

Post by tlccomp » Wed Dec 06, 2006 2:21 am

Wow, that worked. I was able to get it installed now I have this error.

Error: register_globals is enabled!

Newbie

Posts

Joined
Sun Dec 03, 2006 2:55 am

Post by tlccomp » Wed Dec 06, 2006 2:35 am

tlccomp wrote: Wow, that worked. I was able to get it installed now I have this error.

Error: register_globals is enabled!
Fixed it. Added "php_flag register_globals 0" to the .htaccess in the "store" directory. Cool  :)

Newbie

Posts

Joined
Sun Dec 03, 2006 2:55 am

Post by Daniel » Wed Dec 06, 2006 7:58 pm

OKHO wrote: I found OpenCart is very nice to work with, but this desition I made based on DEMO.  My installation does not work at all!!!!

Here is the First Problem I found.
in install/index.php ther is a line 53

if (!$connection = @mysql_connect($_POST['db_server'], $_POST['$db_username'], $_POST['db_password']))
there is extra $ with  $_POST['$db_username']  it should be fixed to
if (!$connection = @mysql_connect($_POST['db_server'], $_POST['db_username'], $_POST['db_password']))

At least installation works after that.
Second BIG problem is with PHP functions.

See attachment.  Because of this nothing works as supposed to be. 
I am running:
PHP 5.1.6
MySql 5.x
Apache with SAPI PHP module.



I will look into this. I did rush the install script and left it quite buggy.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by thinkcast » Sat Dec 16, 2006 3:36 am

Hi Daniel,

Picked up the bug, line 53 in install/index.php simply remove the "$" from _POST[' $ db_username'] then install goes as planned.

For those having issues with magic_quotes & register_globals simply edit your .htaccess and add the following lines

# Turn off register_globals
php_flag register_globals off
# Turn off magic_quotes
php_value magic_quotes_gpc 0

Regards

Newbie

Posts

Joined
Sat Dec 16, 2006 3:30 am
Who is online

Users browsing this forum: No registered users and 3 guests