Post by swflatt » Thu Jan 01, 2009 11:48 am

Just installed 0.7.9-RC5 and received "Notice: Undefined index: REQUEST_URI"  No images are showing up, and all links are dead. any ideas?

Newbie

Posts

Joined
Thu Jan 01, 2009 11:44 am

Post by JNeuhoff » Thu Jan 01, 2009 6:37 pm

We need more details. What's the URL of your website? Is your config.php file correctly set up?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by hm2k » Thu Jan 01, 2009 10:45 pm

Yes, we need more details, like the full error message.

UK Web Hosting


User avatar
Global Moderator

Posts

Joined
Tue Mar 11, 2008 9:06 am
Location - UK

Post by swflatt » Fri Jan 02, 2009 2:18 am

Thanks for the response:

The site is http://www.advanced-ids.com/index.php

At the top header it states:

Notice: Undefined index: REQUEST_URI in C:\Domains\advanced-ids.com\wwwroot\library\application\router.php on line 15

At the footer it states:

Notice: Undefined index: REQUEST_URI in C:\Domains\advanced-ids.com\wwwroot\library\session\session.php on line 64

I didn't really look into the config files, it stated that it was installed successfuly. I did check the read/write permissions and believe they are correct.

As I say all the links direct to "Internet Explorer cannot display the webpage" page.

As for admin page, it diplays following at footer:

Notice: Undefined index: REQUEST_URI in C:\Domains\advanced-ids.com\wwwroot\library\session\session.php on line 67

all the links direct to "Internet Explorer cannot display the webpage" page on this as well, not able to login

Newbie

Posts

Joined
Thu Jan 01, 2009 11:44 am

Post by lev » Fri Jan 02, 2009 2:52 am

This is a PHP on windows issue(IIS).
To resolve do any 1 of the following:

- Install apache server on your windows machine that hosts this application
- Add an .htaccess file to the root of your store with a rewrite mod to create REQUEST_URI from SCRIPT_NAME
    * for this one, I'd recommend getting Helicon ISAPI_Rewrite app. (You can get the Lite version for free which would be sufficient)
- Change all instances of REQUEST_URI with SCRIPT_NAME

lev
New member

Posts

Joined
Wed Apr 30, 2008 10:47 pm

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by hm2k » Fri Jan 02, 2009 7:24 pm

I've attempted to address this issue in the latest SVN, I'd be grateful if someone could test this, otherwise wait till RC6.

UK Web Hosting


User avatar
Global Moderator

Posts

Joined
Tue Mar 11, 2008 9:06 am
Location - UK
Who is online

Users browsing this forum: No registered users and 2 guests