Post by enzearth » Sun May 13, 2007 8:06 am

I have installed on a unix server thought I had done everything ok.Deleted installation folder.Then got this.Help?

Newbie

Posts

Joined
Sun May 13, 2007 8:04 am

Post by Daniel » Sat Jun 02, 2007 4:37 am

Goto php.ini and change registered globals to off.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by enzearth » Tue Jun 12, 2007 12:29 pm

Thanks Daniel ,I tried contacting my host to see if they could help.They tell me that because I am on a shared server they couldnt modify the php ini just for me.Tried commands in htaccess but to no success.Any other way around it.(I wonder how many others are on shared servers)its a lot more expensive to go to a dedicated server or install my own.I suppose I just need to be put out of my misery.Its such a good product.

Newbie

Posts

Joined
Sun May 13, 2007 8:04 am

Post by Daniel » Tue Jun 12, 2007 4:39 pm

Most companies will aloow you you some way of shutting off globals.

Globals is a major security risk and has been completly removed as over PHP6.

You can try switching off globals using ini_set() or using .htaccess.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by Daniel » Tue Jun 12, 2007 4:45 pm

open up .htaccess and change:

#php_flag register_globals off

to

php_flag register_globals off

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by enzearth » Fri Jun 15, 2007 5:06 am

Thanks again Daniel.Tried changing htaccess ,still no go.Can you expand a bit more on ini_set().

Newbie

Posts

Joined
Sun May 13, 2007 8:04 am

Post by Daniel » Fri Jun 15, 2007 4:16 pm

try putting ini_set("register_globals","Off"); at the start of the index.php in the main directory and admin directory.
Last edited by Daniel on Thu Jun 28, 2007 7:37 pm, edited 1 time in total.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by enzearth » Sat Jun 16, 2007 10:15 am

Thanks once again Daniel for your time with this.I tried the putting ini_set("register_globals","On"); in both index files and still no go.It seems its time to give up,i will try another provider,maybe they will be more flexible.Good Luck to you sir and thanks again.

Newbie

Posts

Joined
Sun May 13, 2007 8:04 am

Post by Daniel » Sat Jun 16, 2007 6:26 pm

If you can not disable register globals your hosting company is providing an opening for their customers sites to get hacked.

OpenCart®
Project Owner & Developer.


User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by ysayita » Thu Jun 28, 2007 4:19 pm

I got the same problem and contacted to my host too. I was told that it was already turned off. But it was giving the error. After that I recognised that the problem was solved automatically. I guess the hosting company restarted the IIS or the server itself. You may want your host to do it if the register_globals flag seem turned off in the php.ini file. Because most of them keep it turned off. As I read from your messages they did not mentioned about its current state.

y.


User avatar
Newbie

Posts

Joined
Thu Jun 28, 2007 4:06 pm
Location - Ankara

Post by rwallin » Tue Jul 03, 2007 7:50 pm

Hey guys,

I'm new here and ran into the same problems of being on a shared server with Register Globals set to ON in a php.ini file I had no control of and wanted to share a fix that worked for me.

I tried making the changes in the .htaccess file but that threw a server configuration error.

Adding the ini_set("register_globals","Off"); to the index.php files in the main directory and admin directory did absolutely nothing.

I finally found a fix that worked for me and was to create a php.ini file that had one line of code and save it to the root of the store and admin directory.

Code: Select all

register_globals = Off
everything works beautifully now

Newbie

Posts

Joined
Tue Jul 03, 2007 7:45 pm

Post by fvergara » Fri May 09, 2008 9:13 am

I have the same problem, but i cant change the Error: register_globals is enabled! making all the another steps.
PLEASE HELP ME!

Newbie

Posts

Joined
Fri May 09, 2008 9:11 am

Post by JNeuhoff » Tue May 13, 2008 4:56 am

This can be indeed a problem with many shared hosting accounts. register_globals should be set to off for security reasons and is the recommended default value for PHP 5.x. We set up six OpenCart based websites with different customer accounts on MDWebHosting, and on one of their servers the register_globals kept going back to the wrong value (On) instead of Off. After several weeks we finally asked them to move account to another server box where we knew for sure that register_globals was Off all the time.

As Daniel pointed out, having register_globals=On is an open invitation to hackers, and if the webhosting company doesn't change it to Off, then it is time to find another one. IXWebHosting is a good one which we use for our own web hosting needs.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by david.gilbert » Sun Jun 01, 2008 11:54 am

try adding the following code to the very first line of .htaccess

Code: Select all

php_flag register_globals Off

Professional Website Services - http://www.davidmgilbert.com/


User avatar
Active Member

Posts

Joined
Sun Jan 06, 2008 5:02 pm
Location - Mount Compass, South Australia

Post by Lobsterman » Thu Jun 26, 2008 4:37 am

For those who did not see this, juste create a php.ini

rwallin wrote: Hey guys,

I'm new here and ran into the same problems of being on a shared server with Register Globals set to ON in a php.ini file I had no control of and wanted to share a fix that worked for me.

I tried making the changes in the .htaccess file but that threw a server configuration error.

Adding the ini_set("register_globals","Off"); to the index.php files in the main directory and admin directory did absolutely nothing.

I finally found a fix that worked for me and was to create a php.ini file that had one line of code and save it to the root of the store and admin directory.

Code: Select all

register_globals = Off
everything works beautifully now


Newbie

Posts

Joined
Thu Jun 26, 2008 4:35 am

Post by virtualgeorge » Fri Jul 11, 2008 2:43 am

I am on a shared server and today something changed so a few sites I have using opencart all get the register_globals error.

Changing the .htaccess file won't work on my server but the php.ini file did work. But I couldn't just put it in the root & admin folders. I had to put it in ALL folders for it to work. 

Active Member

Posts

Joined
Wed Jun 18, 2008 5:57 am

Post by Luvz2drv » Fri Jul 11, 2008 2:49 am

yes the php.ini will only work on the current folder.. so yes you would have to copy that from folder to folder

Global Moderator

Posts

Joined
Fri Mar 21, 2008 10:58 am

Post by bruce » Fri Jul 11, 2008 7:00 am

Try sorting it out with your hosting provider and if they will not set it back... change.

Active Member

Posts

Joined
Wed Dec 12, 2007 2:26 pm

Post by JNeuhoff » Thu Jul 17, 2008 12:52 am

Yes, indeed, on most shared servers, such as IXWebHosting or HostGator or MDWebHosting, PHP runs as CGI, in which case the approach with some entries in the '.htaccess' file won't work, but rather it then has to be done in a separate 'php.ini' file which is either located in your 'public_html', 'public_html/cgi-bin', or 'cgi-bin' directory depending on how the web hosting has been configured.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by virtualgeorge » Thu Jul 24, 2008 2:51 am

For my hostgator sites it needs the php file in every folder to work.
So I put the php.ini in the root and then so I don't need to copy to each folder, I put this in the .htaccess


suPHP_ConfigPath /home/USERNAME

order allow,deny
deny from all



I just realized that when I installed the latest version of OC, I didn't have to do this, it worked without it.

Active Member

Posts

Joined
Wed Jun 18, 2008 5:57 am
Who is online

Users browsing this forum: No registered users and 1 guest