Post by IP_CAM » Mon Mar 09, 2020 7:19 am

OpenCart CE Community Version has received some fix, matching the same Code as all
later 1.5.6.x Versions use. I prepared an upload out of it, to solve that problem. Just replace the
default Files, by uploading the content, as it exists in the ZIP Download, created for OC v.1.5.6.4+ !

OC v.1.5.5.1 Users please get the Fix from here: https://github.com/opencart-ce/opencart-ce

Ernie
PS: The Fix has also been implemented in my 2 latest Github OC LIGHT + V-PRO Downloads.

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'550 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by IP_CAM » Tue Mar 24, 2020 3:02 am

For OC 1.5.6.4 + 1.5.6.5_rc Users, I created an update package, containing a bunch of Files, with
some fixes, among changes in controller files, to now include '(int)' like shown below:
OLD Code:

Code: Select all

if (isset($this->request->get['page'])) {
			$page = $this->request->get['page'];
		} else {
			$page = 1;
		}
NEW Code:

Code: Select all

if (isset($this->request->get['page'])) {
			$page = (int)$this->request->get['page'];
		} else {
			$page = 1;
		}
If one want's to know, what it does/changes, ask xxvirusxx about it, I don't know! :laugh:
I also included the PHP-7 capable system/library/encryption.php File.
Existing 1.5.6.4 - 1.5.6.5_rc based DEFAULT Installations could just be overwritten
with the new files, but still make sure, to make a Full Backup first.
Ernie

I am no longer active at the Forum. Please do NOT send me Personal Mails,
they will no longer be replied to.
My Github OC Site: https://github.com/IP-CAM
4'550 + FREE OC Extensions, on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by DoctorDredd » Sun Sep 05, 2021 6:17 am

Hello. Why not working installation and uninstallation modules in admin panel?

Newbie

Posts

Joined
Wed Jul 29, 2020 7:38 pm

Post by Gergely » Tue Sep 07, 2021 10:51 pm

Hello Doctor Dredd,

Interesting choice of topic for this post.
Why not try in the appropriate support forum, after carefully reading this: viewtopic.php?f=176&t=200480#p529151?

Active Member

Posts

Joined
Wed Sep 30, 2020 7:58 pm
Who is online

Users browsing this forum: No registered users and 5 guests