Post by adesignl » Thu Mar 31, 2011 7:15 am

I went from 10-15sec load times by doing a bunch of the things listed above but also the biggest relief that i got was from enabling xcache for my php install. That improved my loads incredibly and the server loved me for it as well.

http://www.adesignlink.com


User avatar
New member

Posts

Joined
Wed Aug 18, 2010 1:07 pm
Location - Florida, USA

Post by glolar » Thu Mar 31, 2011 9:39 am

How do I enable xcache for my php install?

Increase Your Child's I.Q.
iPad Wallpapers
Turtle & Tortoise Screen Savers


User avatar
Active Member

Posts

Joined
Thu Jul 29, 2010 12:35 pm
Location - San Diego, CA

Post by Jeremy Fisk » Wed May 25, 2011 12:06 pm

Hi
[SOLVED][SOLVED][SOLVED][SOLVED][SOLVED]

I have set up an images.prochem.net.nz sub domain to try and optimise my images...

I have changed both the config.php pages...

But the problem is that on my product page, it is still looking to www.prochem.net.nz/image/data/cache/(file).jpg and not www.images.prochem.net.nz/data/cache/(file).jpg

Please help me to fix this as this is very urgent...

please note that my current website is www.prochem.net.nz
[SOLVED][SOLVED][SOLVED][SOLVED][SOLVED]

Many Thanks

Jem
Last edited by Jeremy Fisk on Sat Oct 22, 2011 12:39 pm, edited 2 times in total.

If i have helped... please click here to donate

Bookstore Mod
QuickShop Module
Restricted Access - Compulsory Login
Template Override - Category Specific (vQmod)
Template Override - Brand Specific (vQmod)
How did you find out about us register question mod
Compulsory Login vQmod
Brands In Top Menu
zoom - Product Image - Auto on hover


User avatar
Active Member

Posts

Joined
Thu Nov 11, 2010 6:11 pm
Location - New Zealand (Tokomaru, Palmerston North)

Post by spitos » Thu May 26, 2011 9:38 pm

deludeddonny wrote:OK I got the image subdomain thing to work, and it made a HUGE difference,

I am now trying to add the gzip & cache thing...

This is my .htaccess

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling, then restore the # as this means your host doesn't allow that.

<IfModule mod_deflate.c>
<FilesMatch "\.(js|css)$">
SetOutputFilter DEFLATE
</FilesMatch>
</IfModule>

# Turn on Expires and set default to 0
ExpiresActive On
ExpiresDefault A0

# Set up caching on media files for 5 weeks
<FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up caching on media files for 5 weeks
<FilesMatch "\.(gif|jpg|jpeg|png|swf)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up 1 day caching on commonly updated files
<FilesMatch "\.(xml|txt|html|js|css)$">
ExpiresDefault A86400
Header append Cache-Control "proxy-revalidate"
</FilesMatch>

# Force no caching for dynamic files
<FilesMatch "\.(php|cgi|pl|htm)$">
ExpiresActive Off
Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
Header set Pragma "no-cache"
</FilesMatch>
but I get 500 error... any ideas?

According to my info.php I should have gzip & deflate support...

I'm having the same issue of 500 error. :-[

As soon as I enter this I get the issue, even if I leave all the other additional code off:
# Turn on Expires and set default to 0
ExpiresActive On
ExpiresDefault A0
moggiex wrote:Superb post, although in a dev environment I'd not suggest caching anything :)

To add to the above several mods that are required are not enabled by default these are:

1. mod_headers
2. mod_expire
3. mod_headers

See http://www.virtualistic.nl/archives/73 on how to load them, once enabled they'll stop the server 500 errors you've most likely just received (like I just got).

Just remember to reload apache!
/etc/init.d/apache2 force-reload

Matt
All options that should be enabled are according to my host... any ideas anyone?

Image
Google Analytics Expert - Advanced e-commerce tracking, Product & options reporting, transaction/conversion reporting, Google Adwords conversion & profit reporting, goal & funnel reporting, event tracking, site search tracking, multi-store compatibility, EU Cookie Law compliance and works with any theme or checkout! Easy vqmod install. Get it here


User avatar
Active Member

Posts

Joined
Mon May 23, 2011 6:19 pm
Location - UK

Post by Jeremy Fisk » Fri May 27, 2011 5:10 am

Yep... I had a simmilar problem to "spitos" but my new .htaccess fixed it...
Postby spitos » Fri May 27, 2011 2:38 am

but I get 500 error... any ideas?

According to my info.php I should have gzip & deflate support...
Matt

All options that should be enabled are according to my host... any ideas anyone?
Try this

Code: Select all

php_flag magic_quotes_gpc off

<IfModule mod_deflate.c>
<FilesMatch "\.(js|css)$">
SetOutputFilter DEFLATE
</FilesMatch>
</IfModule>

php_value output_handler ob_gzhandler

# compress the files
AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/x-javascript
# removes some bugs
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4.0[678] no-gzip
BrowserMatch bMSIE !no-gzip !gzip-only-text/html
Header append Vary User-Agent

# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

# Or, compress certain file types by extension:
<Files *.html>
SetOutputFilter DEFLATE
</Files>

# Or, compress certain file types by extension:
<Files *.css>
SetOutputFilter DEFLATE
</Files>

# Or, compress certain file types by extension:
<Files *.js>
SetOutputFilter DEFLATE
</Files>

# Turn on Expires and set default to 0
ExpiresActive On
ExpiresDefault A0

# Set up caching on media files for 5 weeks
<FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up caching on media files for 5 weeks
<FilesMatch "\.(gif|jpg|jpeg|png|swf)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up 5 weeks caching on commonly updated files (change to A86400 for 1 day)
<FilesMatch "\.(xml|txt|html|js|css)$">
ExpiresDefault A3024000
Header append Cache-Control "proxy-revalidate"
</FilesMatch>

# Force no caching for dynamic files
<FilesMatch "\.(php|cgi|pl|htm)$">
ExpiresActive Off
Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
Header set Pragma "no-cache"
</FilesMatch>

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
It works for me...

Check out my site if you want... its a new one... http://www.prochem.net.nz

Any ideas about my image sub domain... any images that i load on the individual product pages wont load from images.prochem.net.nz they are still looking at http://www.porchem.net.nz/images/data ??? ??? :'( :'(

I'd appreciate any help O0 O0

Thanks

Jem

If i have helped... please click here to donate

Bookstore Mod
QuickShop Module
Restricted Access - Compulsory Login
Template Override - Category Specific (vQmod)
Template Override - Brand Specific (vQmod)
How did you find out about us register question mod
Compulsory Login vQmod
Brands In Top Menu
zoom - Product Image - Auto on hover


User avatar
Active Member

Posts

Joined
Thu Nov 11, 2010 6:11 pm
Location - New Zealand (Tokomaru, Palmerston North)

Post by spitos » Fri May 27, 2011 4:31 pm

I've since spoken to my hosts again and they said that they have changed a setting which should allow the expires settings.... Should've done it the first time around after telling me it was all done!

All working now!

Image
Google Analytics Expert - Advanced e-commerce tracking, Product & options reporting, transaction/conversion reporting, Google Adwords conversion & profit reporting, goal & funnel reporting, event tracking, site search tracking, multi-store compatibility, EU Cookie Law compliance and works with any theme or checkout! Easy vqmod install. Get it here


User avatar
Active Member

Posts

Joined
Mon May 23, 2011 6:19 pm
Location - UK

Post by Moggin » Tue Jul 26, 2011 4:11 am

Here is a heads-up on a possible page speed issue with fancybox 1.3.4.

This involves the fancybox css, at catalog/view/javascript/jquery/fancybox/jquery.fancybox-1.3.4.css.

There are reports that the IE-specific styling can cause minor 404 errors, page load slowdown and even browser freezing in IE. (example 1 | example 2 ) YSlow warns that the AlphaImageLoader filters are a problem. (More about this here).

A few fixes are suggested online, some of which advise fixing the paths in the IE styling with absolute URLs. I decided to just delete the IE styles, as discussed in this post.
http://www.opencart.com/forum/viewtopic ... 93#p177544

Your decision may differ, but hope this helps. Comments/advice welcome.

Active Member

Posts

Joined
Wed May 05, 2010 4:56 am

Post by Moggin » Sat Sep 10, 2011 4:39 am

New tutorial available:

How to use a subdomain for images

- courtesy of Qphoria...

Active Member

Posts

Joined
Wed May 05, 2010 4:56 am

Post by spitos » Fri Oct 21, 2011 5:25 pm

There is a mod for this which will improve page load speed massively.
With over 33,000 categories & 60,000+ products, page load time is fine.

http://www.opencart.com/index.php?route ... on_id=3444

Image
Google Analytics Expert - Advanced e-commerce tracking, Product & options reporting, transaction/conversion reporting, Google Adwords conversion & profit reporting, goal & funnel reporting, event tracking, site search tracking, multi-store compatibility, EU Cookie Law compliance and works with any theme or checkout! Easy vqmod install. Get it here


User avatar
Active Member

Posts

Joined
Mon May 23, 2011 6:19 pm
Location - UK

Post by vl2 » Mon Apr 16, 2012 5:20 pm

Thank you very much for this post.
Before i did Speed Up Page Content i got the score of 47/100 in google page rank but after i did evrything you said i got 92/100 that's awsome.
I found an explanation on how to create subdomain if any one is loking for it.
http://www.inmotionhosting.com/support/ ... n-opencart
also this site can cheack your speed
http://www.speedupper.com
thank's again!

i'm using v1.5.1.3

vl2
Newbie

Posts

Joined
Mon Apr 16, 2012 5:14 pm

Post by a2z » Fri Jun 08, 2012 8:37 pm

Hi, I have a .htaccess file in my public_html/ folder and another one in my /shop folder which is the root for opencart installation. Which one should I use to update? I tried doing google page speed tests putting the code in both locations, but still get the same errors and same score. Please tell me what I am doing wrong.

Nevermind. It works now. Not sure what happened.

a2z
New member

Posts

Joined
Tue May 01, 2012 9:43 am

Post by Phil_L » Sun Jun 10, 2012 8:41 pm

Is this is a "generic" .htaccess file - as in "it'll work with mine, as well as his..."

I am running some URL rewrite tool - do I just open the .htaccess I have and add the code.

Prior experiments with the .htaccess file (primarly to block inbound traffic from China, Nigera et al) has lead to a 500error.

My site is running 20,000 products - so, anything I can do (I have a java/css cache tool with the theme), I will run/have run server .gzip, but anything I can do to make this function would be, I guess, worth it?

aside, but aligned to page delivery speed - things like google fonts, Facebook pull in and twitter feeds? what is the general concensus? Keep'em or kill'em?
Jeremy Fisk wrote:Yep... I had a simmilar problem to "spitos" but my new .htaccess fixed it...
Postby spitos » Fri May 27, 2011 2:38 am

but I get 500 error... any ideas?

According to my info.php I should have gzip & deflate support...
Matt

All options that should be enabled are according to my host... any ideas anyone?
Try this

Code: Select all

php_flag magic_quotes_gpc off

<IfModule mod_deflate.c>
<FilesMatch "\.(js|css)$">
SetOutputFilter DEFLATE
</FilesMatch>
</IfModule>

php_value output_handler ob_gzhandler

# compress the files
AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/x-javascript
# removes some bugs
BrowserMatch ^Mozilla/4 gzip-only-text/html
BrowserMatch ^Mozilla/4.0[678] no-gzip
BrowserMatch bMSIE !no-gzip !gzip-only-text/html
Header append Vary User-Agent

# compress text, html, javascript, css, xml:
AddOutputFilterByType DEFLATE text/plain
AddOutputFilterByType DEFLATE text/html
AddOutputFilterByType DEFLATE text/xml
AddOutputFilterByType DEFLATE text/css
AddOutputFilterByType DEFLATE application/xml
AddOutputFilterByType DEFLATE application/xhtml+xml
AddOutputFilterByType DEFLATE application/rss+xml
AddOutputFilterByType DEFLATE application/javascript
AddOutputFilterByType DEFLATE application/x-javascript

# Or, compress certain file types by extension:
<Files *.html>
SetOutputFilter DEFLATE
</Files>

# Or, compress certain file types by extension:
<Files *.css>
SetOutputFilter DEFLATE
</Files>

# Or, compress certain file types by extension:
<Files *.js>
SetOutputFilter DEFLATE
</Files>

# Turn on Expires and set default to 0
ExpiresActive On
ExpiresDefault A0

# Set up caching on media files for 5 weeks
<FilesMatch "\.(flv|ico|pdf|avi|mov|ppt|doc|mp3|wmv|wav)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up caching on media files for 5 weeks
<FilesMatch "\.(gif|jpg|jpeg|png|swf)$">
ExpiresDefault A3024000
Header append Cache-Control "public"
</FilesMatch>

# Set up 5 weeks caching on commonly updated files (change to A86400 for 1 day)
<FilesMatch "\.(xml|txt|html|js|css)$">
ExpiresDefault A3024000
Header append Cache-Control "proxy-revalidate"
</FilesMatch>

# Force no caching for dynamic files
<FilesMatch "\.(php|cgi|pl|htm)$">
ExpiresActive Off
Header set Cache-Control "private, no-cache, no-store, proxy-revalidate, no-transform"
Header set Pragma "no-cache"
</FilesMatch>

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
It works for me...

Check out my site if you want... its a new one... http://www.prochem.net.nz

Any ideas about my image sub domain... any images that i load on the individual product pages wont load from images.prochem.net.nz they are still looking at http://www.porchem.net.nz/images/data ??? ??? :'( :'(

I'd appreciate any help O0 O0

Thanks

Jem

Home Study and Online Courses | Breakwater Brewing Co.


New member

Posts

Joined
Thu May 31, 2012 12:23 am


Post by bigpill » Fri Oct 12, 2012 3:09 pm

Regarding SSL and images, just thought I would post a reply as I was pulling my hair out on this as well....and the solution is simple.

Simply modify your config as such...
define('HTTPS_IMAGE', 'https://www.yourdomain.com/img/');

It's easy to get into "subdomain" tunnel vision, and forget that it can also be referenced as a subdirectory :-)

Newbie

Posts

Joined
Sat Feb 25, 2012 11:27 am

Post by ralphstirrat » Fri Jun 21, 2013 10:59 pm

Hi

I'm using 1.5.5.1 and the config file no longer has this line
define('HTTP_IMAGE', 'http://mydomain.com/');

Is it still possible to use a subdomain with 1.5.5.1?

Does anyone have any good suggestions for fast themes that still look modern?

Thanks

http://colbrook.co.uk


Active Member

Posts

Joined
Wed Aug 29, 2012 7:53 pm

Post by Spiritcraft » Sun Jun 23, 2013 12:35 pm

I switched themes in the middle of developing a new site due to load times. I settled on Kubera.. after running pagespeed tests on every responsive theme that had any decent modern look and features. I am not an expert but load times went from 5 seconds to 1.9 seconds. He must have done something with CSS sprites as well. It isn't free but free meant 5-7 seconds and a mess for me.

Some of the new responsive themes look wonderful, cool features, slideshows everywhere but they are beasts.

Newbie

Posts

Joined
Sun Jun 23, 2013 12:30 pm

Post by utomo » Tue Jul 02, 2013 10:52 am

If you want faster ones try this
http://www.opencart.com/index.php?route ... n_id=10573

I wish OpenCart can improve the speed without too many depend on extension, many people say current opencart is too slow.
If user want much faster then they can buy extension

New member

Posts

Joined
Sat Nov 26, 2011 12:55 pm

Post by paddys_1 » Thu Apr 23, 2015 8:06 pm

You can easily increase your site speed by compressing images with the following extension.

http://www.opencart.com/index.php?route ... n_id=18138

It's enables you to compress all the existing images on your site and then automatically optimises any that you upload afterwards.

Image


User avatar
New member

Posts

Joined
Wed Jul 16, 2014 6:04 am

Post by MaxD » Mon May 04, 2015 1:15 am

I have made 2 demos for people, that wish high PageSpeed scores:
http://demo.devs.mx/slow
http://demo.devs.mx/fast

Cartless (free) - "buy" button instead of "add to cart"
Stripper (free) - strip parts of OpenCart


User avatar
Active Member

Posts

Joined
Fri Jul 06, 2012 6:37 pm

Who is online

Users browsing this forum: No registered users and 4 guests