Post by mbeerden » Mon Dec 28, 2009 11:09 pm

Hi,

This test was for 23 products. So not so many. It is the meaning there will be uploaded 1500 products, is that possible?

With this test the strange thin is, that the products are imported to the site but wont show. When i open the admin i can see the products, they are active. When i select them, choose edit and save them they will appear on the site.

Another problem: i want to upload in total 10.000 products but it seems when i upload a list other products are removed from the site. Does Import/export always remove other product on the site or is there an option such as update only or add only?

Looking forward to the multilanguage version sounds good!

New member

Posts

Joined
Tue Nov 03, 2009 5:06 am

Post by JNeuhoff » Mon Dec 28, 2009 11:40 pm

mbeerden wrote:Hi,

This test was for 23 products. So not so many. It is the meaning there will be uploaded 1500 products, is that possible?

With this test the strange thin is, that the products are imported to the site but wont show. When i open the admin i can see the products, they are active. When i select them, choose edit and save them they will appear on the site.

Another problem: i want to upload in total 10.000 products but it seems when i upload a list other products are removed from the site. Does Import/export always remove other product on the site or is there an option such as update only or add only?

Looking forward to the multilanguage version sounds good!
Take a look here, if you want to import 10,000 products you need a dedicated web server, not one on a simple shared web host, because it will use several hundred MB of process memory during the actual import.

As regards your spreadsheet file: If you send it to me I can take a look at it and try it out on my test server to see if there are any problems.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by OpenFan » Tue Dec 29, 2009 4:06 am

OpenFan wrote:I instaled import/export module.
I have PEAR library.

Error after export :
Fatal error: Class 'OLE_PPS' not found in /..../public_html/opencart1/admin/OLE/PPS/File.php on line 32
It works!
My PEAR was a "clear ,default" instalation.
After instal OLE package everything is OK.
My sugestion for readme file: list of Pear packages for Export/Import module.

Newbie

Posts

Joined
Mon Dec 14, 2009 4:43 am

Post by rebirth » Fri Jan 15, 2010 4:37 pm

I was wondering if this will work on the new 1.4 version? Or will there be an update for this module to work with it?

New member

Posts

Joined
Fri Jan 15, 2010 4:36 pm
Location - .be

User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by ebeing » Sat Jan 23, 2010 5:56 am

This module will not add new products, isnt it supposed to?

It added my NEW categories just fine but, not the products.

New member

Posts

Joined
Wed Jan 06, 2010 2:18 pm

Post by JNeuhoff » Sat Jan 23, 2010 6:09 am

ebeing wrote:This module will not add new products, isnt it supposed to?

It added my NEW categories just fine but, not the products.
It should import both categories and products.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by cmebd » Sat Jan 23, 2010 6:58 am

JNeuhoff wrote:This module will not add new products, isnt it supposed to?

It should import both categories and products.
Hi JNeuhoff,

I PM'd you a last week reporting the same problem. When exporting the product info is not included. Xls file attached.

Cheers
Christine

Attachments


A stupid question is the one you -don't- ask.........(Anon)

)C1.5.0.1 (IN devel)
OC V1.4.9.5
OC V1.4.9.2
OC V1.4.7
OC V1.3.4


User avatar
Active Member

Posts

Joined
Fri Nov 13, 2009 11:17 am
Location - Tasmania, Australia

Post by JNeuhoff » Sat Jan 23, 2010 7:20 am

cmebd wrote: Hi JNeuhoff,

I PM'd you a last week reporting the same problem. When exporting the product info is not included. Xls file attached.

Cheers
Christine
I'll take a look at your file this weekend.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by cmebd » Fri Jan 29, 2010 3:06 am

Hi JN,

Any ideas on where the problem lies with the lack of product information parsing in the export csv file?

Cheers

A stupid question is the one you -don't- ask.........(Anon)

)C1.5.0.1 (IN devel)
OC V1.4.9.5
OC V1.4.9.2
OC V1.4.7
OC V1.3.4


User avatar
Active Member

Posts

Joined
Fri Nov 13, 2009 11:17 am
Location - Tasmania, Australia

Post by cmebd » Fri Jan 29, 2010 9:13 pm

JNeuhoff wrote:

I'll take a look at your file this weekend.
I lost the import/export due to some other modules overwriting..... however have now been through and updated file by file coding from the files provided by this module - so all is now working again.

I have done an export of what I have on the server (which is not much at all) but I am getting the name of the category under "name" rather than the product name.

Any ideas on what the problem may be?????

Tia

A stupid question is the one you -don't- ask.........(Anon)

)C1.5.0.1 (IN devel)
OC V1.4.9.5
OC V1.4.9.2
OC V1.4.7
OC V1.3.4


User avatar
Active Member

Posts

Joined
Fri Nov 13, 2009 11:17 am
Location - Tasmania, Australia

Post by rossradiation » Mon May 24, 2010 8:36 pm

Hello,
I have Open Cart 1.3.4 installed, is it possible to still get the this module for that version or will I have to upgrade my OpenCart to the latest version

I noticed the link in this forum is now dead

Ross

Newbie

Posts

Joined
Mon May 24, 2010 8:33 pm

Post by rossradiation » Wed May 26, 2010 10:20 pm

I had a couple of strange problems installing this (v 1.3.4), I wonder if anyone has had similar errors

firstly, when I first tried to Export the XLS file , I received an SQL error saying the field po.type did not exist... sure enough this field does not exist in the product_options table of my database

I removed the reference in the SQl statement and now the SQL statement runs without error, I have tested this in PHPMyAdmin and the query even returns desired results (good)

BUT every time I run the Export function I download a 0kb Excel file (which has no data in it at all)

any ideas?

Newbie

Posts

Joined
Mon May 24, 2010 8:33 pm

Post by JNeuhoff » Thu May 27, 2010 12:01 am

I have uploaded a new release for 1.3.4 with some bugfixes and updates. Try it again with this new release which you can download from http://www.mhccorp.com/downloads-opencart.shtml

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by rossradiation » Thu May 27, 2010 7:44 am

Thank you, the new version definitely fixes the SQL error I was getting.
However I am still getting a blank 0kb file from the download.
I have tried it in Chrome and Firefox with the same result.
I'll have a tinker with it later on.
What was interesting was when I used PHP to print_r the array (the product details are stored in) the array appeared in the XLS file. So the ability to write to the XLS file is working, but the product details are not being written to it.
Ross

Newbie

Posts

Joined
Mon May 24, 2010 8:33 pm

Post by JNeuhoff » Thu May 27, 2010 7:05 pm

Send me a PM with a copy of your database, or alternatively the PHPMyAdmin, FTP, and OpenCart login details, I can take a look at it. It's working fine on my 1.3.4 test server, so I am unable to replicate your error without further details from you.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Mon May 31, 2010 11:53 pm

I have tested the Export with your database from your PM, and it works fine with your database, too. Something else must be wrong on your server's configuration. Have you checked your error_log?

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am

Who is online

Users browsing this forum: No registered users and 4 guests