Post by fido-x » Fri Jun 26, 2009 11:31 am

First up, apologies for my tardiness in getting these done. I should have had them done some time ago, but have been staying at my daughter's place (due to family matters) and my daughter doesn't have access to the Internet.

I've been having a few problems with my own server lately, I run it from home and I haven't been there very often over the past couple of months. There has been a lot of (much needed) rain where I live that has been causing problems with power outages which keeps knocking my server offline. So, to ensure the availability of these modules, I have uploaded them to the main contributions site.

The following packages have been updated and are available from OpenCart Contributions. All packages have been updated for version 1.2.8 and beyond and have been tested on both 1.2.8 and 1.2.9.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by phpuk » Fri Jun 26, 2009 6:28 pm

Hi fido-x,

Thank you very much for your contributions.
They are popular addons especially the Homepage and news modules.

Phil.

Global Moderator

Posts

Joined
Wed Mar 25, 2009 10:57 am

Post by allsop » Sat Jun 27, 2009 8:33 am

First, thanks for the modules. But I'm having a problem with the FAQ module. I have followed all of the install instructions to the letter. When I get to the Admin section and select "Admin–>Configuration–>Users–>User Group" and then click the edit link in the action column for the "Top Administrator", tick the checkboxes for "catalog/faq" in both the "Access" and "Modify" lists, then click the "Save" button; I get a "Forbidden" page in my browser. That's it. Can't go any further.

Any ideas would be appreciated.

New member

Posts

Joined
Fri Jun 05, 2009 1:17 am

Post by allsop » Wed Jul 01, 2009 12:30 am

I've tried setting magic_quotes_gpc to OFF and this did not help. Any other suggestions?

Thanks.

New member

Posts

Joined
Fri Jun 05, 2009 1:17 am

Post by d0tb0t » Wed Jul 01, 2009 11:31 pm

You forgot about " . DB_PREFIX . " please fix it ;)

Newbie

Posts

Joined
Wed Jun 24, 2009 2:50 am

Post by allsop » Thu Jul 02, 2009 12:40 am

The oc database is not shared and there is no prefix. Is this what you were saying? If not, please except my apologies and elaborate. :)

New member

Posts

Joined
Fri Jun 05, 2009 1:17 am

Post by d0tb0t » Thu Jul 02, 2009 12:52 am

OpenCart v1.2.9

Whats New
DB Prefixes
WorldPay Payment Module
SagePay Payment Module
Seo URL's
Category Descriptions
http://forum.opencart.com/viewtopic.php?f=2&t=4486

Newbie

Posts

Joined
Wed Jun 24, 2009 2:50 am

Post by allsop » Thu Jul 02, 2009 1:03 am

I'm using 1.2.8, didn't think there were enough updates to warrant a change from 1.2.8 to 1.2.9 - Besides Fido-x said the modules were for both releases.

New member

Posts

Joined
Fri Jun 05, 2009 1:17 am

Post by fido-x » Thu Jul 02, 2009 1:08 pm

d0tb0t wrote:
OpenCart v1.2.9

Whats New
DB Prefixes
WorldPay Payment Module
SagePay Payment Module
Seo URL's
Category Descriptions
http://forum.opencart.com/viewtopic.php?f=2&t=4486
The "DB Prefix" is stored in the configuration file (config.php and admin/config.php). Since my contributions aren't involved with payments, I don't need to provide support for any payment modules. I will include support for "SEO URLs" in the next release.
allsop wrote:I'm using 1.2.8, didn't think there were enough updates to warrant a change from 1.2.8 to 1.2.9 - Besides Fido-x said the modules were for both releases.
The modules were built on 1.2.8, but are compatible with 1.2.9.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by d0tb0t » Thu Jul 02, 2009 8:42 pm

but are compatible with 1.2.9.
NOT compatible with 1.2.9
1.2.9 use DB PREFIX in all db query
I received an error installing your module on OC 1.2.9
had to rewrite 8)

Newbie

Posts

Joined
Wed Jun 24, 2009 2:50 am

Post by op_sjo » Fri Jul 03, 2009 9:22 pm

I'm having some problems with the FAQ package on 1.2.9

1) I have no "catalog/controller/module/information.php" file to update, however I do have a "catalog/controller/module/information/information.php" file. I tried putting the text in there but i'm seeing some odd results (see #2 below).

2) On the root page of the site, the menu text isn't working for FAQ. I just get "text_faq" instead of the correct link text. The link does work though. Once I clicked the link and get to the FAQ page (of which all text in the FAQ displays correctly), the menu link has changed text to "Get answers to those commonly asked questions!" (which is also the heading on the faq column itself).

Any thoughts? O0



Thanks!

Newbie

Posts

Joined
Thu Jul 02, 2009 6:14 am

Post by DannyMacD » Wed Jul 08, 2009 8:00 pm

hi fido..

great modules. for someone new to OpenCart they ahve been simple to install.

i just wanted to ask if i wanted catagories for the FAQ one is this possible?

example.

i want to have FAQ for different things. maybe one on processes, one on services etc

cheers :)

Active Member

Posts

Joined
Fri Jun 26, 2009 6:39 am

Post by fido-x » Fri Jul 10, 2009 12:48 pm

Hi Danny,

In answer to your question, the FAQ package could be modified to include categories/subcategories for questions, making it similar to the "Categories" module. However, this can cause conflicts with the "Category" module if "path" is used (I found this out when I built an image gallery module for my own site). But, having said that, the conflict is easily resolvable with a slight modification to the controller for the "Category" module.
Customizing the module to suit your requirements will require a small donation (which can be made by clicking the "Donate" button at http://www.fido-x.net/index.php?route=i ... ion/donate). PM me if you would like the customization done.
d0tb0t wrote:
but are compatible with 1.2.9.
NOT compatible with 1.2.9
1.2.9 use DB PREFIX in all db query
I received an error installing your module on OC 1.2.9
had to rewrite 8)
I understand where you're coming from (I hadn't looked at the code in the "model" in 1.2.9 before releasing these modules - my bad, I hadn't fully tested them on 1.2.9). This issue will be addressed in the next release. However, it should be noted, that this is not really a DB_PREFIX - it's more of a table prefix, since it is not the database that is prefixed, it is the tables within the database that are prefixed. As for the compatibility issue - if you are not using database prefixes, the modules will work with 1.2.9.
allsop wrote:First, thanks for the modules. But I'm having a problem with the FAQ module. I have followed all of the install instructions to the letter. When I get to the Admin section and select "Admin–>Configuration–>Users–>User Group" and then click the edit link in the action column for the "Top Administrator", tick the checkboxes for "catalog/faq" in both the "Access" and "Modify" lists, then click the "Save" button; I get a "Forbidden" page in my browser. That's it. Can't go any further.

Any ideas would be appreciated.
Does the user you logged in as have the necessary permissions to modify the "Top Administrator"? If you do have the necessary permissions, it may have something to do with ownership or permissions of the files themselves. I haven't come across this problem myself, so I'm not sure how to resolve it.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by DannyMacD » Mon Jul 13, 2009 10:09 pm

hi Fido-x,

just wondering if you had a chance to see my PM :)

let me know . ;)

cheers

Active Member

Posts

Joined
Fri Jun 26, 2009 6:39 am

Post by fido-x » Tue Jul 14, 2009 11:20 am

The above modules have been updated for OpenCart 1.2.9. Now provide support for DB_PREFIX and include instructions for SEO URLs.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by fossy » Wed Jul 15, 2009 5:12 am

Thank you for news-module, works proper 8)
Only a small error has crept in:
In news.sql the 'keyword'-field is missing and its better to set the collation/charset to utf-8.

Dirk
--
...it' never too late!


User avatar
New member

Posts

Joined
Tue Jun 02, 2009 3:19 am

Post by Rich » Fri Jul 31, 2009 12:12 am

Hi guys

I am trying to get the FAQs' working on OpenCart 1.3. I got it to work perfectly, but one thing.

On the module information it will not show FAQs' link.

If I go to mywebsite.com/index.php?route=information/faq it works perfectly. In admin it works to.

What I find out is that in installation file is: Edit your store‘s "catalog/language/english/information.php" file by adding the following line:–

$_['text_faq'] = 'FAQs';


but in Opencart 1.3 is catalog/language/english/module/information.php

So I looked and looked where i can change the information so I get link in my information module, but i can't find it.

Can you guys help?? FAQs' its grate I really like to use it.

Thaks

Rich
Bird is the word


User avatar
New member

Posts

Joined
Tue Jul 28, 2009 2:56 am
Location - Bird Cage

Post by fido-x » Fri Aug 07, 2009 1:01 pm

Rich wrote:What I find out is that in installation file is: Edit your store‘s "catalog/language/english/information.php" file by adding the following line:–
$_['text_faq'] = 'FAQs';
but in Opencart 1.3 is catalog/language/english/module/information.php
So I looked and looked where i can change the information so I get link in my information module, but i can't find it.
Can you guys help?? FAQs' its grate I really like to use it.
Thaks
You need to edit the following files:--
"catalog/controller/module/information.php" by adding --

Code: Select all

$this->data['text_faq'] = $this->language->get('text_faq');
$this->data['faq'] = $this->url->http('information/faq');
"catalog/language/english/module/information.php" by adding --

Code: Select all

$_['text_faq'] = 'FAQs';
and "catalog/view/theme/default/template/module/information.tpl" by inserting --

Code: Select all

<li><a href="<?php echo $faq; ?>"><?php echo $text_faq; ?></a></li>
While on the subject of FAQs, the FAQ package has been updated and now supports topics and sub-topics. Get it from http://www.fido-x.net/index.php?route=p ... duct_id=42

The following modules have also been updated for OpenCart 1.3.0:--
Homepage Package -- http://www.fido-x.net/index.php?route=p ... duct_id=40
News Package -- http://www.fido-x.net/index.php?route=p ... duct_id=39
Events Calendar -- http://www.fido-x.net/index.php?route=p ... duct_id=41
Sponsors Module -- http://www.fido-x.net/index.php?route=p ... duct_id=38

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Rich » Fri Aug 07, 2009 9:05 pm

fido-x you are a genius :D Thank you so much it works perfectly. Just finished installing faq, news and sponsors and they are grate.

I have one question about your sponsors module: after I upload image 160 px by 250 px it will get converted to much smaller version. Where I can set it so if I upload image 300 x 500 or so it will convert it to 160px x what ever length ?

Anyway thank you again for your work its grate.

Rich
Bird is the word


User avatar
New member

Posts

Joined
Tue Jul 28, 2009 2:56 am
Location - Bird Cage

Post by fido-x » Tue Aug 11, 2009 2:03 pm

Rich wrote:fido-x you are a genius :D Thank you so much it works perfectly. Just finished installing faq, news and sponsors and they are grate.

I have one question about your sponsors module: after I upload image 160 px by 250 px it will get converted to much smaller version. Where I can set it so if I upload image 300 x 500 or so it will convert it to 160px x what ever length ?

Anyway thank you again for your work its grate.
Thanks for the compliment.

The default image size for the module is set at 160 x 60 and is hard-coded in the controller (catalog/controller/module/sponsors.php). If you want to change it to a size more suitable for your own purposes, this is the file to look in.

Regards, Fido-X.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia
Who is online

Users browsing this forum: No registered users and 9 guests