Post by JNeuhoff » Wed Apr 08, 2009 2:09 am

We have a released a new module for those who do NOT want to support MS Internet Explorer 6 or older for Opencart 1.2.x.

This package implements an automatic browser warning feature. If the user tries to access the store frontend using MS Internet Explorer 6 or older, an error page is displayed with information on how to upgrade to a newer standard compliant web browser.

This module was inspired by the Stop IE6 campaign. It's implemented for the English language only, but can easily be translated into other languages.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by make-oc » Thu Apr 09, 2009 2:49 pm

How many IE6 and older customers have you had – ever looked into the logfiles?
Forgive me, but as much as I like and understand the reasoning it's a useless campain. Those still on IE6 will very often sit im companies where they have good reasons for staying with IE – for example there is two CMS which still only work with IE6 and a company may have paid a lot of money for these CMS. They're not happy, but have to live with it.
So, make things work for all your potential customers, after all you want them to shop at you site!

Just my opinion

Cheers

New member

Posts

Joined
Tue Apr 07, 2009 2:17 pm

Post by JNeuhoff » Thu Apr 09, 2009 9:22 pm

Just updated the module and it now works for Opencart 1.2.6.

User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Thu Apr 09, 2009 9:26 pm

How many IE6 and older customers have you had – ever looked into the logfiles?
Yes, I have. No more than 10 to 15 percent, not enough to justify putting in more work to create non-standard CSS work arounds just for IE6. But you are right, for some businesses it might not be that easy, though I don't understand why some companies bought software products which would only work on a non-standard compliant buggy web browser.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by Daniel » Mon May 04, 2009 11:45 pm

the latest version does not have a problem with IE6. I fixed all the errors using a virutal pc running windows xp and IE6.

User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm

Post by JNeuhoff » Tue May 05, 2009 12:04 am

the latest version does not have a problem with IE6.
Thanks, good to know it now works with IE6.

Though I still think it would be nice for IE6 to come to its end sooner than later. >:D

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by JNeuhoff » Fri May 08, 2009 7:07 pm

The IE6 Browser Warning module has been successfully tested for the latest Opencart 1.2.8 release.

Useful for those who don't want to support IE6 though the Opencart 1.2.8 default templates should now mostly work with IE6.

User avatar
Expert Member
Online

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by yrshopping » Sun Jan 24, 2010 12:57 am

J.Neuhoff

Since I am use v.1.3.4 for online shop, and I like yr browser warning module, however it's not 1.3.4 module because I found index.php is differ. so do you have v.1.3.4 IE6 Browser Warning Module for our installation.

b.rgds
David Wei
yrshopping@gmail.com

New member

Posts

Joined
Wed Aug 12, 2009 12:42 pm

Post by nzjollyroger » Thu Feb 18, 2010 5:05 pm

Hay All,
does anyone have a fix to make this work with opencart 1.3.2???

New member

Posts

Joined
Mon Nov 16, 2009 5:26 am

Post by yrshopping » Thu Feb 18, 2010 10:29 pm

can you fix module to v.1.3.4? thank you in advance.

New member

Posts

Joined
Wed Aug 12, 2009 12:42 pm

Post by hillfish » Wed Mar 03, 2010 5:24 am

Seriously people - this is just crazy !!!
This is an ecommerce package, not some clique website. It is simply unthinkable for any serious (or even half serious) buisness to put up an ecommerce website that doesn't support ie6. I saw someone in this thread quoting 10-15% of visitors still using ie6 - personally I would put the figure a bit higher than that (at least 20%). To knowingly allow an ecommerce website to not be properly usable by 20% of your potential customers is commercial suicide - online retail is hard enough without turning away customers.

As far as I'm concerned any template that breaks ie6 compatibility is essentially useless without modding. I have been looking around at some of the commercially available templates (many linked to from this forum), and time & again the template authors state they will not support ie6 - well they need to re-think that attitude - this is not about designing what you yourself might want. If your actually selling templates for opencart then your wasting your time and loosing customers if you don't support ie6 - period.

Sorry for such a rant - not much really sets me off, but I kinda understand this 'stop ie6' attitude/movement and it is an attitude that does no one any favours. ie6 will die by it's self just as ie5 did - when visitor numbers get down to 1-2% using ie6 then it's reasonable to call it 'dead', but 20% (or even 15%) is a very long way from that ... A VERY LONG WAY !

Cloe

New member

Posts

Joined
Wed Mar 03, 2010 2:31 am
Who is online

Users browsing this forum: No registered users and 2 guests