Post by straightlight » Sat Jun 18, 2016 11:04 pm

This contribution allows to add a logo with customer group that would simply show on the first row of the logged in header page. Feel free to customize this VQMod release at your own will for your custom template.

Contribution: http://www.opencart.com/index.php?route ... n_id=27009

Documentation updated with SQL query.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Sun Jun 19, 2016 12:12 am

Added it's place to the DB by Query ok, and it works, partially ;)
When trying to log in from the Header Icon, it presents an error, still,
the login Link below the error works.

But If I am logged in, it presents the Image inside of the same LOGIN Header Section,
but not on the Account page itself.
Ernie

just try to open the Header Login:
http://www.bigmax.ch/oc22/index.php?route=common/home
or then log in, by use of:
beni |at| jacob.ch --- password: beni
and then click the header Login Icon again.
Last edited by IP_CAM on Mon Jun 20, 2016 6:33 am, edited 1 time in total.

Please do NOT send me Personal Mails, they will no longer be replied to.
---
My Github OC Site: https://github.com/IP-CAM
2'800+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Sun Jun 19, 2016 8:01 am

The red arrow is not pointing to the right location on your picture. It should rather point to the VQCache error message you are receiving. From the XML file, you could remove the last step and manually add the inside-add portion into your custom theme where indicated. This should resolved the problem, afterwards.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by IP_CAM » Mon Jun 20, 2016 5:19 am

I had to rewrite it, to get that image out of the Header-Section, and into the User Page.
I now used a fast-draw type combination between our both VqMods, to make it work, so far.
But still, the IMAGE Height Value needed to be declared, you declared twice the width,
and I changed the Variables product_width+height to category_width + category_height,
because I didn't like the large Product-Image Size of 250x200px. reflected on the User Main Page.

But I changed it all afterwards, because I prefer to declare/define a simple fixed Image Size on the User Page
for this specific purpose into the VqMod, since it is not to be defined seperately in the Admin Theme
Image-Size Section, as it comes. So, I declared 250 x 100 px. in the VqMod on Line 118
of the Code, to make it work!

Code: Select all

$data['image'] = $this->model_tool_image->resize($customer_group['image'], 250, 100);
whereby the responsive thing still shrinks it then from: 250px × 100px to (Skaliert zu 240px × 96px) !! :-\
I guess, I still have to work on this. :D
---
to be corrected in your VqMod, I assume, and also depending on theme-related Image settings:

Code: Select all

$data['image'] = $this->model_tool_image->resize($customer_group['image'], $this->config->get($this->config->get('config_theme') . '_image_category_width'), $this->config->get($this->config->get('config_theme') . '_image_category_height'))
Ernie
---
PS. I created 2 different VqMod Extensions here, to make either a TEXT-TITLE or a User-Group
specific IMAGE visible in the Account Main Section.
Good Luck ! If it does not work, then, it's not a Default Theme OC v.2.2 Problem,
and I have no other v.2 - Version, to check on anything! ;)
---
1. Account Welcome plus Customer Group Logo for OpenCart v.2.x
2. Account Welcome plus Customer Group ID - Title for OpenCart v.2.x
(VqMod OC 2.2.0.0 only !)
http://www.opencart.com/index.php?route ... n_id=27046
Last edited by IP_CAM on Thu Jun 23, 2016 7:47 am, edited 4 times in total.

Please do NOT send me Personal Mails, they will no longer be replied to.
---
My Github OC Site: https://github.com/IP-CAM
2'800+ FREE OC Extensions on the World's largest Github OC Repository Archive Site.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by straightlight » Mon Jun 20, 2016 6:14 pm

I couldn't upload yesterday on this old outdated platform, sorry. Here's my version.

Edit: File deleted. It was for another contribution. My first post on this topic is still the official release.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 8 guests