Post by deeve » Sun Jun 01, 2014 8:19 pm

Hi everyone, I've been at this for 3 days straight now, am seeing double & would really appreciate any advice re: OpenCart

Last week my Webfusion VPS decided to perform an automatic Plesk upgrade to 11.5.30 Update #45 & for some strange reason this has affected one of my sites & not the others ability to export using Export/Import extension by JNeuhoff. The process appears to do nothing then times out after 2 minutes.

I have tried adjusting PHP memory limits in both etc/Apache2/php.ini & my custom php.ini files in both httpdocs & admin folders. I've also tried setting 'session.gc_probability = 0;' as thought it was a session cache problem, with no success.

This particular site does use SEO keyword friendly products & category names so have the .htaccess file enabled which contains the following:

Code: Select all

Options +FollowSymLinks +SymLinksIfOwnerMatch
Options -Indexes
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
php.ini in admin folder:

Code: Select all

magic_quotes_gpc = Off;
register_globals = Off;
default_charset	= UTF-8;
memory_limit = 3072M;
max_execution_time = 18000;
upload_max_filesize = 999M;
safe_mode = Off;
mysql.connect_timeout = 20;
session.use_cookies = On;
session.use_trans_sid = Off;
session.gc_maxlifetime = 12000000;
allow_url_fopen = on;
In my server's error log I get the error:
Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /
and yet no error in my OpenCart system error log.

I've attached the output from a phpinfo.php file in the admin folder. If anyone has time just to look it over & let me know where I'm going wrong I'd really appreciate as I'm not so familiar with Apache permission setups.

Thanks in advance.
Last edited by deeve on Mon Jun 02, 2014 4:28 pm, edited 1 time in total.

Active Member


Tue Oct 20, 2009 4:31 pm

Post by TAC » Mon Jun 02, 2014 3:52 am

No idea if this is relevant or not but I am on the Plesk 11 too and could not get the export/import tool to work.

Best place to post about this is in the E/I thread as the developer is very active in there.

I ended up switching to the Smart E/I tool :) ... n_id=12348

User avatar
Active Member


Sun Sep 26, 2010 1:33 am
Location - England

Post by deeve » Mon Jun 02, 2014 8:32 am

Thanks for the suggestion TAC but I would like to understand why this has happened as I do have other sites on my VPS which were not affected. This one is the only site which has SEO keywords enabled & therefore uses an .htaccess file but worked fine before Plesk 11 upgrade so the problem must be related.

Maybe someone else has had the same problem recently?

Active Member


Tue Oct 20, 2009 4:31 pm
Who is online

Users browsing this forum: No registered users and 12 guests