Post by nodric » Wed Nov 02, 2011 1:19 am

Having now made some changes in mytheme stylesheet.css, I notice they are not effective. i.e. Unless I make the changes in the default template stylesheet.css file they are not in effect.

In keep with the directions on the forum I have not simply copied the default folder to make my own theme, so maybe I missing some files? I do have a copy of stylesheet.css in there, and the rest of the stylesheet folder is there too.

If I disable the default template stylesheet.css file I lose all formatting, so it is using that file.

TIA
Last edited by nodric on Wed Nov 02, 2011 4:19 am, edited 2 times in total.

The Best 4x4xfar


Active Member

Posts

Joined
Wed Jul 06, 2011 10:39 pm

Post by labeshops » Wed Nov 02, 2011 1:42 am

In your custom template, look at common/header.tpl

Look at the path information for the stylesheet. Is it correct? My guess is it is using the default path instead of your custom template path.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by nodric » Wed Nov 02, 2011 4:17 am

labeshops wrote:In your custom template, look at common/header.tpl

Look at the path information for the stylesheet. Is it correct? My guess is it is using the default path instead of your custom template path.

You are indeed a wise man! I on the other hand, am a burke for not checking ;D

The Best 4x4xfar


Active Member

Posts

Joined
Wed Jul 06, 2011 10:39 pm

Post by labeshops » Wed Nov 02, 2011 4:26 am

nodric wrote:
labeshops wrote:In your custom template, look at common/header.tpl

Look at the path information for the stylesheet. Is it correct? My guess is it is using the default path instead of your custom template path.

You are indeed a wise man! I on the other hand, am a burke for not checking ;D
Lol Wise WOman actually, but thanks for the compliment :)

And actually, first template I did, I did the same thing. Took me like an hour to figure it out! lol

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by phil-smiler » Mon Dec 05, 2011 10:46 pm

Hi, im having a problem with this too, i have installed a theme, in the new theme i needed to change the color of text from the default color as its gray and the details including price and product code dont show easily, i have edited the stylesheet but even tho the changes show in the style sheet they seem to make no changes on the site?

Please help im rather confused now..

regards
phil

Active Member

Posts

Joined
Tue Jul 12, 2011 5:17 pm

Post by nodric » Mon Dec 05, 2011 11:39 pm

phil-smiler wrote:Hi, im having a problem with this too, i have installed a theme, in the new theme i needed to change the color of text from the default color as its gray and the details including price and product code dont show easily, i have edited the stylesheet but even tho the changes show in the style sheet they seem to make no changes on the site?

Please help im rather confused now..

regards
phil
In the files you copied to create your custom theme, you should have copied common/header.tpl ?

Edit that file and change the path to point to the 'custom' theme.

This line

<link rel="stylesheet" type="text/css" href="catalog/view/theme/default/stylesheet/stylesheet.css" />


Change default to your theme name (the folder name in which your theme files live)

Nodric

The Best 4x4xfar


Active Member

Posts

Joined
Wed Jul 06, 2011 10:39 pm

Post by phil-smiler » Mon Dec 05, 2011 11:55 pm

SOLVED, thank you

Active Member

Posts

Joined
Tue Jul 12, 2011 5:17 pm

Post by zequinhaBSB » Tue Jul 30, 2013 1:39 am

Great product!!!

Just a suggestion (even though I believe that holding hands is not a good practice on free products): move the default stylesheets (stylesheet.css, carrousel.css, slideshow.css) to the controller.php where those files are automatically loaded with the chosen theme.

Newbie

Posts

Joined
Wed Jul 18, 2012 6:40 am
Who is online

Users browsing this forum: No registered users and 17 guests