Post by thegeekz » Wed May 25, 2011 2:45 pm

Hi everyone!

I have been trying to utilise the beautiful Yoocart 001 to 003, but all face the same problems:

1) Home page, latest products module did not launch, instead shows the following error:
Notice: Undefined variable: modules in /home/thegeekz/public_html/catalog/view/theme/yoocart002/template/common/home.tpl on line 48Warning: Invalid argument supplied for foreach() in /home/thegeekz/public_html/catalog/view/theme/yoocart002/template/common/home.tpl on line 48

For Yoocart001:

Notice: Undefined variable: modules in /home/thegeekz/public_html/catalog/view/theme/yoocart001/template/common/home.tpl on line 29Warning: Invalid argument supplied for foreach() in /home/thegeekz/public_html/catalog/view/theme/yoocart001/template/common/home.tpl on line 29

For Yoocart003:

Notice: Undefined variable: modules in /home/thegeekz/public_html/catalog/view/theme/yoocart003/template/common/home.tpl on line 20Warning: Invalid argument supplied for foreach() in /home/thegeekz/public_html/catalog/view/theme/yoocart003/template/common/home.tpl on line 20


Apparently, all the lines above in the home.tpl = <?php foreach ($modules as $module) { ?>

Really a noob at this, and really do not know why this happens.

** Other themes I use like the Lilac, is ok without such a problem...


2) Seems the Numberings formatting's alignment is way off to the left, any suggestion how to re-align this properly?


Anyone can help? At the moment I shall search for other free themes...

Thank you..
Last edited by thegeekz on Thu May 26, 2011 3:40 pm, edited 1 time in total.

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by hbuchel » Wed May 25, 2011 10:42 pm

What version of OC are you using? Try posting the contents of your home.tpl file.

New member

Posts

Joined
Mon Aug 30, 2010 9:41 pm

Post by thegeekz » Thu May 26, 2011 3:30 pm

As per my signature, I'm using 1.49.3...

Not sure if the home.tpl code will help? this is from the Theme Yoocart001...

I'm looking at Yoocart 002 & Yoocart 003.. maybe I should also post the home.tpl in separate post..

Code: Select all

<?php echo $header; ?>

<table id="contentMainWrapper" border="0" cellpadding="0" cellspacing="0" width="100%">
	<tbody><tr>
    
        <td id="column-left" style="width: 230px;">
            <div style="width:230px;">
                <?php echo $column_left; ?>
            </div>
        </td>
        
        <td id="column-center" valign="top">
            
            
        
            <?php if ($welcome) { ?>
            <div class="column-center-padding">
                <div class="centerColumn" id="indexDefault">
                    <h1 class="titleName"><?php echo $heading_title; ?></h1>
                    
                    <?php echo $welcome; ?>
                </div>                    
                <div class="clear"></div>
            </div>
            <?php } ?>
        
        
        
            <?php foreach ($modules as $module) { ?>
            <?php echo ${$module['code']}; ?>
            <?php } ?>
        </td>
    
    
    </tr>
</tbody></table>


</div>
</div>
</div>

<?php echo $footer; ?> 

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by thegeekz » Thu May 26, 2011 3:36 pm

Yoocart002's home.tpl

Code: Select all

<?php echo $header; ?>

<table id="contentMainWrapper" border="0" cellpadding="0" cellspacing="0" width="100%">
	<tbody><tr>
    
        <td id="column-left" style="width: 230px;">
            <div style="width:230px;">
                <?php echo $column_left; ?>
            </div>
        </td>
        
        <td id="column-center" valign="top">
            
            
        
            <?php if ($welcome) { ?>
            <div class="column-center-padding">
                <div class="centerColumn" id="indexDefault">
                    <h1 class="titleName"><?php echo $heading_title; ?></h1>
                    
                    <?php echo $welcome; ?>
                </div>                    
                <div class="clear"></div>
            </div>
            <?php } ?>
        
        
        
            <?php foreach ($modules as $module) { ?>
            <?php echo ${$module['code']}; ?>
            <?php } ?>
        </td>
    
    
    </tr>
</tbody></table>


</div>
</div>
</div>

<?php echo $footer; ?> 

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by thegeekz » Thu May 26, 2011 3:39 pm

Yoocart003's home.tpl:

Code: Select all

<?php echo $header; ?><?php echo $column_left; ?><?php echo $column_right; ?>
<div id="content">
  <?php if ($welcome) { ?>
  <div class="top">
    <div class="left"></div>
    <div class="right"></div>
    <div class="center">
      <h1><?php echo $heading_title; ?></h1>
    </div>
  </div>
  <div class="middle">
    <div><?php echo $welcome; ?></div>
  </div>
  <div class="bottom">
    <div class="left"></div>
    <div class="right"></div>
    <div class="center"></div>
  </div>
  <?php } ?>
  <?php foreach ($modules as $module) { ?>
  <?php echo ${$module['code']}; ?>
  <?php } ?>
</div>
<?php echo $footer; ?> 

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by thegeekz » Sun May 29, 2011 10:08 am

any expert can help?


Using Lilac or default theme has no issues...

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by qahar » Sun May 29, 2011 7:32 pm

The code look fine. Try to check the controller.
Open catalog\controller\common\home.php, and check is the code bellow available.

Code: Select all

$module_data = $this->model_checkout_extension->getExtensionsByPosition('module', 'home');
$this->data['modules'] = $module_data;

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by thegeekz » Sun May 29, 2011 10:29 pm

qahar wrote:The code look fine. Try to check the controller.
Open catalog\controller\common\home.php, and check is the code bellow available.

Code: Select all

$module_data = $this->model_checkout_extension->getExtensionsByPosition('module', 'home');
$this->data['modules'] = $module_data;
Hmm searched for this code in home.php in controller folder, but its not found... so where do I add this in the php file?

Is this a must for the Yoocart templates/themes?

Thank you.

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by qahar » Sun May 29, 2011 10:56 pm

To make it easy, compare the home.php on your opencart site with the original opencart.
Had you try to install the theme on new opencart installation?

User avatar
Expert Member

Posts

Joined
Tue Jun 29, 2010 10:24 pm
Location - Indonesia

Post by thegeekz » Mon May 30, 2011 10:21 am

qahar wrote:To make it easy, compare the home.php on your opencart site with the original opencart.
Had you try to install the theme on new opencart installation?

Well I had these themes installed in my production cart only, not anywhere else. but currently its still at 1.4.9.3, abandon the thought of upgrading for now.

So there's no way I can compare at the moment...

Hope I comprehend ur post right?

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by thegeekz » Tue May 31, 2011 12:26 pm

any more help please?

Thank you.

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by thegeekz » Thu Jun 02, 2011 11:49 am

sorry, my bad peeps!!

Just looked through the codes : home.php again, and found the coding that Qahar has indicated.

Since I have the code, I do not know what is wrong with Yoocart's themes that I can't use properly -- as the Latest products module does not turn up and came up with the above errors..

Seeing that version 1.50 is up, maybe I should move over to that, and also see if there are some free themes or cheap themes that I can use for it..

Any further help for these issues with Yoocart?

Thank you.

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am

Post by Hereward » Thu Jul 21, 2011 8:58 pm

Hi

I have version 1.5 of Opencart and I thought that some of the free Yoocart templates for this version looked interesting.

These templates are advertised as free, but you must give a $10 donation and then you have access to download as many as you want although there are only 5 different templates for version 1.5. So really the price for access to these templates is $2 each which is admittedly not a lot. A donation is an option payment so really different language should be used so as not to mislead customers. Anyway I decided I was happy to pay the $10 as some of the templates looked rather good.

I downloaded the templates for this version: "Yoodream_15x_5ha8.rar", "Yooglow_15x_qt03.zip", "Yoolight_15x_fk76.zip", "Yoonery_15x_5h9g.zip" and "Yooseren_15x_th78.zip". However I was very disappointed to notice that these templates did not work at all. I have installed other truly free templates for Opencart 1.5 and they work perfectly, like "Simple Brown" and "Turkish Gray".

Does anyone have any suggestions about how to get these yoocart templates to work? Has anyone else had this problem?

I have contacted the developer and I hope to have a reply soon. It seems to me that given that a fee is charged these templates should work without modification.

Many Thanks!

Newbie

Posts

Joined
Fri Jul 08, 2011 5:19 pm
Location - Oxford, England.

Post by thegeekz » Thu Jul 21, 2011 9:12 pm

FYI, it leaves much to be desired.... AS of writing, I'm still unable to use Yoocart's themes for 1.4.9.4!!!

How would I dare to try their 1.5 versions? :( Much less donate~!

No more using Apsona, as they are not updated.

  • Every upgrade -- rem. 2 reinstall vqmod & mindful of modules w/ VQmod -- E.g Import / Export Tool by MHC


Active Member

Posts

Joined
Tue Nov 02, 2010 10:24 am
Who is online

Users browsing this forum: No registered users and 11 guests