Post by matsp » Sun Jan 16, 2011 7:27 pm

  • OpenCart version 1.4.9.3
    url: withnature.co.uk/shop
Hi. I'm delighted that i've installed and found the features of opencart to be perfect. But i'm quite literally having ajax and css nightmares having tried to integrate it into my css design.
The first problem is that when the page loads it spits back at me an error box quoting Error fetching Ajax content. and then listing the source code of my 404 file. It didn't do this before i tried integrating it.

If anyone has an idea why this might be i'd be very grateful to be pointed in the right direction. Thank you.

PS. And thank you for such an incredible script!

Newbie

Posts

Joined
Sun Jan 16, 2011 7:02 pm

Post by JAY6390 » Sun Jan 16, 2011 8:34 pm

Your page is trying to load the stickybar content apparently, from here
withnature.co.uk/shop/stickybarcontent.htm
Which doesn't exist and throws a 404 error
Image
This is called from the expstickybar.js file, at the bottom

Code: Select all

	externalcontent:'stickybarcontent.htm', //path to sticky bar content file on your server, or "" if content is defined 
Note that this is NOT part of opencart core code, it is due to your theme, and you should contact them to arrange to have it fixed for you. Note that since your js file is outside the "shop" folder, your content for the stickybar may also be. Putting it into the shop folder may solve this

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by matsp » Sun Jan 16, 2011 8:47 pm

Bless you. Thank you so much, I just did what you suggested and that error is gone now. Now for the CSS !!!!!!!!!!! I was starting to give up on integrating this so really thank you!

Newbie

Posts

Joined
Sun Jan 16, 2011 7:02 pm

Post by JAY6390 » Sun Jan 16, 2011 8:49 pm

No problem. What is the CSS issue? I'm no expert on CSS but might be able to help

Image


User avatar
Guru Member

Posts

Joined
Wed May 26, 2010 11:47 pm
Location - United Kingdom

Post by matsp » Sun Jan 16, 2011 9:42 pm

Well i've messed about with it as much as I can but as you'll see I still have overlapping content and horizontal rules where I dont want them. I've pretty much exhausted my CSS knowledge, if you can help that'd be great, thank you.

Newbie

Posts

Joined
Sun Jan 16, 2011 7:02 pm

Post by hbuchel » Sun Jan 16, 2011 11:00 pm

You have a few validation errors in your markup that are going to cause some issues. One that I noticed is you have defined a div with an id of "content" more than once, once around here

Code: Select all

 <div id="line"></div>
    <div id="content">
<div id="container">
and again further down in your code. I would consider changing that first content declaration to be named something else, as it appears the second one is the actual declaration from the default theme that you are modifying.

http://css-tricks.com/the-difference-be ... and-class/ has a great explanation of the difference between id's and classes, and when to use each. If you're going to be taking this on yourself, I would definitely check out some other articles on that site as its a great knowledge base to further your CSS know-how :D

There were several other errors of the same type. Visiting your site, right clicking, selecting View Source, and copying and pasting all of it into http://validator.w3.org/ "Validate by Direct Input" tab will show you all of the errors. Don't get too shocked, the default OpenCart theme ships with a lot errors that look like "Line 197, Column 114: general entity "product_id" not defined and no default entity", which aren't going to effect the layout of your site and which I ignore. But use your browsers find feature to find "already defined" on the list of errors it gives you and you will see the id declarations that you've made more than once.

New member

Posts

Joined
Mon Aug 30, 2010 9:41 pm

Post by matsp » Sun Jan 16, 2011 11:16 pm

Thanks very much for the info hbuchel, i'll read that and make those changes as soon as I can.

Newbie

Posts

Joined
Sun Jan 16, 2011 7:02 pm

Post by Chones » Mon Jan 17, 2011 12:11 am

In your stylesheet you have

Code: Select all

#column_right {
	float: right;
	width: 0px;
	clear: right;
}
#content {
	margin-right: 0px;
	margin-bottom: 10px;
}
Try changing it this:

Code: Select all

#column_right {
display: none;
}
#content {
	margin-right: 0px;
	margin-left: 190px;
	margin-bottom: 10px;
}
Template designers eh? ;)

It also looks like you have too many closing </div> tags - but start with the above.

http://scarletandjones.com/
http://sharpdressedman.co.uk/
http://coffincompany.co.uk/
http://horsesculptures.co.uk/
If I've helped you out, why not buy me a beer? http://craigmurray.me.uk


User avatar
Active Member

Posts

Joined
Wed Mar 24, 2010 9:07 pm
Location - London

Post by matsp » Mon Jan 17, 2011 12:31 am

Hi. Thanks for the suggestion. I changed the right column as suggested but found if i add margin left to the content it moves the entire shop over to the right and hidden under the menu.
Thanks for the suggestion though mate.

Newbie

Posts

Joined
Sun Jan 16, 2011 7:02 pm
Who is online

Users browsing this forum: No registered users and 4 guests