Page 1 of 1

Subcategories Images help

Posted: Wed Nov 24, 2010 2:53 am
by ktutu
When I created subcategories, all of a sudden I had this text show up in lieu of a photo. If I add a photo to the "categories" page in admin, but assign it to the appropriate subcategory heading, I still get this text and the photo appears in the header once you've selected the subcategory page. Can someone please tell me how to fix this? Here is a screenshot to reflect my problem, and the website address is http://www.thetutuplace.com

Re: Subcategories Images help

Posted: Wed Nov 24, 2010 5:03 am
by Meeker
Unlikely answer, but is it possible the image is not where it says it is? I.e. the image is actually there.

Re: Subcategories Images help

Posted: Wed Nov 24, 2010 5:48 am
by SteveSherry
It looks to be an HTML error, rather than a missing image problem.

Is this a new theme? maybe you'd ask the theme creator?


Steve...

Re: Subcategories Images help

Posted: Wed Nov 24, 2010 11:03 am
by ktutu
I did not purchase this theme; I simply modified the default OC 1.4.9.1 theme. I actually have not assigned any images to these sections, which is why I'm confused as to why there is anything there at all. If I do assign a picture to one of the subcategories, it still shows the text on the parent category (as pictured), and the picture selected shows up in the heading of the appropriate subcategory page. The screen shot shows what it looks like when you click on "headbands" (the parent category). I simply wish to get rid of the text, no pictures needed.

Re: Subcategories Images help

Posted: Wed Nov 24, 2010 11:27 am
by Johnathan
Looks like you're missing the beginning of the <img> tag in the .tpl file.

Re: Subcategories Images help

Posted: Wed Nov 24, 2010 11:52 am
by ktutu
Johnathan wrote:Looks like you're missing the beginning of the <img> tag in the .tpl file.
I really don't know web design so everything I've done to the site has been from reading the forums. If you could tell me which .tpl file you're talking about, I'd really appreciate it.

Re: Subcategories Images help

Posted: Wed Nov 24, 2010 12:38 pm
by Johnathan
If you're viewing the categories page, the template file is /catalog/view/theme/YOURTHEME/template/product/category.tpl

Re: Subcategories Images help

Posted: Thu Nov 25, 2010 1:41 pm
by ktutu
Johnathan, thank you for your response. I checked that file (and any other .tpl files I could find), but could not find the text shown on the website. Could someone please tell me, should I be looking for those exact lines ("" title="Crochet Headbands" alt="Crochet Headbands" style="margin-bottom: 3px;" />), or is it something else?

Re: Subcategories Images help

Posted: Thu Nov 25, 2010 1:48 pm
by Johnathan
You should be looking for:

Code: Select all

<img src="<?php echo $categories[$j]['thumb']; ?>"
You're likely missing that particular <img> tag. That whole line should look something like this:

Code: Select all

<a href="<?php echo $categories[$j]['href']; ?>"><img src="<?php echo $categories[$j]['thumb']; ?>" title="<?php echo $categories[$j]['name']; ?>" alt="<?php echo $categories[$j]['name']; ?>" style="margin-bottom: 3px;" /></a><br />

Re: Subcategories Images help

Posted: Thu Nov 25, 2010 2:22 pm
by ktutu
Thanks, again, for your response, Johnathan. I found the lines you referred to, and inserted the missing text, but I'm still experiencing the error.