Post by rog_ashbury » Tue Jun 08, 2010 11:19 pm

Don't know whether anyone can help with this. I've set up my site over the past few weeks exactly as I want running 1.4.7 in Soft Grey. However today I set up a coupon and did an order on behalf of a customer only to find that at no time did the coupon show up in the check out process.

I changed back to the default template and the coupon worked fine so it appears to be a problem in the Soft_Grey template.

Can anyone help with finding out why coupons don't work in Soft_Grey?

Thanks in advance for any ideas.

Roger

New member

Posts

Joined
Mon Nov 02, 2009 6:56 am

Post by badgerandhone » Fri Jul 02, 2010 7:18 am

I also would love an answer to this problem if anyone's got one?

I'm guessing its just a piece of code that the developer of the 'Soft Grey' template has left out causing the coupon section to vanish.

Cheers

Newbie

Posts

Joined
Thu Jul 01, 2010 2:46 am

Post by rog_ashbury » Fri Jul 02, 2010 3:28 pm

Coupons do not work in several of the older templates with 1.4.8 the reason being that there are whole new bits in the 1.4.8 stylesheet that are not in the earlier ones.However, if you notice the layout of soft grey is the same as default so it's merely a matter of swapping over images from soft grey into the 1.4.8 default and then editing the default stylesheet to add in the soft grey background image and change the colours of fonts, things like that. That way you'll make your own new grey template.

If you open the 1.4.8 default stylesheet for editing in wordpad say and then open the original soft-grey in wordpad next to it you'll soon see where the differences are between the two templates. Just remember that you want to keep the new default template and layout but make it look like soft grey, not the other way round! It'll only take you an hour or so but every time you change something keep a copy of what you've just modified so you can go back to it if necessary. You can't do any damage and you won't lose anything and you'll also learn a lot in the process.

It's not that difficult. I'd let you have a copy of mine but I've done so many other little hacks that are specific to my business that it would take me too long now to revert my template back to the basic grey one that I made by doing the above.

Hope that helps

Roger

New member

Posts

Joined
Mon Nov 02, 2009 6:56 am

Post by i2Paq » Sat Jul 03, 2010 12:29 am

You can contact the creator here: opencart-design.
hazymat wrote:I have just finished updating all of my templates to 1.4.8, so I know what's where. If you need any specific help give me a shout.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands
Who is online

Users browsing this forum: No registered users and 7 guests