Post by jwreid » Fri May 23, 2014 4:37 am

If I am using a theme other than default and I install an extension that includes (catalog/view/theme/default/template/etc.) Do I have to change the theme/default/ to theme/my theme before install in order for the extension to work properly?

User avatar
Active Member

Posts

Joined
Sun Oct 27, 2013 6:27 pm
Location - Canada

Post by Xyph3r » Fri May 23, 2014 6:16 am

You installed an extension that has a VQMod file. In this case you should change the "default" word in that xml file to "*"
It should look like this:

Code: Select all

catalog/view/theme/*/template/etc
Even if you do this modification, you can stiil have problems with custom themes if the theme doesn't follow the default coding. In this case, you should alter the vqmod file to find the exact lines in your custom template.

ImageImageImage
Opencart Templates, Modules, Themes & Custom Development | ShopThemer


User avatar
Active Member

Posts

Joined
Sun Feb 10, 2013 1:08 am


Post by jwreid » Fri May 23, 2014 6:37 am

The xml files come like that to begin with, I did not have to make any mods. What I would like to know is, do I have to change the name of the default theme folder in the extension to the name of the theme I am currently using.

User avatar
Active Member

Posts

Joined
Sun Oct 27, 2013 6:27 pm
Location - Canada

Post by labeshops » Fri May 23, 2014 6:48 am

If you change it to the wildcard * as suggested, the mod would be applied to any and all themes you have installed.

Running Opencart v2.2 with multi-stores from http://www.labeshops.com which has links to all my stores.

Image


User avatar
Expert Member

Posts

Joined
Thu Aug 04, 2011 4:41 am
Location - Florida, USA

Post by jwreid » Fri May 23, 2014 6:51 am

Thanks, now its clear to me.

User avatar
Active Member

Posts

Joined
Sun Oct 27, 2013 6:27 pm
Location - Canada
Who is online

Users browsing this forum: No registered users and 5 guests