Page 1 of 1

Left & Right Column Fails to Load on Custom Page

Posted: Fri Feb 28, 2014 5:58 pm
by corneliusrodes
Hi - I have created a custom 'information' page and the left and right column boxes are not appearing when I load the pages in a browser. I have created the relevant tpl (template) and php (controller and language) files in the relevant information folders but the right and left column boxes are not loading. I have checked the relevant echo statements for the left and right columns are there on the tpl file but still no joy. Beginning to lose the will to live :laugh: Anyone out there with any ideas. Bear in mind I am not a coder by profession. Thanks in advance.

Re: Left & Right Column Fails to Load on Custom Page

Posted: Fri Feb 28, 2014 10:17 pm
by ocaddons
Hi,

What's the url address of your live store? Let me have a look. It should be due to the fatal error existing in your custom page which result in the content of left and right column are failed to be added into the information page. It means the script exit before generating the left and right column.

It would be better to let me access your ftp account to test it and confirm the reason of the problem.

Re: Left & Right Column Fails to Load on Custom Page

Posted: Sat Mar 01, 2014 3:25 am
by corneliusrodes
Hi ocaddons

Not a live site at present. Still stored locally, but thanks for the offer ;D

Re: Left & Right Column Fails to Load on Custom Page

Posted: Sat Mar 01, 2014 4:23 am
by corneliusrodes
I think I might have worked this out but don't understand why this happens. I have gone into the admin panel and added the 'default' layout to the Information module and selected it to appear in left column. The Information box now appears in the left column.

Anyone have any ideas why I need the 'default' layout included for a custom information page? :crazy:

Re: Left & Right Column Fails to Load on Custom Page

Posted: Sat Mar 01, 2014 10:32 pm
by ocaddons
Hi,

Could you send me the custom file for the information page? In this case, i could put it into my local opencart system and find the reason of the problem for you.

Re: Left & Right Column Fails to Load on Custom Page

Posted: Sun Mar 02, 2014 11:20 am
by MarketInSG
If you had created the custom page, ensure you have added the layout to your system in system > design > layouts.