Post by Joe1234 » Wed Jan 19, 2022 2:56 pm

I have a very weird issue where I cannot upload two particular images to my product. It doesn't matter if I resize it, if I try to upload it to a different product, it simply won't take as a product image. I hit save, I get the message that everything saves, when I go back in or to the product page I don't see the image. When I try to upload a different image to that particular product, or any other product I have no issue. A regular JPG. Has anyone ever had this issue. Has anyone ever experienced this?

Thanks

Using the latest version.
Attached is the image...I don't know if that even matters because I see that the image was resized uploading it here.

Attachments

Cat_&_Jack-Grey-Sleeper-Looks_New_A0000087-A_2.JPG

Cat_&_Jack-Grey-Sleeper-Looks_New_A0000087-A_2.JPG (87.6 KiB) Viewed 277 times

Cat_&_Jack-Grey-Sleeper-Looks_New_A0000087-A.JPG

Cat_&_Jack-Grey-Sleeper-Looks_New_A0000087-A.JPG (91.06 KiB) Viewed 277 times


v3.0.3.8
I'm here for a reason, if your response is contact a/the developer, just don't reply.


Active Member

Posts

Joined
Sat Jan 01, 2022 5:47 am

Post by OSWorX » Wed Jan 19, 2022 3:54 pm

General you should not name images with special characters (and also no spaces, Umlauts, etc.).
The & is one of them!
Have you tried it without it?

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by thekrotek » Wed Jan 19, 2022 4:41 pm

I second this. Never use special characters in file names, otherwise issues may happen.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by paulfeakins » Wed Jan 19, 2022 8:57 pm

Yep, pretty sure the & will be the problem here as others have said.

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Guru Member
Online

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by Joe1234 » Thu Jan 20, 2022 12:23 am

Thanks, this worked, but it makes no sense. I have multiple images on other products with the same type of naming and also apostrophes that have absolutely no issues.

Secondary question, while trying to figure this out I noticed in my file manager under my host "JPG" was listed as a text type, and "jpg" was listed as an image type. Will that be an issue?

v3.0.3.8
I'm here for a reason, if your response is contact a/the developer, just don't reply.


Active Member

Posts

Joined
Sat Jan 01, 2022 5:47 am

Post by JNeuhoff » Thu Jan 20, 2022 5:59 pm

Joe1234 wrote:
Thu Jan 20, 2022 12:23 am
Thanks, this worked, but it makes no sense. I have multiple images on other products with the same type of naming and also apostrophes that have absolutely no issues.

Secondary question, while trying to figure this out I noticed in my file manager under my host "JPG" was listed as a text type, and "jpg" was listed as an image type. Will that be an issue?
You are most likely dealing here with a Linux server using a case-sensitive file system. This means that '.JPG' and '.jpg' isn't the same.

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by OSWorX » Thu Jan 20, 2022 6:19 pm

Joe1234 wrote:
Thu Jan 20, 2022 12:23 am
Thanks, this worked, but it makes no sense. I have multiple images on other products with the same type of naming and also apostrophes that have absolutely no issues.

Secondary question, while trying to figure this out I noticed in my file manager under my host "JPG" was listed as a text type, and "jpg" was listed as an image type. Will that be an issue?
1. it makes sence - several reasons (best would be to use your preferred search engine and look why)
2. a LINUX system is NOT a WINDOWS system
> under Win you can have UPPER and lower letters = does not make any difference
> under *NIX theres is a big difference between UPPER and lower letters
3. text and image type is NOT the same

Guess you have to learn more about the system you are using.
Operating a website is not only creating something, it's also your duty to know what you are doing AND why!

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 9 guests