Post by myt » Wed Jan 19, 2022 10:30 am

Hello all,

I have recently switched away from using an exim mail server to having Outlook host my business email due to security reasons. As such, I disabled php mail on my server and turned off the exim service through cPanel/whm. I also updated my OC store settings under the mail tab to use SMTP with the following settings:

Mail Engine: SMTP
SMTP Hostname: tls://smtp-mail.outlook.com
SMTP Username: <my email>
SMTP Password: <my password>
SMTP Port: 587
SMTP Timeout: 5

I know the credentials are correct, I have verified I can log in with those exact credentials. I got the smtp hostname and port from here: https://support.microsoft.com/en-us/off ... 414e2aa040

However, whenever I try to test this configuration by sending a message through the Contact Us page, the spinner keeps spinning, and under the network tools in firefox I can see the response is: "Error: Password not accepted from server!"

I spent some time poking around in the SMTP code, and I can see that its getting past all checks up to that point, but for some reason submitting the password results in no response (string length of response is 0). I thought maybe my SMTP hostname was wrong, so I tried it without the tls (which results in an EHLO error), and also tried smtp.office365.com (with/without tls) and I'm having pretty much the same problem. I also disabled that setting in cPanel/WHM that limits SMTP to the root account so that all accounts can send SMTP messages.

Does anyone know what the issue could be here?

OC Version: 3.0.3.6
Theme: Journal 3
PHP Version: 7.3

myt
Newbie

Posts

Joined
Sun Jan 01, 2017 10:19 am

Post by thekrotek » Wed Jan 19, 2022 4:14 pm

As far as I remember, there's an issue with Outlook SMTP in OpenCart. Check the Marketplace for a free modification, it should be there.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by ADD Creative » Wed Jan 19, 2022 6:06 pm

Double check your username and password for white space and special characters. Try increasing your timeout.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by myt » Thu Jan 20, 2022 2:27 am

I can't seem to find the modification you are talking about krotek - I have searched for outlook, hotmail, smtp, and combinations of those, but no results that actually say they address that issue.

As for the timeout, I have doubled and tripled it and still the same result. I verified there is no whitespace and no special characters in my smtp username (email) and smtp password.

The weird thing to me is that there is no reply at all when submitting the password - what would cause that?

myt
Newbie

Posts

Joined
Sun Jan 01, 2017 10:19 am

Post by thekrotek » Thu Jan 20, 2022 2:38 am

myt wrote:
Thu Jan 20, 2022 2:27 am
I can't seem to find the modification you are talking about krotek - I have searched for outlook, hotmail, smtp, and combinations of those, but no results that actually say they address that issue.
It is called "Office365" nowadays.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am

Who is online

Users browsing this forum: No registered users and 13 guests