Post by RoyT » Mon Jan 03, 2022 7:22 pm

Hi

A new install of Ver 3.0.3.8 and all of my test emails from the cart are encypted.

The name text I used is till in plain text, see attached image from my email software.

Any ideas please ?

Thanks

Attachments

Screenshot 2022-01-03 112036.png

Screenshot 2022-01-03 112036.png (23.94 KiB) Viewed 732 times


Newbie

Posts

Joined
Sat Mar 04, 2017 7:48 pm

User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by joclip » Thu Jan 20, 2022 11:26 am

I have same issue, have you resolved since ?

Newbie

Posts

Joined
Tue Jan 18, 2022 2:12 am
Location - Montreal, Quebec, CANADA

Post by joclip » Sat Jan 29, 2022 12:49 am

Have you resolved your encoded email issue yet ?

Newbie

Posts

Joined
Tue Jan 18, 2022 2:12 am
Location - Montreal, Quebec, CANADA

Post by by mona » Sat Jan 29, 2022 1:55 am

and now you see why it is etiquette to return and write [SOLVED] to the title post.

If you indeed have the same issue then one can presume the answer is correct also. Whilst the user did not come back to say thank you, users usually come back when their issue is not resolved.
xxvirusxx wrote:
Mon Jan 03, 2022 9:30 pm
Replace with this 3.0.3.8 version
https://github.com/opencart/opencart/tr ... aintenance
If this solution does work for you, would you be so kind as to assist the community to come back to confirm it.
Thank you

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Expert Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by Nixvdv » Sun Feb 13, 2022 2:46 am

It did not work! I have reinstalled it with the installation on the link and still getting encrypted email messages. Please help. ???

Newbie

Posts

Joined
Fri Feb 11, 2022 12:08 am

Post by OSWorX » Sun Feb 13, 2022 1:54 pm

Nixvdv wrote:
Sun Feb 13, 2022 2:46 am
It did not work! I have reinstalled it with the installation on the link and still getting encrypted email messages. Please help. ???
Basically you do not receive "encrypted" emails, instead some of the header lines are in the subject!
Which php-version are you using?

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by by mona » Mon Feb 14, 2022 8:26 am

It might help to post the original mail content, not just what you see, not sure what client you have but most have a function to look at the actual mail message content. In gmail it is called "show original”.

In addition and to what has been written above would be handy if you would state your server details, php version, mail class etc. rather than “not working” - a rather unhelpful statement.

Using PHP mail, i.e. the mail server (which I assume you are using) on your host can be a tricky thing, always use the smtp class unless there is no possibility to do so.
I would suggest you check what your system defines as PHP_EOL and what your host mail server expects it to be.

What I believe OSWorkX is referring to is some MTAs get a little confused with how PHP_EOL characters are handled, \r\n or \n or \r, end-of-line characters need to be correct. Some old MTAs try to correct \n by replacing them with \r\n without checking if it actually already was a \r\n resulting in a \r\r\n and some clients then have a problem with the headers resulting in the headers becoming part of the message.

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Expert Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by OSWorX » Tue Feb 15, 2022 1:39 pm

by mona wrote:
Mon Feb 14, 2022 8:26 am
Using PHP mail, i.e. the mail server (which I assume you are using) on your host can be a tricky thing, always use the smtp class unless there is no possibility to do so.
I would suggest you check what your system defines as PHP_EOL and what your host mail server expects it to be.

What I believe OSWorkX is referring to is some MTAs get a little confused with how PHP_EOL characters are handled, \r\n or \n or \r, end-of-line characters need to be correct. Some old MTAs try to correct \n by replacing them with \r\n without checking if it actually already was a \r\n resulting in a \r\r\n and some clients then have a problem with the headers resulting in the headers becoming part of the message.
First of all, yes.
Second, why the hell are people still using the native php mail function instead SMTP?
Many good reasons doing so and described in many threads in this forum (and somewhere else)!

Third: reading the following may bring some light into:
https://github.com/opencart/opencart/is ... s%3Aclosed

And finally - fourth: better to hire a qualified developers then wasting time.

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria
Who is online

Users browsing this forum: No registered users and 17 guests