Post by coolrix » Wed Mar 24, 2021 9:55 pm

Waw, thank you for you explanation. I'm a newbie and I will check all your points and update my fakeshop.
Somebody an idea about the checkout problem?

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by OSWorX » Wed Mar 24, 2021 9:59 pm

coolrix wrote:
Wed Mar 24, 2021 9:55 pm
Waw, thank you for you explanation. I'm a newbie and I will check all your points and update my fakeshop.
Somebody an idea about the checkout problem?
Even a "newbie" has the duty to inform himself about legal requirements and other regulations - before he/she/it starts in this business!
You are responsible for a qualified, working and - much important - safe Webshop.
And I gave you only a few points of many more ..

Checkout problem: everything said/written.
Better hire some professional.

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by coolrix » Thu Mar 25, 2021 5:44 pm

I downloaded the complete project on my pc. If I run the project on my pc, checkout works fine.
(ps: started to work on all the other remarks I've got)

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by ADD Creative » Thu Mar 25, 2021 6:49 pm

Probably no the cause of your issue, but not all your site is using https. Check all the store URLs in config.php and admin/config.php start with https. Do you have any redirects set up in your htaccess? Search these forums for post on how to set your store to use https correctly.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by coolrix » Thu Mar 25, 2021 8:44 pm

Will check that, thanks.
I see now that if i change the link to https://shop.procollecta.com/index.php?route=/checkout/cart it works fine(extra slash).

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by straightlight » Thu Mar 25, 2021 8:58 pm

.htaccess issues.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by k2tec » Thu Mar 25, 2021 9:09 pm

I think there is standing in your checkout one / too much . Maybe in your template

User avatar
Active Member

Posts

Joined
Mon Apr 12, 2010 8:06 pm

Post by coolrix » Thu Mar 25, 2021 11:06 pm

My .htaccess:

Options +FollowSymlinks
RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://shop.procollecta.com/$1 [R=301,L]

# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "(?i)((\.tpl|.twig|\.ini|\.log|(?<!robots)\.txt))">
Require all denied
## For apache 2.2 and older, replace "Require all denied" with these two lines :
# Order deny,allow
# Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=extension/feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=extension/feed/google_base [L]
RewriteRule ^system/storage/(.*) index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by mikeinterserv » Thu Mar 25, 2021 11:17 pm

coolrix wrote:
Thu Mar 25, 2021 11:06 pm
My .htaccess:
change

Code: Select all

RewriteEngine On
RewriteCond %{SERVER_PORT} 80
RewriteRule ^(.*)$ https://shop.procollecta.com/$1 [R=301,L]
to

Code: Select all

RewriteCond %{HTTPS} off
RewriteRule ^(.*)$ https://shop.procollecta.com%{REQUEST_URI} [L,R=301]
RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
RewriteRule ^ https://%1%{REQUEST_URI} [R=301,L]

Active Member

Posts

Joined
Thu May 28, 2020 6:55 am
Location - Wales

Post by coolrix » Thu Mar 25, 2021 11:49 pm

Thank you.
After the change, i get this error: Parse error: syntax error, unexpected '|', expecting ',' or ';' in /home/procollecta/shop.procollecta.com/system/library/vendor/facebook/php-business-sdk/src/FacebookAds/CrashReporter.php on line 47

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by mikeinterserv » Thu Mar 25, 2021 11:55 pm

Well that is the facebook extension
You have a shop on www. and shop.
Which one is your store

Active Member

Posts

Joined
Thu May 28, 2020 6:55 am
Location - Wales

Post by coolrix » Fri Mar 26, 2021 12:10 am

shop.procollecta.com

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by mikeinterserv » Fri Mar 26, 2021 12:12 am

Your shop is working fine on front end

Active Member

Posts

Joined
Thu May 28, 2020 6:55 am
Location - Wales

Post by coolrix » Fri Mar 26, 2021 12:17 am

I disabled the facebook module, but still the same

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by mikeinterserv » Fri Mar 26, 2021 12:18 am

So where are you seeing this problem
Refresh cache and modifications after disabling extension

Active Member

Posts

Joined
Thu May 28, 2020 6:55 am
Location - Wales

Post by coolrix » Fri Mar 26, 2021 12:18 am

I mean checkout still doesn't work

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by mikeinterserv » Fri Mar 26, 2021 12:22 am

So this is your problem

Parse error: syntax error, unexpected '.' in /home/procollecta/shop.procollecta.com/catalog/controller/payment/mollie-api-client/vendor/autoload.php on line 11

Disable that useless payment method and test with bank transfer or COD

Active Member

Posts

Joined
Thu May 28, 2020 6:55 am
Location - Wales

Post by coolrix » Fri Mar 26, 2021 12:24 am

Oeps, forgot to clear the cash, sorry. Now it works.

Thanks to everybody of the opencart community. I learnt a lot

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm

Post by straightlight » Fri Mar 26, 2021 12:27 am

Now that the issue has been solved due to .htaccess issues, please add [SOLVED] at the beginning of the subject line on your first post.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by coolrix » Fri Mar 26, 2021 12:36 am

done

New member

Posts

Joined
Fri Jul 17, 2020 5:58 pm
Who is online

Users browsing this forum: No registered users and 26 guests