Page 1 of 1

[SOLVED] - New Products Missing from Category

Posted: Fri Mar 13, 2020 3:14 am
by head_dunce
I'm not running a basic install of OC, so I know this might not be an easy answer from this forum. I just figured I'd ask, maybe someone had a tip?
I'm adding new products via an API call, and although the product is added to the site, it doesn't appear in the category it was assigned.
For example, here is a new product -
https://www.carguygarage.com/storage/ca ... nets-77475
But if you look in the category, it's not listed -
https://www.carguygarage.com/storage/ca ... f-cabinets
I've cleared OC caches. Rebuilt the categories. Cleared OPCache. Still nothing?

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 3:29 am
by sw!tch
Edit: never mind, wrong product.

Check the product and category tables. Must be missing something.

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 3:33 am
by head_dunce
sw!tch wrote:
Fri Mar 13, 2020 3:29 am
Looks to be showing on my end. You fix it?
No, weird, not showing on my end...

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 3:37 am
by head_dunce
You sure you're seeing that product listed in the category? (Not just the image in the side gallery) -- I've tried a few browsers, incognito, etc, nothing showing here.

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 3:39 am
by sw!tch
Sorry had the wrong product. Shows up in search though. For model 77475. Whats weird is the breadcrumb is showing the category, must be something missing in the database..

Check date_available is in the past. and language is set.

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 3:45 am
by head_dunce
Yeah, I'm poking around in the DB now. In the admin side of OC it shows being in the category correctly. I also know from trying on another product that if I hit save in the admin side of OC it will show up.

Just tried clearing the SQL cache, no help.

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 3:58 am
by sw!tch
Check your cache folder . Since this is Journal hard to tell, but maybe products or categories are being cached. When you hit save in the admin it might flush that cache.

Otherwise look at the catalog model for categories and see what's being requested in the select statement.

Re: New Products Missing from Category

Posted: Fri Mar 13, 2020 4:56 am
by head_dunce
AH! Figured it out, had to do with an extension for sorting categories. It was missing en entry in the db for the new product. Thanks for the help