Post by waynec444 » Sun Oct 20, 2019 1:27 am

I will ship (flat rate) to U.S. addresses only. Flat rate shipping is showing as available in other countries (at the U.S. rate). I will NOT ship flat-rate outside of the U.S.

New member

Posts

Joined
Sun Oct 06, 2019 11:53 pm

Post by Johnathan » Sun Oct 20, 2019 8:16 am

1. Set up a Geo Zone for the United States (All Zones) in System > Localisation > Geo Zones

2. Set the "Flat Rate" shipping method to only be available for that geo zone, in Extensions > Shipping > Flat Rate

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by waynec444 » Tue Oct 22, 2019 12:17 am

In both sections I only have an option for UK zones. The U.S. is not shown (nor is any other country).

New member

Posts

Joined
Sun Oct 06, 2019 11:53 pm

Post by Johnathan » Tue Oct 22, 2019 3:47 am

Someone may have deleted all your countries then. Check whether they exist and are enabled in System > Localisation > Countries. If the only country in there is the UK, you'll need to re-add the United States and all its zones. You'll probably need to do that in the database since it would take a long time to do it manually --- if you're not familiar with MySQL, you should hire someone to do this for you (or ask whoever deleted them in the first place, if you know).

If you need to find a developer, you can post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by waynec444 » Tue Oct 22, 2019 5:21 am

No one deleted all the countries. IF that had been done the UK and the UK VAT ones would have been deleted too. They were never there.

Cannot spend any money to fix this. All I have ever seen is the UK ones. Figured this was a UK cart.

New member

Posts

Joined
Sun Oct 06, 2019 11:53 pm

Post by Johnathan » Tue Oct 22, 2019 10:16 pm

Did you follow my step #1 then? If you haven't deleted any countries, you should be able to create a Geo Zone for the United States. It's in System > Localisation > Geo Zones. If you still can't figure out how to do that, post some screenshots of what you're seeing, because setting up Geo Zones is one of the most basic things you should learn how to do in OpenCart.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by waynec444 » Wed Oct 23, 2019 5:26 am

My sincere apologies. I did NOT do your number 1. I wrongly assumed that the U.S. would already be there.

I now have added United States (All Zones) and then set the flat rate for that GeoZone only.

Thanks for pointing out MY not doing what you said to do.

New member

Posts

Joined
Sun Oct 06, 2019 11:53 pm

Post by Johnathan » Wed Oct 23, 2019 10:39 pm

Glad I could help

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am

Who is online

Users browsing this forum: paulfeakins and 39 guests