Page 1 of 1

Twig PHP Version requirements

Posted: Thu Oct 10, 2019 11:46 pm
by jmoncrieff
Hi,
I'm currently looking into possibly upgrading our 2.0.1.1 to the latest version 3.0.3.2
I've a lot of concerns about breaking the theme ( was custom built I believe - i've inherited maintenance of this site)

I'm comfortable with html and css, but know very little php. I've been looking at how to edit twig template files.
However, on the twig documentation, it states that 'Twig needs at least php 7.0.0 to run'
On my test install of the new shop, the min php requirement was for PHP 5.4 or higher - I have 5.6

Am i going to need php7 to rebuild the theme?
Or do .tpl files still work (as long as the .tpl and .twig aren't mixed - think I remember reading this somewhere)

Scared to progress with the update if I break our shop and can't repair it ???

Re: Twig PHP Version requirements

Posted: Fri Oct 11, 2019 3:05 pm
by rjcalifornia
jmoncrieff wrote:
Thu Oct 10, 2019 11:46 pm
Hi,
I'm currently looking into possibly upgrading our 2.0.1.1 to the latest version 3.0.3.2
I've a lot of concerns about breaking the theme ( was custom built I believe - i've inherited maintenance of this site)

I'm comfortable with html and css, but know very little php. I've been looking at how to edit twig template files.
However, on the twig documentation, it states that 'Twig needs at least php 7.0.0 to run'
On my test install of the new shop, the min php requirement was for PHP 5.4 or higher - I have 5.6

Am i going to need php7 to rebuild the theme?
Or do .tpl files still work (as long as the .tpl and .twig aren't mixed - think I remember reading this somewhere)

Scared to progress with the update if I break our shop and can't repair it ???
You will have to upgrade/rebuild the theme:

https://github.com/opencart/opencart/wi ... 2.3-to-3.0

I suggest you to work on a local version of the store.

Re: Twig PHP Version requirements

Posted: Fri Oct 11, 2019 4:44 pm
by paulfeakins
rjcalifornia wrote:
Fri Oct 11, 2019 3:05 pm
You will have to upgrade/rebuild the theme
Unfortunately I think this will be the case too.

Re: Twig PHP Version requirements

Posted: Fri Oct 11, 2019 4:50 pm
by jmoncrieff
Thanks for the answers guys - thought that might be the case
...off to learn PHP twig I guess :(