Page 1 of 1

Paypal stopped working, returns token instead of paypal login window

Posted: Thu Oct 10, 2019 12:21 pm
by JDHayesBC
When I go to check out, rather than getting the typical paypal login window, what I'm seeing is a window with a white background and this one line:

{"token":"XX-XXXXXXXXXXXXXXXX"}

(where the XX's represent a random string of characters).

Anyone have any clues?

Re: Paypal stopped working, returns token instead of paypal login window

Posted: Thu Oct 10, 2019 5:26 pm
by paulfeakins
JDHayesBC wrote:
Thu Oct 10, 2019 12:21 pm
Anyone have any clues?
No we have no clues because you haven't given us any such as:

- OpenCart version
- Theme Name
- Extensions
- Any custom work
- A link to the site
- The latest errors in the logs

Re: Paypal stopped working, returns token instead of paypal login window

Posted: Thu Oct 10, 2019 11:56 pm
by JDHayesBC
Problem payment method: Paypal Express. Last night I installed PayPal standard which is working fine and got the site up and running again.

OpenCart Version: 3.0.3.2
Theme Name: Whatever the built-in Theme is
Extensions: currencyupdatev3x.ocmod.zip
OC3-facebook-opengraph-tags.ocmod.zip
livesearch3.ocmod.zip
modificationmanager-3.1.1.ocmod.zip
squareup.ocmod.zip
Link to site: shop.vgha.ca -- NOTE: Paypal express is currently disabled.
Custom Work: None
Log Errors: I cleared the log, re-enabled PayPal Express, and tried to do a transaction. This is what the log shows:

Code: Select all

2019-10-10 15:53:24 - PayPal Express debug (Call data): {"METHOD":"SetExpressCheckout","MAXAMT":10.5,"RETURNURL":"https:\/\/shop.vgha.ca\/index.php?route=extension\/payment\/pp_express\/checkoutReturn","CANCELURL":"https:\/\/shop.vgha.ca\/index.php?route=checkout\/checkout","REQCONFIRMSHIPPING":0,"NOSHIPPING":0,"LANDINGPAGE":"Login","LOGOIMG":null,"CHANNELTYPE":"Merchant","PAYMENTREQUEST_0_SHIPTONAME":"xxxxxx xxxxxx","PAYMENTREQUEST_0_SHIPTOSTREET":"xxx xxxxxx xx","PAYMENTREQUEST_0_SHIPTOSTREET2":"","PAYMENTREQUEST_0_SHIPTOCITY":"xxxxx","PAYMENTREQUEST_0_SHIPTOSTATE":"xx","PAYMENTREQUEST_0_SHIPTOZIP":"xxx xxx","PAYMENTREQUEST_0_SHIPTOCOUNTRYCODE":"CA","ADDROVERRIDE":1,"PAYMENTREQUEST_0_SHIPPINGAMT":"","PAYMENTREQUEST_0_CURRENCYCODE":"CAD","PAYMENTREQUEST_0_PAYMENTACTION":"Sale","L_PAYMENTREQUEST_0_DESC0":"","L_PAYMENTREQUEST_0_NAME0":"Basic Potted Poinsettia - 4", Red","L_PAYMENTREQUEST_0_NUMBER0":"P4P-2018-4-RED","L_PAYMENTREQUEST_0_AMT0":7,"L_PAYMENTREQUEST_0_QTY0":"1","L_PAYMENTREQUEST_0_ITEMURL0":"http:\/\/shop.vgha.ca\/index.php?route=product\/product&product_id=54","L_PAYMENTREQUEST_0_ITEMLENGTHVALUE0":"5.00000000","L_PAYMENTREQUEST_0_ITEMLENGTHUNIT0":"in","L_PAYMENTREQUEST_0_ITEMWIDTHVALUE0":"5.00000000","L_PAYMENTREQUEST_0_ITEMWIDTHUNIT0":"in","L_PAYMENTREQUEST_0_ITEMHEIGHTVALUE0":"5.00000000","L_PAYMENTREQUEST_0_ITEMHEIGHTUNIT0":"in","PAYMENTREQUEST_0_ITEMAMT":"7.00","PAYMENTREQUEST_0_AMT":"7.00"}
2019-10-10 15:53:25 - PayPal Express debug (Result): "TOKEN=EC%2d5SX76125SN919862V&TIMESTAMP=2019%2d10%2d10T15%3a53%3a25Z&CORRELATIONID=f684f5c4c325f&ACK=Success&VERSION=109%2e0&BUILD=53717468"

Re: Paypal stopped working, returns token instead of paypal login window

Posted: Fri Oct 11, 2019 4:41 pm
by paulfeakins
Good info, thanks.

I can't immediately see what's wrong but someone more familiar with this gateway may be able to from that ...