Post by prototype0104 » Mon Sep 30, 2019 11:05 pm

Hello! I'd like to know if someone has this problem with journal 3 theme: No discount code input in cart page ( I can't use discount code )
In Journal options, Coupon visibility is checked and in twig file I have:

Code: Select all

{% for voucher in vouchers %}
                <tr>
                  <td></td>
                  <td class="text-left td-voucher">{{ voucher.description }}</td>
                  <td class="text-left td-voucher"></td>
                  <td class="text-left td-voucher"><div class="input-group btn-block" style="max-width: 200px;">
                      <input type="text" name="" value="1" size="1" disabled="disabled" class="form-control" />
                      <span class="input-group-btn">
                  <button type="button" data-toggle="tooltip" title="{{ button_remove }}" class="btn btn-danger" onclick="voucher.remove('{{ voucher.key }}');"><i class="fa fa-times-circle"></i></button>
                  </span></div></td>
                  <td class="text-right td-voucher">{{ voucher.amount }}</td>
                  <td class="text-right td-voucher">{{ voucher.amount }}</td>
                </tr>
              {% endfor %}
Anyone had this problem? Thank you!

New member

Posts

Joined
Sun Mar 24, 2019 6:08 pm

Post by thekrotek » Mon Sep 30, 2019 11:16 pm

Contact Journal support on the matter.

Professional OpenCart extensions, support and custom work.
Contact me via email or Skype by support@thekrotek.com


User avatar
Expert Member

Posts

Joined
Sun Jul 03, 2016 12:24 am


Post by prototype0104 » Thu Oct 03, 2019 10:20 pm

Hi! I contacted them but they said that is about OpenCart default theme.. I'm using OpenCart default cart / checkout.. In my cart, is not appearing discount code form.

EDIT: In Journal options I have:
Coupon
Estimate delivery
Gift Certificate
When Coupon is active in cart page appear Estimate Delivery Cost, when is inactive it dissappear
If I'm editing the other two ( estimate and gift certificate status ) nothing changes in cart page. It's strange..

New member

Posts

Joined
Sun Mar 24, 2019 6:08 pm

Post by by mona » Thu Oct 03, 2019 11:42 pm

I am sorry you are having problems with Journal.
If you have settings in Journal then this must effect your cart somehow.

Turn off Journal theme and check on default theme. Maybe you have another extension that is causing the problem?
I have checked on default and it works as it should. Attached.

Please ask Journal to explain how they concluded this is Opencart default , are they suggesting they sell add-on products knowing it can not work because the original product does not work in the first place?

Attachments

Screen-Shot-2019-10-03a.png

Screen-Shot-2019-10-03a.png (36.88 KiB) Viewed 221 times

Screen-Shot-2019-10-03b.png

Screen-Shot-2019-10-03b.png (35.56 KiB) Viewed 221 times


DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by talalismail » Fri Apr 03, 2020 6:12 am

Hi,
Actually i have almost the same problem as i understand.
i created for example (New2020) for 10% discount, i recive this msg after i enter the coupon and click apply "Success: Your coupon discount has been applied!", and i also recive this in total.
Coupon (New2020): USD 0.00
Sub-Total: USD 180.00
Total: USD 180.00

i contacted Journal and they said this open cart issu, please contact them.
I switshed to opencart default theme and i have the same problem.

It was working in the test stage from long time ago, but when i start to be in need now, i faced this problem.

can any one help me please.

Regards,
Talal Ismail
talal_ez@hotmail.com

Newbie

Posts

Joined
Mon Apr 13, 2015 7:38 pm
Who is online

Users browsing this forum: No registered users and 23 guests